Merge pull request #700 from srdjantot/master

Raspberry Pi patch
This commit is contained in:
Kevin Mihelich 2014-01-31 05:12:52 -08:00
commit 20291c0d60
4 changed files with 52 additions and 64 deletions

View file

@ -30,7 +30,7 @@ pkgname=('qt5-base'
'qt5-x11extras'
'qt5-xmlpatterns')
pkgver=5.2.0
pkgrel=4
pkgrel=4.1
arch=('i686' 'x86_64')
url='http://qt-project.org/'
license=('GPL3' 'LGPL' 'FDL' 'custom')
@ -45,7 +45,7 @@ _pkgfqn="qt-everywhere-opensource-src-${pkgver}"
source=("http://download.qt-project.org/official_releases/qt/5.2/${pkgver}/single/${_pkgfqn}.tar.xz"
'assistant.desktop' 'designer.desktop' 'linguist.desktop' 'qdbusviewer.desktop'
'use-python2.patch'
'deppath_gnu.patch' 'rpi.patch' 'undef_B0.patch'
'rpi.patch'
'qt5webkit-0002-Fix-QtWebKit-build-on-ARM-softfp.patch')
md5sums=('8f60b47ca9461831d940f579ee90517e'
'b2897dd6a2967bccf8f10e397aafee55'
@ -53,9 +53,7 @@ md5sums=('8f60b47ca9461831d940f579ee90517e'
'188da8f4c87316e730ebf1c6217bf5a0'
'322b419b16c75d4de0ee7ad0a246caa1'
'a378deccf363bd6079da459c89aff7b9'
'21e4389ed0dd9c37e7cb48712d3bff91'
'3f8d2f8fb4e5715f7ce79950fac3c31f'
'8a9ba2d990d8840a2114fcffb9f9d2a4'
'd7992d2309194c42a7d47b86010d13d7'
'd9eb94a6cf4f178a7d77d6b8a9280ee2')
prepare() {
@ -69,13 +67,13 @@ prepare() {
cd ..
# Raspberry Pi
# if [ "$CARCH" == 'armv6h' ]; then
# patch -p1 -i "${srcdir}"/deppath_gnu.patch
# patch -p1 -i "${srcdir}"/rpi.patch
# patch -p1 -i "${srcdir}"/undef_B0.patch
# rbp_config="-device linux-rasp-pi-g++ -eglfs"
# export CXXFLAGS=${CXXFLAGS}" -I/opt/vc/include -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux"
# fi
if [ "$CARCH" == 'armv6h' ]; then
cd qtbase
patch -p1 -i "${srcdir}"/rpi.patch
cd ..
rbp_config="-device linux-rasp-pi-g++ -eglfs"
export CXXFLAGS=${CXXFLAGS}" -I/opt/vc/include -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux"
fi
sed -i "s|-O2|${CXXFLAGS}|" qtbase/mkspecs/common/{g++,gcc}-base.conf
sed -i "/^QMAKE_LFLAGS_RPATH/s| -Wl,-rpath,||g" qtbase/mkspecs/common/gcc-base-unix.conf

View file

@ -1,12 +0,0 @@
diff -urN a/qtbase/mkspecs/features/qt_functions.prf b/qtbase/mkspecs/features/qt_functions.prf
--- a/qtbase/mkspecs/features/qt_functions.prf 2013-07-02 01:09:32.000000000 -0600
+++ b/qtbase/mkspecs/features/qt_functions.prf 2013-07-06 14:32:15.335100188 -0600
@@ -256,7 +256,7 @@
}
equals(QMAKE_HOST.os, Windows) {
deppath.name = PATH
- } else:contains(QMAKE_HOST.os, Linux|FreeBSD) {
+ } else:contains(QMAKE_HOST.os, Linux|FreeBSD|GNU) {
deppath.name = LD_LIBRARY_PATH
} else:equals(QMAKE_HOST.os, Darwin) {
contains(QT_CONFIG, qt_framework): \

View file

@ -1,7 +1,21 @@
diff -urN a/qtbase/configure b/qtbase/configure
--- a/qtbase/configure 2013-07-02 01:09:32.000000000 -0600
+++ b/qtbase/configure 2013-07-06 14:25:04.356963083 -0600
@@ -2725,11 +2725,6 @@
--- a/src/gui/Qt5GuiConfigExtras.cmake.in
+++ b/src/gui/Qt5GuiConfigExtras.cmake.in
@@ -96,12 +96,10 @@
string(REGEX REPLACE "[^_A-Za-z0-9]" "_" _cmake_lib_name ${_lib})
if (NOT TARGET Qt5::Gui_${_cmake_lib_name})
find_library(Qt5Gui_${_cmake_lib_name}_LIBRARY ${_lib}
-!!IF !isEmpty(CROSS_COMPILE)
PATHS \"${LibDir}\"
!!IF !mac
NO_DEFAULT_PATH
!!ENDIF
-!!ENDIF
)
!!IF mac
set(Qt5Gui_${_cmake_lib_name}_LIBRARY "${Qt5Gui_${_cmake_lib_name}_LIBRARY}/${_lib}")
--- a/configure
+++ b/configure
@@ -3206,11 +3206,6 @@
else
XQMAKESPEC="$relpath/mkspecs/${XPLATFORM}"
fi
@ -13,7 +27,7 @@ diff -urN a/qtbase/configure b/qtbase/configure
if [ "$BUILD_ON_MAC" = "yes" ]; then
if [ `basename $QMAKESPEC` = "macx-xcode" ] || [ `basename $XQMAKESPEC` = "macx-xcode" ]; then
@@ -2997,11 +2992,6 @@
@@ -3538,11 +3533,6 @@
if [ "$CFG_DEV" = "yes" ]; then
CFG_BUILD_PARTS="$CFG_BUILD_PARTS tests"
fi
@ -25,33 +39,21 @@ diff -urN a/qtbase/configure b/qtbase/configure
fi
for nobuild in $CFG_NOBUILD_PARTS; do
CFG_BUILD_PARTS=`echo "$CFG_BUILD_PARTS" | sed "s, $nobuild,,g"`
diff -urN a/qtbase/mkspecs/devices/common/linux_device_post.conf b/qtbase/mkspecs/devices/common/linux_device_post.conf
--- a/qtbase/mkspecs/devices/common/linux_device_post.conf 2013-07-02 01:09:32.000000000 -0600
+++ b/qtbase/mkspecs/devices/common/linux_device_post.conf 2013-07-06 14:25:04.356963083 -0600
@@ -1,15 +1,3 @@
-contains(DISTRO_OPTS, deb-multi-arch) {
- QMAKE_LFLAGS += -Wl,-rpath-link,$$[QT_SYSROOT]/usr/lib/$${GCC_MACHINE_DUMP} \
- -Wl,-rpath-link,$$[QT_SYSROOT]/lib/$${GCC_MACHINE_DUMP}
-}
-
-contains(DISTRO_OPTS, hard-float) {
- COMPILER_FLAGS += -mfloat-abi=hard
-} else {
- COMPILER_FLAGS += -mfloat-abi=softfp
-}
-
--- a/mkspecs/devices/common/linux_device_post.conf
+++ b/mkspecs/devices/common/linux_device_post.conf
@@ -6,4 +6,3 @@
QMAKE_CFLAGS += $$COMPILER_FLAGS
QMAKE_CXXFLAGS += $$COMPILER_FLAGS
-deviceSanityCheckCompiler()
diff -urN a/qtbase/mkspecs/devices/common/linux_device_pre.conf b/qtbase/mkspecs/devices/common/linux_device_pre.conf
--- a/qtbase/mkspecs/devices/common/linux_device_pre.conf 2013-07-02 01:09:32.000000000 -0600
+++ b/qtbase/mkspecs/devices/common/linux_device_pre.conf 2013-07-06 14:25:04.356963083 -0600
@@ -11,14 +11,3 @@
!load(device_config) {
diff --git a/mkspecs/devices/common/linux_device_pre.conf b/mkspecs/devices/common/linux_device_pre.conf
index 51f04d9..4794b1e 100644
--- a/mkspecs/devices/common/linux_device_pre.conf
+++ b/mkspecs/devices/common/linux_device_pre.conf
@@ -12,14 +12,3 @@
error(Could not successfully load device configuration)
}
-
-# modifications to g++-unix.conf
-QMAKE_CC = $${CROSS_COMPILE}gcc
-QMAKE_CXX = $${CROSS_COMPILE}g++
@ -61,4 +63,18 @@ diff -urN a/qtbase/mkspecs/devices/common/linux_device_pre.conf b/qtbase/mkspecs
-# modifications to linux.conf
-QMAKE_AR = $${CROSS_COMPILE}ar cqs
-QMAKE_OBJCOPY = $${CROSS_COMPILE}objcopy
-QMAKE_NM = $${CROSS_COMPILE}nm -P
-QMAKE_STRIP = $${CROSS_COMPILE}strip
--- a/mkspecs/devices/linux-rasp-pi-g++/qmake.conf
+++ b/mkspecs/devices/linux-rasp-pi-g++/qmake.conf
@@ -18,6 +18,10 @@
QMAKE_LIBS_EGL = -lEGL -lGLESv2
+QMAKE_INCDIR_OPENVG = $$[QT_SYSROOT]/opt/vc/include
+QMAKE_LIBDIR_OPENVG = $$[QT_SYSROOT]/opt/vc/lib
+QMAKE_LIBS_OPENVG = -lOpenVG -lGLESv2
+
contains(DISTRO, squeeze) {
#Debian Squeeze: Legacy everything
QMAKE_LIBS_OPENGL_ES2 = -lGLESv2 -lEGL

View file

@ -1,14 +0,0 @@
diff -urN a/qtbase/src/gui/painting/qpagedpaintdevice.h b/qtbase/src/gui/painting/qpagedpaintdevice.h
--- a/qtbase/src/gui/painting/qpagedpaintdevice.h 2013-07-02 01:09:54.000000000 -0600
+++ b/qtbase/src/gui/painting/qpagedpaintdevice.h 2013-07-06 14:30:35.874606990 -0600
@@ -44,6 +44,10 @@
#include <QtGui/qpaintdevice.h>
+#if defined(B0)
+#undef B0 // Terminal hang-up. We assume that you do not want that.
+#endif
+
QT_BEGIN_NAMESPACE
#if defined(B0)