mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
Update linux-sun7i to 3.4.79
Adds support for cubietruck. Changes source to http://github.com/linux-sunxi/linux-sunxi * nfs doesn't seem to work yet * neither does wifi
This commit is contained in:
parent
496e2a8ccd
commit
20508ec55f
5 changed files with 39620 additions and 356 deletions
|
@ -4,35 +4,34 @@
|
||||||
buildarch=4
|
buildarch=4
|
||||||
|
|
||||||
pkgbase=linux-sun7i
|
pkgbase=linux-sun7i
|
||||||
_commit=e906c090ca17ed30ed0e826df3c4d095e5f5c865
|
_commit=8ea347bcb4b4a5e50ec0343afac579e933ce8402
|
||||||
_srcname=linux-sunxi-${_commit}
|
_srcname=linux-sunxi-${_commit}
|
||||||
_kernelname=${pkgbase#linux}
|
_kernelname=${pkgbase#linux}
|
||||||
_desc="sun7i"
|
_desc="sun7i"
|
||||||
pkgver=3.3.0
|
pkgver=3.4.79
|
||||||
pkgrel=10
|
pkgrel=1
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
url="https://github.com/cubieboard2/linux-sunxi"
|
url="https://github.com/linux-sunxi/linux-sunxi/"
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'uboot-mkimage')
|
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'uboot-mkimage')
|
||||||
options=('!strip')
|
options=('!strip')
|
||||||
source=("https://github.com/cubieboard2/linux-sunxi/archive/${_commit}.tar.gz"
|
source=("https://github.com/linux-sunxi/linux-sunxi/archive/${_commit}.tar.gz"
|
||||||
"memset.patch"
|
'config'
|
||||||
'config')
|
'working-bcmdhd-driver.patch')
|
||||||
md5sums=('7fa48cc5b9d8917601aa1f95818a6a08'
|
md5sums=('a6f18158a7f8dcb552547ea958c24c6b'
|
||||||
'39be2896f0b968d61a19b33da75ce6e0'
|
'2f846d0509ed554324f966b2291cef10'
|
||||||
'222d7ed0f04d1095cc4e650e9c28bdec')
|
'07c260ca97572a830778362c7b744f9c')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "${srcdir}/${_srcname}"
|
cd "${srcdir}/${_srcname}"
|
||||||
|
|
||||||
cat "${srcdir}/config" > ./.config
|
cat "${srcdir}/config" > ./.config
|
||||||
|
|
||||||
# memset fix for GCC 4.8
|
# patch bcmdhd driver with a working version
|
||||||
patch -p1 -i ../memset.patch
|
patch -Np1 -i "${srcdir}/working-bcmdhd-driver.patch"
|
||||||
|
|
||||||
# add pkgrel to extraversion
|
# add pkgrel to extraversion
|
||||||
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
||||||
sed -ri "138c MODULE_LICENSE(\"GPL\");" arch/arm/mach-sun7i/rf/bt_pm.c
|
|
||||||
|
|
||||||
# don't run depmod on 'make install'. We'll do this ourselves in packaging
|
# don't run depmod on 'make install'. We'll do this ourselves in packaging
|
||||||
sed -i '2iexit 0' scripts/depmod.sh
|
sed -i '2iexit 0' scripts/depmod.sh
|
||||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -2,7 +2,7 @@
|
||||||
# arg 2: the old package version
|
# arg 2: the old package version
|
||||||
|
|
||||||
KERNEL_NAME=-sun7i
|
KERNEL_NAME=-sun7i
|
||||||
KERNEL_VERSION=3.3.0-3-ARCH
|
KERNEL_VERSION=3.4.79-1-ARCH
|
||||||
|
|
||||||
post_install () {
|
post_install () {
|
||||||
# updating module dependencies
|
# updating module dependencies
|
||||||
|
|
|
@ -1,204 +0,0 @@
|
||||||
--- a/arch/arm/lib/memset.S
|
|
||||||
+++ b/arch/arm/lib/memset.S
|
|
||||||
@@ -19,9 +19,9 @@
|
|
||||||
1: subs r2, r2, #4 @ 1 do we have enough
|
|
||||||
blt 5f @ 1 bytes to align with?
|
|
||||||
cmp r3, #2 @ 1
|
|
||||||
- strltb r1, [r0], #1 @ 1
|
|
||||||
- strleb r1, [r0], #1 @ 1
|
|
||||||
- strb r1, [r0], #1 @ 1
|
|
||||||
+ strltb r1, [ip], #1 @ 1
|
|
||||||
+ strleb r1, [ip], #1 @ 1
|
|
||||||
+ strb r1, [ip], #1 @ 1
|
|
||||||
add r2, r2, r3 @ 1 (r2 = r2 - (4 - r3))
|
|
||||||
/*
|
|
||||||
* The pointer is now aligned and the length is adjusted. Try doing the
|
|
||||||
@@ -29,10 +29,14 @@
|
|
||||||
*/
|
|
||||||
|
|
||||||
ENTRY(memset)
|
|
||||||
- ands r3, r0, #3 @ 1 unaligned?
|
|
||||||
+/*
|
|
||||||
+ * Preserve the contents of r0 for the return value.
|
|
||||||
+ */
|
|
||||||
+ mov ip, r0
|
|
||||||
+ ands r3, ip, #3 @ 1 unaligned?
|
|
||||||
bne 1b @ 1
|
|
||||||
/*
|
|
||||||
- * we know that the pointer in r0 is aligned to a word boundary.
|
|
||||||
+ * we know that the pointer in ip is aligned to a word boundary.
|
|
||||||
*/
|
|
||||||
orr r1, r1, r1, lsl #8
|
|
||||||
orr r1, r1, r1, lsl #16
|
|
||||||
@@ -43,29 +47,28 @@ ENTRY(memset)
|
|
||||||
#if ! CALGN(1)+0
|
|
||||||
|
|
||||||
/*
|
|
||||||
- * We need an extra register for this loop - save the return address and
|
|
||||||
- * use the LR
|
|
||||||
+ * We need 2 extra registers for this loop - use r8 and the LR
|
|
||||||
*/
|
|
||||||
- str lr, [sp, #-4]!
|
|
||||||
- mov ip, r1
|
|
||||||
+ stmfd sp!, {r8, lr}
|
|
||||||
+ mov r8, r1
|
|
||||||
mov lr, r1
|
|
||||||
|
|
||||||
2: subs r2, r2, #64
|
|
||||||
- stmgeia r0!, {r1, r3, ip, lr} @ 64 bytes at a time.
|
|
||||||
- stmgeia r0!, {r1, r3, ip, lr}
|
|
||||||
- stmgeia r0!, {r1, r3, ip, lr}
|
|
||||||
- stmgeia r0!, {r1, r3, ip, lr}
|
|
||||||
+ stmgeia ip!, {r1, r3, r8, lr} @ 64 bytes at a time.
|
|
||||||
+ stmgeia ip!, {r1, r3, r8, lr}
|
|
||||||
+ stmgeia ip!, {r1, r3, r8, lr}
|
|
||||||
+ stmgeia ip!, {r1, r3, r8, lr}
|
|
||||||
bgt 2b
|
|
||||||
- ldmeqfd sp!, {pc} @ Now <64 bytes to go.
|
|
||||||
+ ldmeqfd sp!, {r8, pc} @ Now <64 bytes to go.
|
|
||||||
/*
|
|
||||||
* No need to correct the count; we're only testing bits from now on
|
|
||||||
*/
|
|
||||||
tst r2, #32
|
|
||||||
- stmneia r0!, {r1, r3, ip, lr}
|
|
||||||
- stmneia r0!, {r1, r3, ip, lr}
|
|
||||||
+ stmneia ip!, {r1, r3, r8, lr}
|
|
||||||
+ stmneia ip!, {r1, r3, r8, lr}
|
|
||||||
tst r2, #16
|
|
||||||
- stmneia r0!, {r1, r3, ip, lr}
|
|
||||||
- ldr lr, [sp], #4
|
|
||||||
+ stmneia ip!, {r1, r3, r8, lr}
|
|
||||||
+ ldmfd sp!, {r8, lr}
|
|
||||||
|
|
||||||
#else
|
|
||||||
|
|
||||||
@@ -74,54 +77,54 @@ ENTRY(memset)
|
|
||||||
* whole cache lines at once.
|
|
||||||
*/
|
|
||||||
|
|
||||||
- stmfd sp!, {r4-r7, lr}
|
|
||||||
+ stmfd sp!, {r4-r8, lr}
|
|
||||||
mov r4, r1
|
|
||||||
mov r5, r1
|
|
||||||
mov r6, r1
|
|
||||||
mov r7, r1
|
|
||||||
- mov ip, r1
|
|
||||||
+ mov r8, r1
|
|
||||||
mov lr, r1
|
|
||||||
|
|
||||||
cmp r2, #96
|
|
||||||
- tstgt r0, #31
|
|
||||||
+ tstgt ip, #31
|
|
||||||
ble 3f
|
|
||||||
|
|
||||||
- and ip, r0, #31
|
|
||||||
- rsb ip, ip, #32
|
|
||||||
- sub r2, r2, ip
|
|
||||||
- movs ip, ip, lsl #(32 - 4)
|
|
||||||
- stmcsia r0!, {r4, r5, r6, r7}
|
|
||||||
- stmmiia r0!, {r4, r5}
|
|
||||||
- tst ip, #(1 << 30)
|
|
||||||
- mov ip, r1
|
|
||||||
- strne r1, [r0], #4
|
|
||||||
+ and r8, ip, #31
|
|
||||||
+ rsb r8, r8, #32
|
|
||||||
+ sub r2, r2, r8
|
|
||||||
+ movs r8, r8, lsl #(32 - 4)
|
|
||||||
+ stmcsia ip!, {r4, r5, r6, r7}
|
|
||||||
+ stmmiia ip!, {r4, r5}
|
|
||||||
+ tst r8, #(1 << 30)
|
|
||||||
+ mov r8, r1
|
|
||||||
+ strne r1, [ip], #4
|
|
||||||
|
|
||||||
3: subs r2, r2, #64
|
|
||||||
- stmgeia r0!, {r1, r3-r7, ip, lr}
|
|
||||||
- stmgeia r0!, {r1, r3-r7, ip, lr}
|
|
||||||
+ stmgeia ip!, {r1, r3-r8, lr}
|
|
||||||
+ stmgeia ip!, {r1, r3-r8, lr}
|
|
||||||
bgt 3b
|
|
||||||
- ldmeqfd sp!, {r4-r7, pc}
|
|
||||||
+ ldmeqfd sp!, {r4-r8, pc}
|
|
||||||
|
|
||||||
tst r2, #32
|
|
||||||
- stmneia r0!, {r1, r3-r7, ip, lr}
|
|
||||||
+ stmneia ip!, {r1, r3-r8, lr}
|
|
||||||
tst r2, #16
|
|
||||||
- stmneia r0!, {r4-r7}
|
|
||||||
- ldmfd sp!, {r4-r7, lr}
|
|
||||||
+ stmneia ip!, {r4-r7}
|
|
||||||
+ ldmfd sp!, {r4-r8, lr}
|
|
||||||
|
|
||||||
#endif
|
|
||||||
|
|
||||||
4: tst r2, #8
|
|
||||||
- stmneia r0!, {r1, r3}
|
|
||||||
+ stmneia ip!, {r1, r3}
|
|
||||||
tst r2, #4
|
|
||||||
- strne r1, [r0], #4
|
|
||||||
+ strne r1, [ip], #4
|
|
||||||
/*
|
|
||||||
* When we get here, we've got less than 4 bytes to zero. We
|
|
||||||
* may have an unaligned pointer as well.
|
|
||||||
*/
|
|
||||||
5: tst r2, #2
|
|
||||||
- strneb r1, [r0], #1
|
|
||||||
- strneb r1, [r0], #1
|
|
||||||
+ strneb r1, [ip], #1
|
|
||||||
+ strneb r1, [ip], #1
|
|
||||||
tst r2, #1
|
|
||||||
- strneb r1, [r0], #1
|
|
||||||
+ strneb r1, [ip], #1
|
|
||||||
mov pc, lr
|
|
||||||
ENDPROC(memset)
|
|
||||||
--- a/arch/arm/lib/memset.S
|
|
||||||
+++ b/arch/arm/lib/memset.S
|
|
||||||
@@ -14,31 +14,15 @@
|
|
||||||
|
|
||||||
.text
|
|
||||||
.align 5
|
|
||||||
- .word 0
|
|
||||||
-
|
|
||||||
-1: subs r2, r2, #4 @ 1 do we have enough
|
|
||||||
- blt 5f @ 1 bytes to align with?
|
|
||||||
- cmp r3, #2 @ 1
|
|
||||||
- strltb r1, [ip], #1 @ 1
|
|
||||||
- strleb r1, [ip], #1 @ 1
|
|
||||||
- strb r1, [ip], #1 @ 1
|
|
||||||
- add r2, r2, r3 @ 1 (r2 = r2 - (4 - r3))
|
|
||||||
-/*
|
|
||||||
- * The pointer is now aligned and the length is adjusted. Try doing the
|
|
||||||
- * memset again.
|
|
||||||
- */
|
|
||||||
|
|
||||||
ENTRY(memset)
|
|
||||||
-/*
|
|
||||||
- * Preserve the contents of r0 for the return value.
|
|
||||||
- */
|
|
||||||
- mov ip, r0
|
|
||||||
- ands r3, ip, #3 @ 1 unaligned?
|
|
||||||
- bne 1b @ 1
|
|
||||||
+ ands r3, r0, #3 @ 1 unaligned?
|
|
||||||
+ mov ip, r0 @ preserve r0 as return value
|
|
||||||
+ bne 6f @ 1
|
|
||||||
/*
|
|
||||||
* we know that the pointer in ip is aligned to a word boundary.
|
|
||||||
*/
|
|
||||||
- orr r1, r1, r1, lsl #8
|
|
||||||
+1: orr r1, r1, r1, lsl #8
|
|
||||||
orr r1, r1, r1, lsl #16
|
|
||||||
mov r3, r1
|
|
||||||
cmp r2, #16
|
|
||||||
@@ -127,4 +111,13 @@ ENTRY(memset)
|
|
||||||
tst r2, #1
|
|
||||||
strneb r1, [ip], #1
|
|
||||||
mov pc, lr
|
|
||||||
+
|
|
||||||
+6: subs r2, r2, #4 @ 1 do we have enough
|
|
||||||
+ blt 5b @ 1 bytes to align with?
|
|
||||||
+ cmp r3, #2 @ 1
|
|
||||||
+ strltb r1, [ip], #1 @ 1
|
|
||||||
+ strleb r1, [ip], #1 @ 1
|
|
||||||
+ strb r1, [ip], #1 @ 1
|
|
||||||
+ add r2, r2, r3 @ 1 (r2 = r2 - (4 - r3))
|
|
||||||
+ b 1b
|
|
||||||
ENDPROC(memset)
|
|
39416
core/linux-sun7i/working-bcmdhd-driver.patch
Normal file
39416
core/linux-sun7i/working-bcmdhd-driver.patch
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue