mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/gstreamer0.10-bad to 0.10.23-18
This commit is contained in:
parent
554e5156ed
commit
205e1fbefe
2 changed files with 26 additions and 5 deletions
|
@ -1,4 +1,4 @@
|
|||
# $Id: PKGBUILD 184389 2013-05-06 19:37:43Z foutrelis $
|
||||
# $Id$
|
||||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
@ -7,22 +7,26 @@
|
|||
pkgbase=gstreamer0.10-bad
|
||||
pkgname=('gstreamer0.10-bad' 'gstreamer0.10-bad-plugins')
|
||||
pkgver=0.10.23
|
||||
pkgrel=17
|
||||
pkgrel=18
|
||||
arch=('i686' 'x86_64')
|
||||
license=('LGPL' 'GPL')
|
||||
makedepends=('pkgconfig' 'gstreamer0.10-base>=0.10.36' 'xvidcore' 'libdca' 'bzip2' 'libdc1394' 'neon' 'faac' 'musicbrainz' 'faad2' 'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa' 'soundtouch' 'libvdpau' 'schroedinger' 'libass' 'libvpx' 'gsm' 'libgme' 'rtmpdump' 'libsndfile' 'librsvg' 'wildmidi' 'opus' 'git' 'spandsp' 'celt')
|
||||
url="http://gstreamer.freedesktop.org/"
|
||||
options=(!libtool !emptydirs)
|
||||
options=(!emptydirs)
|
||||
source=("git://anongit.freedesktop.org/gstreamer-sdk/gst-plugins-bad#commit=57569a4854a0f2d14ef19a8264a4ae9a7a1d1125"
|
||||
fix-libmodplug-include.patch
|
||||
drop-vpx-compat-defs.patch
|
||||
disable-assrender-test.patch
|
||||
disable-camerabin-test.patch
|
||||
faad2-version-check.patch)
|
||||
faad2-version-check.patch
|
||||
wildmidi-0.4.patch)
|
||||
sha256sums=('SKIP'
|
||||
'd89d8f4307c7d5a143b9240467d260a1cb6bb1ab2e7ca57841ce0901f41c9cb7'
|
||||
'eb97037b7b581d1ab994eadd144044c083975e5670a73ec827de126bf888f4b9'
|
||||
'e66642affa6c0e69837d37615010e67e59ef3d672663303d46c1e2591e2ddfc6'
|
||||
'01e780ddf1f8161a6115dded9dc5bf4bdd4d09a9eee00fa423b1330e90e76c68'
|
||||
'741492ae7a9518603fc51d87ae331d882f075547ea7fdec19c60f399085f18cc')
|
||||
'741492ae7a9518603fc51d87ae331d882f075547ea7fdec19c60f399085f18cc'
|
||||
'7a8698df3b53c34c627c00d3b025045818898cedc5ee7ffa13272d8758fcefd2')
|
||||
|
||||
prepare() {
|
||||
cd gst-plugins-bad
|
||||
|
@ -32,6 +36,7 @@ prepare() {
|
|||
patch -Np1 -i ../disable-assrender-test.patch
|
||||
patch -Np1 -i ../disable-camerabin-test.patch
|
||||
patch -Np1 -i ../faad2-version-check.patch
|
||||
patch -Np1 -i ../wildmidi-0.4.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
16
extra/gstreamer0.10-bad/wildmidi-0.4.patch
Normal file
16
extra/gstreamer0.10-bad/wildmidi-0.4.patch
Normal file
|
@ -0,0 +1,16 @@
|
|||
Old versions used char* for the data, new versions use int8_t*. They're often
|
||||
not the same and differ in signedness.
|
||||
|
||||
(backported from 04199db2aeea966c2c879b1764427c87433570f1)
|
||||
|
||||
--- a/ext/timidity/gstwildmidi.c
|
||||
+++ b/ext/timidity/gstwildmidi.c
|
||||
@@ -631,7 +631,7 @@
|
||||
size = GST_BUFFER_SIZE (buffer);
|
||||
|
||||
GST_OBJECT_LOCK (wildmidi);
|
||||
- bytes_read = WildMidi_GetOutput (wildmidi->song, (char *) data,
|
||||
+ bytes_read = WildMidi_GetOutput (wildmidi->song, (gpointer *) data,
|
||||
(unsigned long int) size);
|
||||
GST_OBJECT_UNLOCK (wildmidi);
|
||||
|
Loading…
Reference in a new issue