mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added community/zathura
This commit is contained in:
parent
9d6fb96d95
commit
2069f2eaef
4 changed files with 103 additions and 0 deletions
50
community/zathura/PKGBUILD
Normal file
50
community/zathura/PKGBUILD
Normal file
|
@ -0,0 +1,50 @@
|
|||
# $Id$
|
||||
# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
|
||||
# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
|
||||
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
|
||||
# Contributor: ML <neldoreth>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix FTBFS on ARM
|
||||
|
||||
pkgname=zathura
|
||||
pkgver=0.3.6
|
||||
pkgrel=1
|
||||
|
||||
pkgdesc="Minimalistic document viewer"
|
||||
url="http://pwmt.org/projects/zathura/"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('custom')
|
||||
|
||||
depends=('girara>=0.2.4' 'sqlite' 'desktop-file-utils' 'file' 'libsynctex')
|
||||
makedepends=('python2-docutils' 'texlive-bin')
|
||||
optdepends=('zathura-djvu: DjVu support'
|
||||
'zathura-pdf-poppler: PDF support using Poppler'
|
||||
'zathura-pdf-mupdf: PDF support using MuPDF'
|
||||
'zathura-ps: PostScript support')
|
||||
|
||||
install=zathura.install
|
||||
source=(http://pwmt.org/projects/zathura/download/zathura-$pkgver.tar.gz
|
||||
bash-completion
|
||||
makefile.patch)
|
||||
|
||||
sha1sums=('db5e76815fdfd0c2d6b5d5c16492995720268440'
|
||||
'94a8236c483626a7f3acee053a1ea885aed45a82'
|
||||
'be57203c6709951635981936d0a7907db5672663')
|
||||
|
||||
prepare() {
|
||||
patch -p1 -d zathura-$pkgver -i ../makefile.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd zathura-$pkgver
|
||||
make WITH_SYNCTEX=1
|
||||
}
|
||||
|
||||
package() {
|
||||
cd zathura-$pkgver
|
||||
|
||||
make install DESTDIR="$pkgdir"
|
||||
install -D -m664 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
|
||||
install -Dm0644 "$srcdir"/bash-completion "$pkgdir"/usr/share/bash-completion/completions/zathura
|
||||
}
|
29
community/zathura/bash-completion
Normal file
29
community/zathura/bash-completion
Normal file
|
@ -0,0 +1,29 @@
|
|||
_zathura() {
|
||||
_init_completion || return
|
||||
|
||||
EXTENTIONS=''
|
||||
for PLUGIN in /usr/lib/zathura/*.so; do
|
||||
case ${PLUGIN##*/} in
|
||||
pdf.so)
|
||||
EXTENTIONS="$EXTENTIONS|pdf"
|
||||
;;
|
||||
ps.so)
|
||||
EXTENTIONS="$EXTENTIONS|ps|eps|epsi|epsf"
|
||||
;;
|
||||
djvu.so)
|
||||
EXTENTIONS="$EXTENTIONS|djvu|djv"
|
||||
;;
|
||||
epub.so)
|
||||
EXTENTIONS="$EXTENTIONS|epub"
|
||||
;;
|
||||
cb.so)
|
||||
EXTENTIONS="$EXTENTIONS|cb7|cbr|cbz|cbt|rar|zip|7z|tar"
|
||||
;;
|
||||
*)
|
||||
;;
|
||||
esac
|
||||
done
|
||||
|
||||
_filedir "${EXTENTIONS#|}"
|
||||
} &&
|
||||
complete -F _zathura zathura
|
12
community/zathura/makefile.patch
Normal file
12
community/zathura/makefile.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -urN a/Makefile b/Makefile
|
||||
--- a/Makefile 2016-03-08 13:48:07.000000000 -0700
|
||||
+++ b/Makefile 2016-04-19 19:03:42.200343001 -0600
|
||||
@@ -288,7 +288,7 @@
|
||||
$(QUIET)rm -f $(DESTDIR)$(APPDATAPREFIX)/$(PROJECT).appdata.xml
|
||||
$(MAKE) -C po uninstall
|
||||
|
||||
-DEPENDS = ${DEPENDDIRS:^=${DEPENDDIR}/}$(addprefix ${DEPENDDIR}/,${OBJECTS:.o=.o.dep})
|
||||
+DEPENDS = ${DEPENDDIRS:^=${DEPENDDIR}/}$(addprefix ${DEPENDDIR}/,${OBJECTS:.o=.dep})
|
||||
-include ${DEPENDS}
|
||||
|
||||
.PHONY: all options clean doc debug valgrind gdb dist doc install uninstall \
|
12
community/zathura/zathura.install
Normal file
12
community/zathura/zathura.install
Normal file
|
@ -0,0 +1,12 @@
|
|||
post_install() {
|
||||
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
Loading…
Reference in a new issue