removed community/zathura

This commit is contained in:
Kevin Mihelich 2018-03-24 16:06:35 +00:00
parent 48061f2c19
commit 208474fb22
3 changed files with 0 additions and 91 deletions

View file

@ -1,50 +0,0 @@
# $Id$
# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: ML <neldoreth>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix FTBFS on ARM
pkgname=zathura
pkgver=0.3.8
pkgrel=1
pkgdesc="Minimalistic document viewer"
url="http://pwmt.org/projects/zathura/"
arch=('x86_64')
license=('custom')
makedepends=('python2-docutils' 'texlive-bin')
depends=('girara>=0.2.7' 'sqlite' 'desktop-file-utils' 'file' 'libsynctex')
optdepends=('zathura-djvu: DjVu support'
'zathura-pdf-poppler: PDF support using Poppler'
'zathura-pdf-mupdf: PDF support using MuPDF'
'zathura-ps: PostScript support'
'zathura-cb: Comic book support')
source=(https://pwmt.org/projects/zathura/download/zathura-$pkgver.tar.gz
bash-completion
makefile.patch)
sha1sums=('f96df67bd12068af8ed14671877b1ebe64931241'
'94a8236c483626a7f3acee053a1ea885aed45a82'
'be57203c6709951635981936d0a7907db5672663')
prepare() {
patch -p1 -d zathura-$pkgver -i ../makefile.patch
}
build() {
cd zathura-$pkgver
make WITH_SYNCTEX=1
}
package() {
cd zathura-$pkgver
make install DESTDIR="$pkgdir"
install -D -m664 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
install -Dm0644 "$srcdir"/bash-completion "$pkgdir"/usr/share/bash-completion/completions/zathura
}

View file

@ -1,29 +0,0 @@
_zathura() {
_init_completion || return
EXTENTIONS=''
for PLUGIN in /usr/lib/zathura/*.so; do
case ${PLUGIN##*/} in
pdf.so)
EXTENTIONS="$EXTENTIONS|pdf"
;;
ps.so)
EXTENTIONS="$EXTENTIONS|ps|eps|epsi|epsf"
;;
djvu.so)
EXTENTIONS="$EXTENTIONS|djvu|djv"
;;
epub.so)
EXTENTIONS="$EXTENTIONS|epub"
;;
cb.so)
EXTENTIONS="$EXTENTIONS|cb7|cbr|cbz|cbt|rar|zip|7z|tar"
;;
*)
;;
esac
done
_filedir "${EXTENTIONS#|}"
} &&
complete -F _zathura zathura

View file

@ -1,12 +0,0 @@
diff -urN a/Makefile b/Makefile
--- a/Makefile 2016-03-08 13:48:07.000000000 -0700
+++ b/Makefile 2016-04-19 19:03:42.200343001 -0600
@@ -288,7 +288,7 @@
$(QUIET)rm -f $(DESTDIR)$(APPDATAPREFIX)/$(PROJECT).appdata.xml
$(MAKE) -C po uninstall
-DEPENDS = ${DEPENDDIRS:^=${DEPENDDIR}/}$(addprefix ${DEPENDDIR}/,${OBJECTS:.o=.o.dep})
+DEPENDS = ${DEPENDDIRS:^=${DEPENDDIR}/}$(addprefix ${DEPENDDIR}/,${OBJECTS:.o=.dep})
-include ${DEPENDS}
.PHONY: all options clean doc debug valgrind gdb dist doc install uninstall \