mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/rust to 1.73.0-1
This commit is contained in:
parent
c54d646941
commit
2099d6b816
6 changed files with 97 additions and 53 deletions
78
extra/rust/.SRCINFO
Normal file
78
extra/rust/.SRCINFO
Normal file
|
@ -0,0 +1,78 @@
|
|||
pkgbase = rust
|
||||
pkgdesc = Systems programming language focused on safety, speed and concurrency
|
||||
pkgver = 1.73.0
|
||||
pkgrel = 1
|
||||
epoch = 1
|
||||
url = https://www.rust-lang.org/
|
||||
arch = x86_64
|
||||
license = Apache
|
||||
license = MIT
|
||||
checkdepends = gdb
|
||||
checkdepends = procps-ng
|
||||
makedepends = cmake
|
||||
makedepends = lib32-gcc-libs
|
||||
makedepends = libffi
|
||||
makedepends = lld
|
||||
makedepends = llvm
|
||||
makedepends = musl
|
||||
makedepends = ninja
|
||||
makedepends = perl
|
||||
makedepends = python
|
||||
makedepends = rust
|
||||
makedepends = wasi-libc
|
||||
depends = curl
|
||||
depends = gcc
|
||||
depends = gcc-libs
|
||||
depends = libssh2
|
||||
depends = llvm-libs
|
||||
options = !debug
|
||||
options = !emptydirs
|
||||
options = !lto
|
||||
options = !strip
|
||||
source = https://static.rust-lang.org/dist/rustc-1.73.0-src.tar.gz
|
||||
source = https://static.rust-lang.org/dist/rustc-1.73.0-src.tar.gz.asc
|
||||
source = 0001-bootstrap-Change-libexec-dir.patch
|
||||
source = 0002-bootstrap-Change-bash-completion-dir.patch
|
||||
source = 0003-compiler-Change-LLVM-targets.patch
|
||||
source = 0004-compiler-Use-wasm-ld-for-wasm-targets.patch
|
||||
validpgpkeys = 108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE
|
||||
b2sums = d25823e433ce66d3148359deab7fcf5b6e6aecf832359cf3d7cec55e7f45163c981d396f6b772fa12393896a71e69c91cdfd01d633e2c05d641d0f1b2174e264
|
||||
b2sums = SKIP
|
||||
b2sums = ec4a0ab6f92cecc7c8ced752a379609089664cbce7e53264167c800df38b672c625f493458547b3d27c643d5c22b4e173115457cb7e441d27795bd930d6ad714
|
||||
b2sums = c8db828623b9bc2c9c34a4594f4c9409585c55815d0f3c0bf8b48ea2d3a01fe866c15850503ad5d3b6e04a6e68dd7e7f064d9745f4eb60a267fb90c7ad101d70
|
||||
b2sums = cd5a2a5e237a935c236dffc3b0bbf7d468b693f19b63f9d1959f7b13c1c0cc6ec21b717d4f2874d7e357b861e9664fba3c2d22aa2f7f6c932d71adde7b9ac531
|
||||
b2sums = e0acea294146ae14ec18ac1f99cb9113dfe0dbe87cfd557fb093b56fc15cf036ac076af905fbe358a11a913d2fc845619c5fd8e18ac97127c232127a28666117
|
||||
|
||||
pkgname = rust
|
||||
optdepends = gdb: rust-gdb script
|
||||
optdepends = lldb: rust-lldb script
|
||||
provides = cargo
|
||||
provides = rustfmt
|
||||
conflicts = cargo
|
||||
conflicts = rust-docs<1:1.56.1-3
|
||||
conflicts = rustfmt
|
||||
replaces = cargo
|
||||
replaces = cargo-tree
|
||||
replaces = rust-docs<1:1.56.1-3
|
||||
replaces = rustfmt
|
||||
|
||||
pkgname = lib32-rust-libs
|
||||
pkgdesc = 32-bit target and libraries for Rust
|
||||
depends = lib32-gcc-libs
|
||||
depends = rust
|
||||
provides = lib32-rust
|
||||
conflicts = lib32-rust
|
||||
replaces = lib32-rust
|
||||
|
||||
pkgname = rust-musl
|
||||
pkgdesc = Musl target for Rust
|
||||
depends = rust
|
||||
|
||||
pkgname = rust-wasm
|
||||
pkgdesc = WebAssembly targets for Rust
|
||||
depends = lld
|
||||
depends = rust
|
||||
|
||||
pkgname = rust-src
|
||||
pkgdesc = Source code for the Rust standard library
|
||||
depends = rust
|
|
@ -4,15 +4,15 @@ Date: Thu, 6 May 2021 20:14:58 +0200
|
|||
Subject: [PATCH] bootstrap: Change libexec dir
|
||||
|
||||
---
|
||||
src/bootstrap/dist.rs | 4 ++--
|
||||
src/bootstrap/dist.rs | 2 +-
|
||||
src/bootstrap/tool.rs | 2 +-
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
||||
index b34a4b2dc63b..be5ecfda261a 100644
|
||||
index 32da4ac29a46..78a5faeae04b 100644
|
||||
--- a/src/bootstrap/dist.rs
|
||||
+++ b/src/bootstrap/dist.rs
|
||||
@@ -420,7 +420,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) {
|
||||
@@ -423,7 +423,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) {
|
||||
},
|
||||
builder.kind,
|
||||
) {
|
||||
|
@ -21,20 +21,11 @@ index b34a4b2dc63b..be5ecfda261a 100644
|
|||
}
|
||||
|
||||
let libdir_relative = builder.libdir_relative(compiler);
|
||||
@@ -1081,7 +1081,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
|
||||
let dirent = dirent.expect("read dir entry");
|
||||
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
|
||||
- tarball.add_file(&dirent.path(), "libexec", 0o755);
|
||||
+ tarball.add_file(&dirent.path(), "lib", 0o755);
|
||||
}
|
||||
}
|
||||
|
||||
diff --git a/src/bootstrap/tool.rs b/src/bootstrap/tool.rs
|
||||
index 06c031788629..b7ca91a28157 100644
|
||||
index e6d27757ac66..70e499bdabbe 100644
|
||||
--- a/src/bootstrap/tool.rs
|
||||
+++ b/src/bootstrap/tool.rs
|
||||
@@ -719,7 +719,7 @@ fn run(self, builder: &Builder<'_>) -> Option<PathBuf> {
|
||||
@@ -689,7 +689,7 @@ fn run(self, builder: &Builder<'_>) -> Option<PathBuf> {
|
||||
|
||||
// Copy `rust-analyzer-proc-macro-srv` to `<sysroot>/libexec/`
|
||||
// so that r-a can use it.
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
|
||||
Date: Thu, 6 May 2021 20:13:31 +0200
|
||||
Subject: [PATCH] cargo: Change libexec dir
|
||||
|
||||
---
|
||||
src/cargo/util/auth/mod.rs | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/cargo/util/auth/mod.rs b/src/cargo/util/auth/mod.rs
|
||||
index 58309964f493..f621e1d643c4 100644
|
||||
--- a/src/cargo/util/auth/mod.rs
|
||||
+++ b/src/cargo/util/auth/mod.rs
|
||||
@@ -711,7 +711,7 @@ fn sysroot_credential(
|
||||
.parent()
|
||||
.and_then(|p| p.parent())
|
||||
.ok_or_else(|| format_err!("expected cargo path {}", cargo.display()))?;
|
||||
- let exe = root.join("libexec").join(format!(
|
||||
+ let exe = root.join("lib").join(format!(
|
||||
"cargo-credential-{}{}",
|
||||
cred_name,
|
||||
std::env::consts::EXE_SUFFIX
|
|
@ -8,10 +8,10 @@ Subject: [PATCH] bootstrap: Change bash-completion dir
|
|||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
||||
index be5ecfda261a..7ab950067eb4 100644
|
||||
index 78a5faeae04b..4f4e4e508619 100644
|
||||
--- a/src/bootstrap/dist.rs
|
||||
+++ b/src/bootstrap/dist.rs
|
||||
@@ -1074,7 +1074,11 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||
@@ -1079,7 +1079,11 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||
|
||||
tarball.add_file(&cargo, "bin", 0o755);
|
||||
tarball.add_file(etc.join("_cargo"), "share/zsh/site-functions", 0o644);
|
||||
|
|
|
@ -24,10 +24,10 @@ targets, as things break when this is done:
|
|||
4 files changed, 12 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
||||
index f97cb3440d25..e96a8749823a 100644
|
||||
index f00472f181d8..1aae877a275a 100644
|
||||
--- a/compiler/rustc_session/src/config.rs
|
||||
+++ b/compiler/rustc_session/src/config.rs
|
||||
@@ -2169,7 +2169,7 @@ pub fn parse_target_triple(
|
||||
@@ -2225,7 +2225,7 @@ pub fn parse_target_triple(
|
||||
handler.early_error(format!("target file {path:?} does not exist"))
|
||||
})
|
||||
}
|
||||
|
@ -50,10 +50,10 @@ index 73e536a7e4d9..af48d437533c 100644
|
|||
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
||||
f64:32:64-f80:32-n8:16:32-S128"
|
||||
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
||||
index 2365dfaf1af8..7e92928d214d 100644
|
||||
index 31b6961bb622..24e7b156b1c5 100644
|
||||
--- a/compiler/rustc_target/src/spec/mod.rs
|
||||
+++ b/compiler/rustc_target/src/spec/mod.rs
|
||||
@@ -3205,6 +3205,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
@@ -3254,6 +3254,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
Ok(TargetTriple::TargetJson { path_for_rustdoc: canonicalized_path, triple, contents })
|
||||
}
|
||||
|
||||
|
|
|
@ -20,7 +20,7 @@ pkgname=(
|
|||
rust-src
|
||||
)
|
||||
epoch=1
|
||||
pkgver=1.72.1
|
||||
pkgver=1.73.0
|
||||
pkgrel=1
|
||||
pkgdesc="Systems programming language focused on safety, speed and concurrency"
|
||||
url=https://www.rust-lang.org/
|
||||
|
@ -59,18 +59,16 @@ checkdepends=(
|
|||
)
|
||||
source=(
|
||||
"https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz"{,.asc}
|
||||
0001-cargo-Change-libexec-dir.patch
|
||||
0001-bootstrap-Change-libexec-dir.patch
|
||||
0002-bootstrap-Change-bash-completion-dir.patch
|
||||
0003-compiler-Change-LLVM-targets.patch
|
||||
0004-compiler-Use-wasm-ld-for-wasm-targets.patch
|
||||
)
|
||||
b2sums=('83d23b1d02679245a52fa8bdc35d7ff9bda1f187ab58630e3872fbba5d0a275d55e4074c0cf1366988fbfb201ff9ea4476a882ee218caa72e1043c67aa1d8231'
|
||||
b2sums=('d25823e433ce66d3148359deab7fcf5b6e6aecf832359cf3d7cec55e7f45163c981d396f6b772fa12393896a71e69c91cdfd01d633e2c05d641d0f1b2174e264'
|
||||
'SKIP'
|
||||
'c4bf40d48fd7ccb02c73fc02d5d968cfda80d1fd85c1ade4781d174bb4cb165b52998af4bf9495f2c04b0a25b147c13a5f3de4281d621353c9e799a67297a3fe'
|
||||
'0b079767043116d1e2c30ce66e82972266bc46a70b54884c0d41786c7f4271fdacb04611d34d4106a394db9df4b384b0138fa4f52c3076bfb3932d410f668b15'
|
||||
'f165abb36f03bb1ddcdca8e674244e51c7ce3a6b83e59b44d520e16e3735952cdd1c6da9edca51a755b343323f6f37c7ea7093708212300974e41560d15ee6ef'
|
||||
'5faa0c65de5186dd225afcb58d0d0b2fddf2f2a7008f7a7d84bf14e78a23dbf08ae04c016d3c8241359ec9eb286f5186a7ae84ce03446f37e56fc2667fa1c114'
|
||||
'ec4a0ab6f92cecc7c8ced752a379609089664cbce7e53264167c800df38b672c625f493458547b3d27c643d5c22b4e173115457cb7e441d27795bd930d6ad714'
|
||||
'c8db828623b9bc2c9c34a4594f4c9409585c55815d0f3c0bf8b48ea2d3a01fe866c15850503ad5d3b6e04a6e68dd7e7f064d9745f4eb60a267fb90c7ad101d70'
|
||||
'cd5a2a5e237a935c236dffc3b0bbf7d468b693f19b63f9d1959f7b13c1c0cc6ec21b717d4f2874d7e357b861e9664fba3c2d22aa2f7f6c932d71adde7b9ac531'
|
||||
'e0acea294146ae14ec18ac1f99cb9113dfe0dbe87cfd557fb093b56fc15cf036ac076af905fbe358a11a913d2fc845619c5fd8e18ac97127c232127a28666117')
|
||||
validpgpkeys=(
|
||||
108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||
|
@ -79,9 +77,8 @@ validpgpkeys=(
|
|||
prepare() {
|
||||
cd rustc-$pkgver-src
|
||||
|
||||
# Patch bootstrap and cargo so credential helpers
|
||||
# are in /usr/lib instead of /usr/libexec
|
||||
patch -d src/tools/cargo -Np1 < ../0001-cargo-Change-libexec-dir.patch
|
||||
# Patch bootstrap so that rust-analyzer-proc-macro-srv
|
||||
# is in /usr/lib instead of /usr/libexec
|
||||
patch -Np1 -i ../0001-bootstrap-Change-libexec-dir.patch
|
||||
|
||||
# Put bash completions where they belong
|
||||
|
|
Loading…
Reference in a new issue