mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/sbc to 1.5-1
This commit is contained in:
parent
71220a368a
commit
20f367f389
3 changed files with 57 additions and 13 deletions
|
@ -1,7 +1,7 @@
|
|||
From e460c51017a7d1e04511ea4d293296a3d422049a Mon Sep 17 00:00:00 2001
|
||||
From fc950fbd3e4a1bb53825576678e0e3828ac2e08e Mon Sep 17 00:00:00 2001
|
||||
From: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
|
||||
Date: Mon, 3 Apr 2017 01:42:26 +0900
|
||||
Subject: [PATCH] Add config.h in sbc/sbc_primitives.h
|
||||
Subject: [PATCH 1/2] Add config.h in sbc/sbc_primitives.h
|
||||
|
||||
When we use "--enable-high-precision" option of configure, this does not work
|
||||
effectively. Because SBC_HIGH_PRECISION enabled by this option is not available
|
||||
|
@ -29,5 +29,5 @@ index e01c957..b060484 100644
|
|||
#define SBC_X_BUFFER_SIZE 328
|
||||
|
||||
--
|
||||
2.11.0
|
||||
2.28.0
|
||||
|
||||
|
|
27
extra/sbc/0002-Fix-build-on-ARM.patch
Normal file
27
extra/sbc/0002-Fix-build-on-ARM.patch
Normal file
|
@ -0,0 +1,27 @@
|
|||
From 10e4085d20a15d82f2a72c179e240b102041a531 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 8 Dec 2020 15:16:27 -0700
|
||||
Subject: [PATCH 2/2] Fix build on ARM
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
sbc/sbc_primitives.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/sbc/sbc_primitives.c b/sbc/sbc_primitives.c
|
||||
index 97a75be..653ad3f 100644
|
||||
--- a/sbc/sbc_primitives.c
|
||||
+++ b/sbc/sbc_primitives.c
|
||||
@@ -630,7 +630,9 @@ void sbc_init_primitives(struct sbc_encoder_state *state)
|
||||
state->implementation_info = "Generic C";
|
||||
|
||||
/* X86/AMD64 optimizations */
|
||||
+#if (SBC_BUILD_WITH_MMX_SUPPORT || SBC_BUILD_WITH_SSE_SUPPORT)
|
||||
sbc_init_primitives_x86(state);
|
||||
+#endif
|
||||
|
||||
/* ARM optimizations */
|
||||
#ifdef SBC_BUILD_WITH_ARMV6_SUPPORT
|
||||
--
|
||||
2.28.0
|
||||
|
|
@ -1,35 +1,52 @@
|
|||
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
||||
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - configure with --enable-high-precision for v6/v7 to fix stack corruption
|
||||
# - patch to fix enabling high precision
|
||||
# - patch to fix FTBFS on ARM
|
||||
|
||||
pkgname=sbc
|
||||
pkgver=1.4
|
||||
pkgrel=2
|
||||
pkgver=1.5
|
||||
pkgrel=1
|
||||
pkgdesc="Bluetooth Subband Codec (SBC) library"
|
||||
url="http://www.bluez.org/"
|
||||
arch=(x86_64)
|
||||
license=(GPL LGPL)
|
||||
depends=(glibc)
|
||||
source=(https://mirrors.edge.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.xz
|
||||
0001-Add-config.h-in-sbc-sbc_primitives.h.patch)
|
||||
sha512sums=('f35250c202034e93ce4046d29883d76b162164d42fb59e6af8ff5e57f197244238f5f8087309cef2d44755c179e7f0869cf096735c8de510b1ac7e0f6c29d84f'
|
||||
'c2810208cc8b7a80361c4decc9e56ac26d1409174bff450a7f7c30e4b494292fcad7e78664a9fc981dd260cc2a699ad991954a29bbab497413941a7db3178d73')
|
||||
makedepends=(git)
|
||||
_commit=b2c20a3ecf5ed00f63c94077a9762b505935ede9 # tags/1.5^0
|
||||
source=("git+https://git.kernel.org/pub/scm/bluetooth/sbc.git#commit=$_commit"
|
||||
0001-Add-config.h-in-sbc-sbc_primitives.h.patch
|
||||
0002-Fix-build-on-ARM.patch)
|
||||
sha512sums=('SKIP'
|
||||
'5daaffdf735b6fa8d3526b02cccbb378aa91c72a6f093824164d335f80a72448285835666226ef5fcecc2fc802b1bf44cb34356bfe4e90b944a5b128373a9f52'
|
||||
'ffe8736c3efb51833eddd983a23ca924c2bf6071f59ff391e253c184469995a399d762ee05e826fb8a83f697c5698e8551e779c3d86a23238647df304a0d43f1')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgname
|
||||
git describe --tags | sed 's/-/+/g'
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
cd $pkgname
|
||||
patch -p1 -i ../0001-Add-config.h-in-sbc-sbc_primitives.h.patch
|
||||
patch -p1 -i ../0002-Fix-build-on-ARM.patch
|
||||
autoreconf -fvi
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
cd $pkgname
|
||||
[[ $CARCH == "armv6h" || $CARCH == "armv7h" ]] && CONFIG="--enable-high-precision"
|
||||
./configure --prefix=/usr --disable-static --disable-tester $CONFIG
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd $pkgname
|
||||
make check
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
cd $pkgname
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue