mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
alarm/kodi-rbp-git to 18.0b5.20181104-1 (#1636)
This commit is contained in:
parent
da736845fe
commit
20f8fa2b9d
2 changed files with 4 additions and 21 deletions
|
@ -12,10 +12,10 @@ _prefix=/usr
|
|||
pkgbase=kodi-rbp-git
|
||||
_suffix=rbp-git
|
||||
pkgname=("kodi-$_suffix" "kodi-eventclients-$_suffix" "kodi-tools-texturepacker-$_suffix" "kodi-dev-$_suffix")
|
||||
pkgver=18.0b4.20181023
|
||||
pkgrel=3
|
||||
pkgver=18.0b5.20181104
|
||||
pkgrel=1
|
||||
_codename=Leia
|
||||
_tag="18.0b4-$_codename"
|
||||
_tag="18.0b5-$_codename"
|
||||
_rtype=Alpha
|
||||
_ffmpeg_version="4.0.3-$_codename-Beta"5
|
||||
_libdvdcss_version="1.4.2-$_codename-Beta"-5
|
||||
|
@ -43,7 +43,6 @@ source=("https://github.com/popcornmix/xbmc/archive/newclock5_$_tag.tar.gz"
|
|||
'kodi-framebuffer'
|
||||
'99-kodi.rules'
|
||||
'polkit.rules'
|
||||
'hifiberry_digi.patch'
|
||||
"ffmpeg-$_ffmpeg_version.tar.gz::https://github.com/xbmc/FFmpeg/archive/$_ffmpeg_version.tar.gz"
|
||||
"libdvdcss-$_libdvdcss_version.tar.gz::https://github.com/xbmc/libdvdcss/archive/$_libdvdcss_version.tar.gz"
|
||||
"libdvdnav-$_libdvdnav_version.tar.gz::https://github.com/xbmc/libdvdnav/archive/$_libdvdnav_version.tar.gz"
|
||||
|
@ -63,12 +62,11 @@ noextract=(
|
|||
"fstrcmp-$_fstrcmp_version.tar.gz"
|
||||
"flatbuffers-$_flatbuffers_version.tar.gz"
|
||||
)
|
||||
sha256sums=('4022a169e1467a4d5c3b338ae0882d22febe49f2e5727c83b60a6e6201e9dae7'
|
||||
sha256sums=('f447006ce1dee5053579fc5193cac1e2e8c19074e71ed86c71e60089232ee2cf'
|
||||
'6eded8b5f52808d5ffa77de546fbf799a255dde2473540e8a8bd46daa6f753d9'
|
||||
'fe7a1ab2a6e2bf00f756c76545a338d2763003052764d722d492b06b1bc05f5e'
|
||||
'b31570f95654434b01fd8531612fbb6be77cbc1c519dd60f92feae26eb160f3d'
|
||||
'9ea592205023ba861603d74b63cdb73126c56372a366dc4cb7beb379073cbb96'
|
||||
'0b9d951911a8576c26dec8a31f394282677e48afff49b9579448121d27b8509e'
|
||||
'f25559d4b803321483b28ac9b513671200bdc8e3531c02f0affdd622846a9c5e'
|
||||
'38816f8373e243bc5950449b4f3b18938c4e1c59348e3411e23f31db4072e40d'
|
||||
'071e414e61b795f2ff9015b21a85fc009dde967f27780d23092643916538a57a'
|
||||
|
@ -83,7 +81,6 @@ prepare() {
|
|||
|
||||
[[ -d kodi-build ]] && rm -rf kodi-build
|
||||
mkdir $srcdir/kodi-build
|
||||
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
diff -rupN a/xbmc/cores/AudioEngine/Sinks/AESinkALSA.cpp b/xbmc/cores/AudioEngine/Sinks/AESinkALSA.cpp
|
||||
--- a/xbmc/cores/AudioEngine/Sinks/AESinkALSA.cpp 2016-04-24 07:48:30.000000000 +0100
|
||||
+++ b/xbmc/cores/AudioEngine/Sinks/AESinkALSA.cpp 2016-07-06 23:15:14.851453568 +0100
|
||||
@@ -1342,6 +1342,10 @@ void CAESinkALSA::EnumerateDevice(AEDevi
|
||||
if (snd_card_get_name(cardNr, &cardName) == 0)
|
||||
info.m_displayName = cardName;
|
||||
|
||||
+ /* hifiberry digi doesn't correctly report as iec958 device. Needs fixing in kernel driver */
|
||||
+ if (info.m_displayName == "snd_rpi_hifiberry_digi")
|
||||
+ info.m_deviceType = AE_DEVTYPE_IEC958;
|
||||
+
|
||||
if (info.m_deviceType == AE_DEVTYPE_HDMI && info.m_displayName.size() > 5 &&
|
||||
info.m_displayName.substr(info.m_displayName.size()-5) == " HDMI")
|
||||
{
|
Loading…
Reference in a new issue