rmeoved extra/digikam

This commit is contained in:
Kevin Mihelich 2017-12-17 14:59:47 +00:00
parent 6d04f8f242
commit 21318039bd
3 changed files with 0 additions and 209 deletions

View file

@ -1,34 +0,0 @@
From 9b37ca152cbae4b86ce2b93f7b1af58f092d1ccf Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 5 Jul 2016 18:47:56 -0600
Subject: [PATCH] optionally enable OpenGL
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 89e0682..b60d0b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -105,6 +105,7 @@ option(ENABLE_KFILEMETADATASUPPORT "Build digiKam with KDE files indexer suppor
option(ENABLE_AKONADICONTACTSUPPORT "Build digiKam with KDE Mail Contacts support (default=OFF)" OFF)
option(ENABLE_MEDIAPLAYER "Build digiKam with Media Player support (default=OFF)" OFF)
option(ENABLE_DBUS "Build digiKam with DBUS support (default=ON)" ON)
+option(ENABLE_OPENGL "Build digiKam with OpenGL support (default=ON)" ON)
option(ENABLE_APPSTYLES "Build digiKam with support for changing the widget application style (default=OFF)" OFF)
# Mysql support options (experimental):
@@ -293,7 +294,7 @@ else()
endif()
# decide if Presentation tool can be built with OpenGL
-if(OPENGL_FOUND AND OPENGL_GLU_FOUND AND Qt5OpenGL_FOUND)
+if(OPENGL_FOUND AND OPENGL_GLU_FOUND AND Qt5OpenGL_FOUND AND ENABLE_OPENGL)
set(HAVE_OPENGL TRUE)
elseif()
set(HAVE_OPENGL FALSE)
--
2.10.2

View file

@ -1,98 +0,0 @@
# $Id$
# Maintainer: Ronald van Haren <ronald@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to enable/disable OpenGL via a switch
# - cmake with -DENABLE_OPENGL=OFF
pkgbase=digikam
pkgname=('digikam' 'kipi-plugins')
_pkgver=5.7.0
pkgver=${_pkgver//-/_} # for beta versions
pkgrel=3
pkgdesc="An advanced digital photo management application"
arch=('x86_64')
license=('GPL')
url="http://www.digikam.org/"
makedepends=('extra-cmake-modules' 'libkipi' 'libksane' 'liblqr' 'opencv' 'boost'
'doxygen' 'lensfun' 'eigen' 'kdoctools' 'marble-common' 'kdesignerplugin'
'kfilemetadata' 'akonadi-contacts' 'qtav' 'threadweaver' 'kcalcore'
'knotifyconfig' 'libmediawiki' 'libkvkontakte')
source=("http://download.kde.org/stable/${pkgname}/${pkgname}-${_pkgver}.tar.xz"
digikam-kcalcore-17.12.patch
digikam-qt-5.9.3.patch::"https://cgit.kde.org/digikam.git/patch/?id=855ba5b7"
0001-optionally-enable-OpenGL.patch)
sha256sums=('3605ffb5b6e8fbd6b725e5075f74f505d7edee7531789c2882d11df2d20150f5'
'61648bdeb88dcb94d2896b9d9211c6a6b50a39a143701e04465aa040a60053c0'
'03822e596321028d0971ec82351337dad76abeda93c9cef3b1d2a31807e02661'
'f6f234f430f02e058e12e48577f9d8441959e84b42f4e50d733706be8b214bf5')
prepare() {
mkdir -p build
# sv docs fail to build
sed -e '/sv/d' -i $pkgname-$pkgver/doc-translated/CMakeLists.txt
# fix conflicts with libkvkontakte
rm $pkgbase-$pkgver/po/*/libkvkontakte.po
# fix build with kcalcore 17.12
cd $pkgname-$_pkgver/core
patch -p1 -i "$srcdir"/digikam-kcalcore-17.12.patch
# fix thumbnails with Qt 5.9.3
patch -p1 -i "$srcdir"/digikam-qt-5.9.3.patch
# OpenGL switch
patch -p1 -i ${srcdir}/0001-optionally-enable-OpenGL.patch
}
build() {
cd build
cmake ../${pkgname}-${_pkgver} \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=Release \
-DBUILD_TESTING=OFF \
-DENABLE_KFILEMETADATASUPPORT=ON \
-DENABLE_MEDIAPLAYER=ON \
-DENABLE_AKONADICONTACTSUPPORT=ON \
-DENABLE_MYSQLSUPPORT=ON \
-DENABLE_OPENCV3=ON \
-DENABLE_APPSTYLES=ON \
-DENABLE_OPENGL=OFF
make
}
package_digikam() {
pkgdesc="Digital photo management application for KDE"
depends=('liblqr' 'libkipi' 'lensfun' 'opencv' 'akonadi-contacts'
'knotifyconfig' 'libksane' 'kfilemetadata' 'qtav' 'marble-common' 'threadweaver' 'kcalcore')
optdepends=('kipi-plugins: export to various online services'
'hugin: panorama tool' 'qt5-imageformats: WEBP format support')
cd build/core
make DESTDIR="$pkgdir" install
cd $srcdir/build/doc
make DESTDIR="$pkgdir" install
cd $srcdir/build/po
make DESTDIR="$pkgdir" install
# Provided by kipi-plugins
rm "$pkgdir"/usr/share/locale/*/LC_MESSAGES/kipiplugin*.mo
}
package_kipi-plugins() {
pkgdesc="A collection of plugins extending the KDE graphics and image applications as digiKam"
depends=('kio' 'libkipi')
optdepends=('libmediawiki: MediaWiki Export plugin'
'libkvkontakte: VKontakte.ru Exporter plugin')
cd build/extra
make DESTDIR="$pkgdir" install
cd $srcdir/build/po
make DESTDIR="$pkgdir" install
# Provided by digikam
rm "$pkgdir"/usr/share/locale/*/LC_MESSAGES/digikam.mo
}

View file

@ -1,77 +0,0 @@
From dad750fadc926b62603cc9d64009ee5072a46d97 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Vr=C3=A1til?= <dvratil@kde.org>
Date: Wed, 13 Sep 2017 16:51:14 +0200
Subject: Adapt to KCalCore API changes
This change supports both old (pre-QDateTime) and new version.
Differential Revision: https://phabricator.kde.org/D7802
---
CMakeLists.txt | 3 +++
app/utils/digikam_config.h.cmake.in | 3 +++
utilities/assistants/calendar/print/calsettings.cpp | 14 ++++++++++----
3 files changed, 16 insertions(+), 4 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ad686d..e2f28a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -174,6 +174,9 @@ find_package(KF5 ${CALENDAR_MIN_VERSION} QUIET
OPTIONAL_COMPONENTS
CalendarCore # For Calendar tool.
)
+if ("${KF5CalendarCore_VERSION}" VERSION_GREATER 5.6.40)
+ set(HAVE_KCALENDAR_QDATETIME TRUE)
+endif()
if(ENABLE_AKONADICONTACTSUPPORT AND NOT KF5AkonadiContact_FOUND)
set(ENABLE_KFILEMETADATASUPPORT OFF)
diff --git a/app/utils/digikam_config.h.cmake.in b/app/utils/digikam_config.h.cmake.in
index 8a2e8e5..ffd3a22 100644
--- a/app/utils/digikam_config.h.cmake.in
+++ b/app/utils/digikam_config.h.cmake.in
@@ -75,6 +75,9 @@
/* Define to 1 if you have KCalendar core shared libraries installed */
#cmakedefine HAVE_KCALENDAR 1
+/* Define to 1 if you have KCalendar core shared libraries with QDateTime support installed */
+#cmakedefine HAVE_KCALENDAR_QDATETIME 1
+
/* Define to 1 if Panorama tool is supported */
#cmakedefine HAVE_PANORAMA 1
diff --git a/utilities/assistants/calendar/print/calsettings.cpp b/utilities/assistants/calendar/print/calsettings.cpp
index 46e995d..c6554ef 100644
--- a/utilities/assistants/calendar/print/calsettings.cpp
+++ b/utilities/assistants/calendar/print/calsettings.cpp
@@ -290,7 +290,13 @@ void CalSettings::loadSpecial(const QUrl& url, const QColor& color)
return;
}
- KCalCore::MemoryCalendar::Ptr memCal(new KCalCore::MemoryCalendar(QString::fromLatin1("UTC")));
+#if HAVE_KCALENDAR_QDATETIME
+ KCalCore::MemoryCalendar::Ptr memCal(new KCalCore::MemoryCalendar(QTimeZone::utc()));
+ using DateTime = QDateTime;
+#else
+ KCalCore::MemoryCalendar::Ptr memCal(new KCalCore::MemoryCalendar(QString::fromLatin1("UTC")));
+ using DateTime = KDateTime;
+#endif
KCalCore::FileStorage::Ptr fileStorage(new KCalCore::FileStorage(memCal, url.toLocalFile(), new KCalCore::ICalFormat));
qCDebug(DIGIKAM_GENERAL_LOG) << "Loading calendar from file " << url.toLocalFile();
@@ -308,9 +309,9 @@ void CalSettings::loadSpecial(const QUrl& url, const QColor& color)
qLast = calSys.date(params.year + 1, 1, 1);
qLast = qLast.addDays(-1);
- KDateTime dtFirst(qFirst);
- KDateTime dtLast(qLast);
- KDateTime dtCurrent;
+ DateTime dtFirst(qFirst, QTime(0, 0));
+ DateTime dtLast(qLast, QTime(0, 0));
+ DateTime dtCurrent;
int counter = 0;
KCalCore::Event::List list = memCal->rawEvents(qFirst, qLast);
--
cgit v0.11.2