mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/gcc to 7.3.1+20180312-2
This commit is contained in:
parent
4e80263cbc
commit
215025f7dc
2 changed files with 33 additions and 1 deletions
|
@ -19,7 +19,7 @@ pkgname=(gcc gcc-libs gcc-fortran gcc-objc gcc-go)
|
|||
pkgver=7.3.1+20180312
|
||||
_majorver=${pkgver:0:1}
|
||||
_islver=0.18
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc='The GNU Compiler Collection'
|
||||
arch=(x86_64)
|
||||
license=(GPL LGPL FDL custom)
|
||||
|
@ -32,6 +32,7 @@ source=(https://sources.archlinux.org/other/gcc/gcc-${pkgver/+/-}.tar.xz{,.sig}
|
|||
#source=(https://ftp.gnu.org/gnu/gcc/gcc-$pkgver/gcc-$pkgver.tar.xz{,.sig}
|
||||
http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
|
||||
c89 c99
|
||||
bz84080.patch
|
||||
0001-ARMv5-disable-LDRD-STRD.patch)
|
||||
validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.org
|
||||
13975A70E63C361C73AE69EF6EEB81F8981C74C7) # richard.guenther@gmail.com
|
||||
|
@ -40,6 +41,7 @@ sha256sums=('c52618f656f2102b3544419e7d0a8a4f4e6ff052783865202be73edf1a40e28b'
|
|||
'6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b'
|
||||
'de48736f6e4153f03d0a5d38ceb6c6fdb7f054e8f47ddd6af0a3dbf14f27b931'
|
||||
'2513c6d9984dd0a2058557bf00f06d8d5181734e41dcfe07be7ed86f2959622a'
|
||||
'bce05807443558db55f0d6b4dae37a678ea1bb3388b541c876fe3d110e3717e7'
|
||||
'31e24baa9eee826d7d77dbcf8f1a6a44c92f771e52d21677acb8d76fac7ae204')
|
||||
|
||||
_svnrev=258469
|
||||
|
@ -67,6 +69,9 @@ prepare() {
|
|||
[[ ! -d gcc ]] && ln -s gcc-${pkgver/+/-} gcc
|
||||
cd gcc
|
||||
|
||||
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=84080
|
||||
patch -p0 -i "$srcdir/bz84080.patch"
|
||||
|
||||
# link isl for in-tree build
|
||||
ln -s ../isl-${_islver} isl
|
||||
|
||||
|
|
27
core/gcc/bz84080.patch
Normal file
27
core/gcc/bz84080.patch
Normal file
|
@ -0,0 +1,27 @@
|
|||
Index: gcc/testsuite/g++.dg/cpp1y/auto-fn47.C
|
||||
===================================================================
|
||||
--- gcc/testsuite/g++.dg/cpp1y/auto-fn47.C (nonexistent)
|
||||
+++ gcc/testsuite/g++.dg/cpp1y/auto-fn47.C (revision 257630)
|
||||
@@ -0,0 +1,6 @@
|
||||
+// PR c++/84080
|
||||
+// { dg-do compile { target c++14 } }
|
||||
+
|
||||
+template <int i, typename T> T foo();
|
||||
+
|
||||
+template <> auto foo<0>() { return 42; } // { dg-error "does not match" }
|
||||
Index: gcc/cp/pt.c
|
||||
===================================================================
|
||||
--- gcc/cp/pt.c (revision 257629)
|
||||
+++ gcc/cp/pt.c (revision 257630)
|
||||
@@ -2203,6 +2203,11 @@
|
||||
specialize TMPL will produce DECL. */
|
||||
continue;
|
||||
|
||||
+ if (uses_template_parms (targs))
|
||||
+ /* We deduced something involving 'auto', which isn't a valid
|
||||
+ template argument. */
|
||||
+ continue;
|
||||
+
|
||||
/* Remove, from the set of candidates, all those functions
|
||||
whose constraints are not satisfied. */
|
||||
if (flag_concepts && !constraints_satisfied_p (fn, targs))
|
Loading…
Reference in a new issue