mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/libdrm to 2.4.71-1.2
This commit is contained in:
parent
f27044d5f1
commit
215289487d
3 changed files with 45 additions and 4 deletions
|
@ -1,7 +1,7 @@
|
||||||
From 677cd97dc4a930af508388713f5016baf664ed18 Mon Sep 17 00:00:00 2001
|
From 677cd97dc4a930af508388713f5016baf664ed18 Mon Sep 17 00:00:00 2001
|
||||||
From: Rob Herring <robh@kernel.org>
|
From: Rob Herring <robh@kernel.org>
|
||||||
Date: Fri, 21 Oct 2016 10:07:59 -0700
|
Date: Fri, 21 Oct 2016 10:07:59 -0700
|
||||||
Subject: [PATCH] Return an -ENODEV from drmGetDevice() when no device was
|
Subject: [PATCH 1/2] Return an -ENODEV from drmGetDevice() when no device was
|
||||||
found.
|
found.
|
||||||
|
|
||||||
Fixes crashes in Mesa on platform devices, which expected *device to
|
Fixes crashes in Mesa on platform devices, which expected *device to
|
||||||
|
|
|
@ -0,0 +1,38 @@
|
||||||
|
From 2d8c01f256011c013edf3a76672d6ce9e2b05d8f Mon Sep 17 00:00:00 2001
|
||||||
|
From: Eric Anholt <eric@anholt.net>
|
||||||
|
Date: Fri, 21 Oct 2016 10:09:47 -0700
|
||||||
|
Subject: [PATCH 2/2] Silence runtime complaints on platform devices
|
||||||
|
|
||||||
|
glxgears was spamming this 12 times at startup because of Mesa's
|
||||||
|
probing of the DRM device code, which doesn't support platform
|
||||||
|
devices.
|
||||||
|
|
||||||
|
Signed-off-by: Eric Anholt <eric@anholt.net>
|
||||||
|
Reviewed-by: Alex Deucher <alexander.deucher@amd.com>
|
||||||
|
---
|
||||||
|
xf86drm.c | 2 --
|
||||||
|
1 file changed, 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/xf86drm.c b/xf86drm.c
|
||||||
|
index 9b52889..52add5e 100644
|
||||||
|
--- a/xf86drm.c
|
||||||
|
+++ b/xf86drm.c
|
||||||
|
@@ -3149,7 +3149,6 @@ int drmGetDevice(int fd, drmDevicePtr *device)
|
||||||
|
|
||||||
|
break;
|
||||||
|
default:
|
||||||
|
- fprintf(stderr, "The subsystem type is not supported yet\n");
|
||||||
|
continue;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -3259,7 +3258,6 @@ int drmGetDevices(drmDevicePtr devices[], int max_devices)
|
||||||
|
|
||||||
|
break;
|
||||||
|
default:
|
||||||
|
- fprintf(stderr, "The subsystem type is not supported yet\n");
|
||||||
|
continue;
|
||||||
|
}
|
||||||
|
|
||||||
|
--
|
||||||
|
2.10.2
|
||||||
|
|
|
@ -4,11 +4,11 @@
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
# - enable omap, exynos, tegra, etnaviv for v7
|
# - enable omap, exynos, tegra, etnaviv for v7
|
||||||
# - drop valgrind makdepend for v5 and v6
|
# - drop valgrind makdepend for v5 and v6
|
||||||
# - upstream patch to fix glamoregl segfault with Mesa 13.0
|
# - upstream patches to fix glamoregl segfault with Mesa 13.0
|
||||||
|
|
||||||
pkgname=libdrm
|
pkgname=libdrm
|
||||||
pkgver=2.4.71
|
pkgver=2.4.71
|
||||||
pkgrel=1.1
|
pkgrel=1.2
|
||||||
pkgdesc="Userspace interface to kernel DRM services"
|
pkgdesc="Userspace interface to kernel DRM services"
|
||||||
arch=(i686 x86_64)
|
arch=(i686 x86_64)
|
||||||
license=('custom')
|
license=('custom')
|
||||||
|
@ -21,10 +21,12 @@ replaces=('libdrm-new' 'libdrm-nouveau')
|
||||||
url="http://dri.freedesktop.org/"
|
url="http://dri.freedesktop.org/"
|
||||||
source=(http://dri.freedesktop.org/$pkgname/$pkgname-$pkgver.tar.bz2{,.sig}
|
source=(http://dri.freedesktop.org/$pkgname/$pkgname-$pkgver.tar.bz2{,.sig}
|
||||||
0001-Return-an-ENODEV-from-drmGetDevice-when-no-device-wa.patch
|
0001-Return-an-ENODEV-from-drmGetDevice-when-no-device-wa.patch
|
||||||
|
0002-Silence-runtime-complaints-on-platform-devices.patch
|
||||||
COPYING)
|
COPYING)
|
||||||
sha256sums=('c66287ddeee5f46ea8f8880b94b80acb3bbc33ba6321d17767eef145046df9b8'
|
sha256sums=('c66287ddeee5f46ea8f8880b94b80acb3bbc33ba6321d17767eef145046df9b8'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'3b3bf1b68c8f8f8666a6e7ee31609dd255c8d6015561c90049d6510675764aad'
|
'2b35620c67771ef286106863076f7f544d7795d53368f51b757105865d82b88f'
|
||||||
|
'bc6ef82d3a4a601590ea40dc644734cfc05aa6e74dbdb3401d98e966d7f45e48'
|
||||||
'9631d4f694952e3e6ae5a05534c2e93e994e47d3413677a3a00e45c8cef6db93')
|
'9631d4f694952e3e6ae5a05534c2e93e994e47d3413677a3a00e45c8cef6db93')
|
||||||
validpgpkeys=('B97BD6A80CAC4981091AE547FE558C72A67013C3') # Maarten Lankhorst <maarten.lankhorst@canonical.com>
|
validpgpkeys=('B97BD6A80CAC4981091AE547FE558C72A67013C3') # Maarten Lankhorst <maarten.lankhorst@canonical.com>
|
||||||
validpgpkeys+=('215DEE688925CCB965BE5DA97C03D7797B6E1AE2') # Damien Lespiau <damien.lespiau@intel.com>
|
validpgpkeys+=('215DEE688925CCB965BE5DA97C03D7797B6E1AE2') # Damien Lespiau <damien.lespiau@intel.com>
|
||||||
|
@ -38,6 +40,7 @@ prepare() {
|
||||||
cd $pkgname-$pkgver
|
cd $pkgname-$pkgver
|
||||||
|
|
||||||
patch -p1 -i ../0001-Return-an-ENODEV-from-drmGetDevice-when-no-device-wa.patch
|
patch -p1 -i ../0001-Return-an-ENODEV-from-drmGetDevice-when-no-device-wa.patch
|
||||||
|
patch -p1 -i ../0002-Silence-runtime-complaints-on-platform-devices.patch
|
||||||
|
|
||||||
# pthread is useless in Linux
|
# pthread is useless in Linux
|
||||||
sed -i "/pthread-stubs/d" configure.ac
|
sed -i "/pthread-stubs/d" configure.ac
|
||||||
|
|
Loading…
Reference in a new issue