alarm/uboot-odroid to 2015.01-1

This commit is contained in:
Kevin Mihelich 2015-01-21 03:57:41 +00:00
parent 752a07fae1
commit 2180d2f45e
3 changed files with 53 additions and 62 deletions

View file

@ -1,14 +1,14 @@
From d07e0f54020cf26196e2554c6dbabf62bc729ab1 Mon Sep 17 00:00:00 2001
From e8374fe12000eaadbf2c486700138e85286bea32 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 22 Aug 2014 17:51:41 -0600
Subject: [PATCH] arch linux arm modifications
---
include/configs/odroid.h | 163 ++++++++++++++++++-----------------------------
1 file changed, 62 insertions(+), 101 deletions(-)
include/configs/odroid.h | 167 +++++++++++++++++++----------------------------
1 file changed, 66 insertions(+), 101 deletions(-)
diff --git a/include/configs/odroid.h b/include/configs/odroid.h
index b928af8..8466e57 100644
index 807e96b..0bc008b 100644
--- a/include/configs/odroid.h
+++ b/include/configs/odroid.h
@@ -14,6 +14,7 @@
@ -27,7 +27,7 @@ index b928af8..8466e57 100644
#include <linux/sizes.h>
@@ -47,11 +49,12 @@
@@ -47,11 +49,10 @@
#define CONFIG_SYS_CONSOLE_IS_IN_ENV
#define CONFIG_CMD_BOOTZ
@ -38,12 +38,10 @@ index b928af8..8466e57 100644
-#define CONFIG_BOOTARGS "Please use defined boot"
-#define CONFIG_BOOTCOMMAND "run autoboot"
-#define CONFIG_DEFAULT_CONSOLE "console=ttySAC1,115200n8\0"
+
+#define CONFIG_BOOTDELAY 3
#define CONFIG_SYS_INIT_SP_ADDR (CONFIG_SYS_LOAD_ADDR \
- GENERATED_GBL_DATA_SIZE)
@@ -66,35 +69,6 @@
@@ -66,35 +67,6 @@
#define CONFIG_ENV_OFFSET (SZ_1K * 1280) /* 1.25 MiB offset */
#define CONFIG_ENV_OVERWRITE
@ -79,7 +77,7 @@ index b928af8..8466e57 100644
/*
* Bootable media layout:
* dev: SD eMMC(part boot)
@@ -103,77 +77,64 @@
@@ -103,77 +75,70 @@
* UBOOT 63 62
* TZSW 2111 2110
* ENV 2560 2560(part user)
@ -161,52 +159,58 @@ index b928af8..8466e57 100644
+ "rdaddr=42000000\0" \
+ "rdfile=initramfs-linux.img\0" \
+ "fdtaddr=40800000\0" \
+ "fdt_file=\0" /* rename to fdtfile when Odroid-X detection is available */ \
+ "fdtfile=\0" \
+ "fdtdir=/boot/dtbs\0" \
+ "optargs=\0" \
+ "mmcdev=0\0" \
+ "mmcroot=/dev/mmcblk0p1 rw rootwait\0" \
+ "mmcargs=setenv bootargs console=${console} " \
+ "${optargs} " \
+ "root=${mmcroot} " \
+ "root=${root} " \
+ "video=${video}\0" \
+ "loadimage=load mmc ${bootpart} ${loadaddr} ${bootdir}/${bootfile}\0" \
+ "loadrd=load mmc ${bootpart} ${rdaddr} ${bootdir}/${rdfile}\0" \
+ "loadfdt=echo loading ${fdtdir}/${fdt_file} ...; load mmc ${bootpart} ${fdtaddr} ${fdtdir}/${fdt_file}\0" \
+ "mmcboot=mmc dev ${mmcdev}; " \
+ "if mmc rescan; then " \
+ "echo SD/MMC found on device ${mmcdev};" \
+ "setenv bootpart ${mmcdev}:1; " \
+ "echo Checking for: ${bootdir}/uEnv.txt ...;" \
+ "if test -e mmc ${bootpart} ${bootdir}/uEnv.txt; then " \
+ "load mmc ${bootpart} ${loadaddr} ${bootdir}/uEnv.txt;" \
+ "env import -t ${loadaddr} ${filesize};" \
+ "echo Loaded environment from ${bootdir}/uEnv.txt;" \
+ "echo Checking if uenvcmd is set ...;" \
+ "if test -n ${uenvcmd}; then " \
+ "echo Running uenvcmd ...;" \
+ "run uenvcmd;" \
+ "loadimage=load ${devtype} ${bootpart} ${loadaddr} ${bootdir}/${bootfile}\0" \
+ "loadrd=load ${devtype} ${bootpart} ${rdaddr} ${bootdir}/${rdfile}\0" \
+ "loadfdt=echo loading ${fdtdir}/${fdtfile} ...; load ${devtype} ${bootpart} ${fdtaddr} ${fdtdir}/${fdtfile}\0" \
+ "mmcboot=usb start;" \
+ "for devtype in mmc usb; do " \
+ "setenv devnum 0;" \
+ "while ${devtype} dev ${devnum}; do " \
+ "echo ${devtype} found on device ${devnum};" \
+ "setenv bootpart ${devnum}:1;" \
+ "part uuid ${devtype} ${bootpart} uuid;" \
+ "setenv root PARTUUID=${uuid} rw rootwait;" \
+ "echo Checking for: ${bootdir}/uEnv.txt ...;" \
+ "if test -e ${devtype} ${bootpart} ${bootdir}/uEnv.txt; then " \
+ "load ${devtype} ${bootpart} ${loadaddr} ${bootdir}/uEnv.txt;" \
+ "env import -t ${loadaddr} ${filesize};" \
+ "echo Loaded environment from ${bootdir}/uEnv.txt;" \
+ "echo Checking if uenvcmd is set ...;" \
+ "if test -n ${uenvcmd}; then " \
+ "echo Running uenvcmd ...;" \
+ "run uenvcmd;" \
+ "fi;" \
+ "fi;" \
+ "fi; " \
+ "if run loadimage; then " \
+ "run mmcargs;" \
+ "if run loadfdt; then " \
+ "if run loadrd; then " \
+ "bootz ${loadaddr} ${rdaddr}:${filesize} ${fdtaddr};" \
+ "if run loadimage; then " \
+ "run mmcargs;" \
+ "if run loadfdt; then " \
+ "if run loadrd; then " \
+ "bootz ${loadaddr} ${rdaddr}:${filesize} ${fdtaddr};" \
+ "else " \
+ "bootz ${loadaddr} - ${fdtaddr};" \
+ "fi;" \
+ "else " \
+ "bootz ${loadaddr} - ${fdtaddr};" \
+ "if run loadrd; then " \
+ "bootz ${loadaddr} ${rdaddr}:${filesize};" \
+ "else " \
+ "bootz ${loadaddr};" \
+ "fi;" \
+ "fi;" \
+ "else " \
+ "if run loadrd; then " \
+ "bootz ${loadaddr} ${rdaddr}:${filesize};" \
+ "else " \
+ "bootz ${loadaddr};" \
+ "fi;" \
+ "echo No kernel found;" \
+ "fi;" \
+ "else " \
+ "echo No kernel found;" \
+ "fi;" \
+ "fi;\0"
+ "setexpr devnum ${devnum} + 1;" \
+ "done;" \
+ "done;\0"
+
+#define CONFIG_BOOTCOMMAND \
+ "run mmcboot;"
@ -214,5 +218,5 @@ index b928af8..8466e57 100644
/* I2C */
#define CONFIG_CMD_I2C
--
2.2.1
2.2.2

View file

@ -4,7 +4,7 @@
buildarch=4
pkgname=uboot-odroid
pkgver=2014.10
pkgver=2015.01
pkgrel=1
pkgdesc="U-Boot for ODROID-X/X2/U2/U3"
arch=('armv7h')
@ -21,13 +21,13 @@ source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
"sd_fusing.sh"
'0001-arch-linux-arm-modifications.patch'
'uEnv.txt')
md5sums=('3ddcaee2f05b7c464778112ec83664b5'
md5sums=('7f08dc9e98a71652bd6968888ed6ec95'
'3ab6d3cc2061bc2590d60320254017c6'
'841502de02bd42f2898e36c89c260b0f'
'c38faafa02a6a1ae834457f378c82113'
'17909ae93a0ae7b4c155234040105035'
'565256b2d83b05906074dc40ed3b8e8c'
'08921d3ead5fa3e97dfc1b8e50334677')
'2052114e0a93366c700611f8041dc82c'
'fb5c9ea3108afa298087549f0453b00f')
prepare() {
cd u-boot-${pkgver}

View file

@ -1,24 +1,11 @@
# Use this file to make modifications to the U-Boot environment.
# Defaults in the environment are provided below, uncomment and modify to change them.
### Kernel
# bootdir=/boot
# bootfile=zImage
### root filesystem device
# mmcroot=/dev/mmcblk0p1 rw rootwait
# root=/dev/... rw rootwait
### optargs (extra options to pass to the kernel)
# optargs=
### Flattened Device Tree file (specify for mainline kernel use)
# fdtfile=exynos4412-odroidu3.dtb
# fdtfile=exynos4412-odroidx.dtb
# fdtfile=exynos4412-odroidx2.dtb
### initramfs
# rdfile=initramfs-linux.img
### video
## 1920x1080 (1080P) with monitor provided EDID information. (1080p-edid)
# video=HDMI-A-1:1920x1080@60