mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
removed community/packagekit
This commit is contained in:
parent
29050654f4
commit
2181216157
5 changed files with 0 additions and 1834 deletions
|
@ -1,150 +0,0 @@
|
||||||
# $Id$
|
|
||||||
# Maintainer: Jonathan Conder <jonno.conder@gmail.com>
|
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
# - --disable-strict, ensure our cflags are used
|
|
||||||
|
|
||||||
pkgbase='packagekit'
|
|
||||||
pkgname=('packagekit' 'packagekit-qt2' 'python2-packagekit' 'python-packagekit')
|
|
||||||
pkgver=0.7.6
|
|
||||||
pkgrel=12
|
|
||||||
pkgdesc="A system designed to make installation and updates of packages easier."
|
|
||||||
arch=('i686' 'x86_64')
|
|
||||||
url="http://www.packagekit.org"
|
|
||||||
license=('GPL')
|
|
||||||
makedepends=('dbus-glib' 'gobject-introspection' 'gtk-doc' 'intltool'
|
|
||||||
'networkmanager' 'pacman' 'pm-utils' 'polkit' 'python2' 'qt4'
|
|
||||||
'shared-mime-info' 'sqlite' 'udev' 'python')
|
|
||||||
source=("http://www.freedesktop.org/software/PackageKit/releases/PackageKit-$pkgver.tar.xz"
|
|
||||||
'adopt.patch'
|
|
||||||
'alpm.patch'
|
|
||||||
'libarchive.patch')
|
|
||||||
sha256sums=('82c0a553075d49add3c4f58e6e93f7f3613938809a4b8e36f46476e86981b45d'
|
|
||||||
'd0ee8580202a878571dddd470017731299c63e5c5120afe881bb41b9544322b8'
|
|
||||||
'c7f6da04f5b8f09e6d884ae4f480c064eae10de1d2528bf14d2f55b34e472c23'
|
|
||||||
'0d3798c8992afdc0930aa271b3e44deb55c046ab4adee25b4ec4c33bcdd950e2')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd "$srcdir/PackageKit-$pkgver"
|
|
||||||
|
|
||||||
sed -i 's@SUBDIRS = test@SUBDIRS =@' 'backends/Makefile.in'
|
|
||||||
sed -i 's@-Werror@@' configure.ac
|
|
||||||
patch -Np1 -i "$srcdir/adopt.patch"
|
|
||||||
patch -Np1 -i "$srcdir/alpm.patch"
|
|
||||||
patch -Np1 -i "$srcdir/libarchive.patch"
|
|
||||||
sed -i 's@sbin_PROGRAMS@bin_PROGRAMS@' 'contrib/device-rebind/Makefile.am'
|
|
||||||
|
|
||||||
cd "$srcdir"
|
|
||||||
cp -r PackageKit-$pkgver PackageKit-$pkgver-python3
|
|
||||||
|
|
||||||
cd "$srcdir/PackageKit-$pkgver"
|
|
||||||
sed -i 's@python @python2 @' 'lib/python/packagekit/Makefile.in'
|
|
||||||
sed -i 's@bin/python@bin/python2@' 'lib/python/packagekit/'*.py
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
|
||||||
cd "$srcdir/PackageKit-$pkgver"
|
|
||||||
|
|
||||||
export PYTHON=/usr/bin/python2
|
|
||||||
./autogen.sh --prefix=/usr \
|
|
||||||
--sysconfdir=/etc \
|
|
||||||
--localstatedir=/var \
|
|
||||||
--libexecdir=/usr/lib/PackageKit \
|
|
||||||
--disable-strict \
|
|
||||||
--disable-static \
|
|
||||||
--disable-gtk-doc \
|
|
||||||
--disable-tests \
|
|
||||||
--disable-local \
|
|
||||||
--disable-browser-plugin \
|
|
||||||
--disable-gstreamer-plugin \
|
|
||||||
--disable-gtk-module \
|
|
||||||
--disable-command-not-found \
|
|
||||||
--disable-cron \
|
|
||||||
--disable-debuginfo-install \
|
|
||||||
--enable-pm-utils \
|
|
||||||
--disable-dummy \
|
|
||||||
--enable-alpm \
|
|
||||||
--with-default-backend=alpm
|
|
||||||
make -s CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64 -O2 -Wno-unused-local-typedefs -Wno-deprecated-declarations -Wno-suggest-attribute=format"
|
|
||||||
|
|
||||||
cd "$srcdir/PackageKit-$pkgver-python3"
|
|
||||||
|
|
||||||
export PYTHON=/usr/bin/python
|
|
||||||
./autogen.sh --prefix=/usr \
|
|
||||||
--sysconfdir=/etc \
|
|
||||||
--localstatedir=/var \
|
|
||||||
--libexecdir=/usr/lib/PackageKit \
|
|
||||||
--disable-strict \
|
|
||||||
--disable-static \
|
|
||||||
--disable-gtk-doc \
|
|
||||||
--disable-tests \
|
|
||||||
--disable-local \
|
|
||||||
--disable-browser-plugin \
|
|
||||||
--disable-gstreamer-plugin \
|
|
||||||
--disable-gtk-module \
|
|
||||||
--disable-command-not-found \
|
|
||||||
--disable-cron \
|
|
||||||
--disable-debuginfo-install \
|
|
||||||
--enable-pm-utils \
|
|
||||||
--disable-dummy \
|
|
||||||
--enable-alpm \
|
|
||||||
--with-default-backend=alpm
|
|
||||||
make -s CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64 -O2 -Wno-unused-local-typedefs -Wno-deprecated-declarations -Wno-suggest-attribute=format"
|
|
||||||
}
|
|
||||||
|
|
||||||
package_packagekit() {
|
|
||||||
backup=('var/lib/PackageKit/transactions.db'
|
|
||||||
'etc/PackageKit/alpm.d/pacman.conf'
|
|
||||||
'etc/PackageKit/alpm.d/repos.list')
|
|
||||||
depends=('dbus-glib' 'pacman>=4.1.0' 'pacman<4.2.0' 'polkit'
|
|
||||||
'shared-mime-info' 'sqlite' 'udev')
|
|
||||||
optdepends=('networkmanager')
|
|
||||||
install='packagekit.install'
|
|
||||||
|
|
||||||
cd "$srcdir/PackageKit-$pkgver"
|
|
||||||
|
|
||||||
make DESTDIR="$pkgdir" install
|
|
||||||
|
|
||||||
rm -rf "$pkgdir/usr/include/PackageKit/packagekit-qt"*
|
|
||||||
rm -rf "$pkgdir/usr/lib/libpackagekit-qt"*
|
|
||||||
rm -rf "$pkgdir/usr/lib/pkgconfig/packagekit-qt"*
|
|
||||||
rm -rf "$pkgdir/usr/lib/cmake"
|
|
||||||
|
|
||||||
rm -rf "$pkgdir/usr/lib/python"*
|
|
||||||
rm -rf "$pkgdir/usr/share/PackageKit/website"
|
|
||||||
|
|
||||||
mkdir -p "$pkgdir/usr/share/bash-completion/completions"
|
|
||||||
mv "$pkgdir/etc/bash_completion.d/pk-completion.bash" \
|
|
||||||
"$pkgdir/usr/share/bash-completion/completions/pkcon"
|
|
||||||
rmdir "$pkgdir/etc/bash_completion.d"
|
|
||||||
touch "$pkgdir/var/log/PackageKit"
|
|
||||||
}
|
|
||||||
|
|
||||||
package_packagekit-qt2() {
|
|
||||||
depends=('packagekit' 'qt4')
|
|
||||||
pkgdesc=('Qt bindings for PackageKit')
|
|
||||||
|
|
||||||
cd "$srcdir/PackageKit-$pkgver/lib/packagekit-qt2"
|
|
||||||
|
|
||||||
make DESTDIR="$pkgdir" install
|
|
||||||
}
|
|
||||||
|
|
||||||
package_python2-packagekit() {
|
|
||||||
depends=('packagekit' 'python2')
|
|
||||||
pkgdesc=('Python 2 bindings for PackageKit')
|
|
||||||
conflicts=('packagekit-python')
|
|
||||||
replaces=('packagekit-python')
|
|
||||||
|
|
||||||
cd "$srcdir/PackageKit-$pkgver/lib/python"
|
|
||||||
|
|
||||||
make DESTDIR="$pkgdir" install
|
|
||||||
}
|
|
||||||
|
|
||||||
package_python-packagekit() {
|
|
||||||
depends=('packagekit' 'python')
|
|
||||||
pkgdesc=('Python 3 bindings for PackageKit')
|
|
||||||
|
|
||||||
cd "$srcdir/PackageKit-$pkgver-python3/lib/python"
|
|
||||||
|
|
||||||
make DESTDIR="$pkgdir" install
|
|
||||||
}
|
|
|
@ -1,13 +0,0 @@
|
||||||
diff -ru a/lib/packagekit-glib2/pk-client.c b/lib/packagekit-glib2/pk-client.c
|
|
||||||
--- a/lib/packagekit-glib2/pk-client.c 2012-08-22 00:30:33.000000000 +1200
|
|
||||||
+++ b/lib/packagekit-glib2/pk-client.c 2012-08-22 19:58:44.772432269 +1200
|
|
||||||
@@ -4898,9 +4898,6 @@
|
|
||||||
|
|
||||||
/* connect */
|
|
||||||
pk_client_proxy_connect (state);
|
|
||||||
-
|
|
||||||
- state->ret = TRUE;
|
|
||||||
- pk_client_state_finish (state, NULL);
|
|
||||||
}
|
|
||||||
|
|
||||||
/**
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,39 +0,0 @@
|
||||||
diff -Nru a/lib/packagekit-glib2/pk-service-pack.c b/lib/packagekit-glib2/pk-service-pack.c
|
|
||||||
--- a/lib/packagekit-glib2/pk-service-pack.c 2012-08-17 00:36:38.000000000 +1200
|
|
||||||
+++ b/lib/packagekit-glib2/pk-service-pack.c 2013-03-01 19:00:08.773738469 +1300
|
|
||||||
@@ -207,7 +207,7 @@
|
|
||||||
archive_read_support_format_tar (arch);
|
|
||||||
|
|
||||||
/* open the tar file */
|
|
||||||
- r = archive_read_open_file (arch, filename, 10240);
|
|
||||||
+ r = archive_read_open_filename (arch, filename, 10240);
|
|
||||||
if (r) {
|
|
||||||
g_set_error (error, PK_SERVICE_PACK_ERROR, PK_SERVICE_PACK_ERROR_FAILED_EXTRACTION,
|
|
||||||
"cannot open: %s", archive_error_string (arch));
|
|
||||||
@@ -246,7 +246,7 @@
|
|
||||||
/* close the archive */
|
|
||||||
if (arch != NULL) {
|
|
||||||
archive_read_close (arch);
|
|
||||||
- archive_read_finish (arch);
|
|
||||||
+ archive_read_free (arch);
|
|
||||||
}
|
|
||||||
|
|
||||||
/* switch back to PWD */
|
|
||||||
@@ -572,7 +572,7 @@
|
|
||||||
|
|
||||||
/* we can only write tar achives */
|
|
||||||
arch = archive_write_new ();
|
|
||||||
- archive_write_set_compression_none (arch);
|
|
||||||
+ archive_write_add_filter_none (arch);
|
|
||||||
archive_write_set_format_ustar (arch);
|
|
||||||
archive_write_open_filename (arch, state->filename);
|
|
||||||
|
|
||||||
@@ -596,7 +596,7 @@
|
|
||||||
/* close the archive */
|
|
||||||
if (arch != NULL) {
|
|
||||||
archive_write_close (arch);
|
|
||||||
- archive_write_finish (arch);
|
|
||||||
+ archive_write_free (arch);
|
|
||||||
}
|
|
||||||
return ret;
|
|
||||||
}
|
|
|
@ -1,11 +0,0 @@
|
||||||
post_install() {
|
|
||||||
update-mime-database usr/share/mime &> /dev/null
|
|
||||||
}
|
|
||||||
|
|
||||||
post_upgrade() {
|
|
||||||
post_install
|
|
||||||
}
|
|
||||||
|
|
||||||
post_remove() {
|
|
||||||
post_install
|
|
||||||
}
|
|
Loading…
Reference in a new issue