mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
Merge remote-tracking branch 'upstream/master'
This commit is contained in:
commit
219ad7b567
12 changed files with 124 additions and 113 deletions
|
@ -5,10 +5,10 @@
|
|||
# Contributor: Farhan Yousaf <farhany at xaviya dot com>
|
||||
|
||||
pkgname=netatalk
|
||||
pkgver=3.1.2
|
||||
pkgver=3.1.3
|
||||
pkgrel=1
|
||||
pkgdesc='A kernel-level implementation of AFP services'
|
||||
arch=('i686' 'x86_64')
|
||||
arch=('i686' 'x86_64' 'armv6h')
|
||||
url='http://netatalk.sourceforge.net'
|
||||
license=('GPL')
|
||||
depends=('avahi>=0.6' 'libldap' 'libgcrypt>=1.2.3' 'libevent' 'python2' 'dbus-glib' 'python2-dbus')
|
||||
|
@ -19,7 +19,7 @@ install=$pkgname.install
|
|||
source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2
|
||||
avahi-client.patch
|
||||
python2.patch)
|
||||
md5sums=('cfdf3dd2278d2900275e11b4423eacc0'
|
||||
md5sums=('ac65dafa20d502a10438fec7e1116b1e'
|
||||
'00379aacb88dcac8c1e0513da1a5f24c'
|
||||
'97bc0467dd8a866d9f0835d6440e3c19')
|
||||
|
||||
|
@ -31,11 +31,11 @@ prepare() {
|
|||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
autoreconf -fi
|
||||
CFLAGS="-Wno-unused-result -O2" \
|
||||
./configure --prefix=/usr --localstatedir=/var/state --sysconfdir=/etc \
|
||||
--sbindir=/usr/bin --enable-silent-rules --with-init-style=systemd \
|
||||
--with-cracklib --with-cnid-cdb-backend --enable-pgp-uam --with-libevent=no \
|
||||
--enable-zeroconf=/usr/include/avahi-client
|
||||
--with-cracklib --with-cnid-cdb-backend --enable-pgp-uam --with-libevent=no
|
||||
make
|
||||
}
|
||||
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
pkgname=pjproject
|
||||
pkgver=2.2.1
|
||||
pkgrel=2.1
|
||||
pkgrel=3
|
||||
pkgdesc="Open source SIP stack and media stack"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.pjsip.org/"
|
||||
|
@ -30,6 +30,7 @@ build() {
|
|||
patch -p1 -i ../arm.patch
|
||||
#./configure --prefix=/usr --with-external-speex --with-external-pa --disable-oss --enable-shared --disable-opencore-amr
|
||||
./configure --prefix=/usr --with-external-speex --with-external-srtp --with-external-pa --with-external-gsm --disable-oss --enable-shared --disable-opencore-amr --disable-v4l2 --disable-video --disable-sound
|
||||
echo "#define PJ_HAS_IPV6 1" >> "${srcdir}/${pkgname}-${pkgver}/pjlib/include/pj/config_site.h"
|
||||
make -j1 dep
|
||||
make -j1
|
||||
}
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
# $Id: PKGBUILD 81227 2012-12-13 19:50:09Z mtorromeo $
|
||||
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
|
||||
# Contributor: William J Bowman <bluephoenix47@gmail.com>
|
||||
|
||||
pkgname=python2-certifi
|
||||
_libname=${pkgname/python2-/}
|
||||
pkgver=1.0.1
|
||||
pkgrel=1
|
||||
pkgdesc="Mozilla's SSL Certs"
|
||||
arch=(any)
|
||||
url="http://pypi.python.org/pypi/certifi"
|
||||
license=('GPL')
|
||||
depends=('python2')
|
||||
makedepends=('python2-setuptools')
|
||||
source=(http://pypi.python.org/packages/source/${_libname:0:1}/$_libname/$_libname-$pkgver.tar.gz)
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$_libname-$pkgver"
|
||||
sed -i '1 s|python$|python2|' certifi/core.py
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$_libname-$pkgver"
|
||||
python2 setup.py build
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$_libname-$pkgver"
|
||||
python2 setup.py install --skip-build -O1 --root="$pkgdir"
|
||||
install -m0644 -D "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
}
|
||||
|
||||
sha256sums=('f2c18c7edd349ec10378ef43ff16f81ae1d0af61d5d2858a8b383e8f6814a9cc')
|
|
@ -1,7 +1,7 @@
|
|||
pkgname=sabnzbd
|
||||
_pkgname=SABnzbd
|
||||
pkgver=0.7.17
|
||||
pkgrel=1
|
||||
pkgver=0.7.18
|
||||
pkgrel=2
|
||||
pkgdesc="A web-interface based binary newsgrabber with NZB file support"
|
||||
url="http://www.sabnzbd.org"
|
||||
arch=("any")
|
||||
|
@ -14,7 +14,7 @@ install="${pkgname}.install"
|
|||
backup=("etc/conf.d/sabnzbd" "opt/${pkgname}/${pkgname}.ini")
|
||||
source=("http://downloads.sourceforge.net/sabnzbdplus/${_pkgname}-${pkgver}-src.tar.gz"
|
||||
"${pkgname}" "${pkgname}.desktop" "addnzb.sh" "nzb-2.png" "sab2_64.png" "x-nzb.xml" "${pkgname}.service" "${pkgname}.confd")
|
||||
md5sums=('5056006fb15d6e62654af9f80955eba3'
|
||||
md5sums=('64d8b675da010dbd444c932bbb3112b6'
|
||||
'48d60a1c626503c7fef1bc5374390513'
|
||||
'f9bd5485072714b11f8c30a28024dc4d'
|
||||
'69b9bcbcf67ff3e7a4cdd9f26e001341'
|
||||
|
|
|
@ -9,8 +9,10 @@ SABNZBD_DIR="/opt/sabnzbd" # should not be changed
|
|||
## arg 1: the new package version
|
||||
post_install() {
|
||||
# add x-nzb mimetype
|
||||
xdg-mime install --mode system "${SABNZBD_DIR}/x-nzb.xml"
|
||||
xdg-icon-resource install --context mimetypes --size 64 "${SABNZBD_DIR}/nzb-2.png" application-x-nzb
|
||||
if [[ -f /usr/bin/xdg-mime ]]; then
|
||||
xdg-mime install --mode system "${SABNZBD_DIR}/x-nzb.xml"
|
||||
xdg-icon-resource install --context mimetypes --size 64 "${SABNZBD_DIR}/nzb-2.png" application-x-nzb
|
||||
fi
|
||||
|
||||
post_upgrade
|
||||
|
||||
|
@ -50,8 +52,10 @@ post_upgrade() {
|
|||
pre_remove() {
|
||||
pre_upgrade
|
||||
|
||||
xdg-mime uninstall --mode system "${SABNZBD_DIR}/x-nzb.xml"
|
||||
xdg-icon-resource uninstall --context mimetypes --size 64 application-x-nzb
|
||||
if [[ -f /usr/bin/xdg-mime ]]; then
|
||||
xdg-mime uninstall --mode system "${SABNZBD_DIR}/x-nzb.xml"
|
||||
xdg-icon-resource uninstall --context mimetypes --size 64 application-x-nzb
|
||||
fi
|
||||
}
|
||||
|
||||
## arg 1: the old package version
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
# - remove wine makedepend, no vst
|
||||
|
||||
pkgname=lmms
|
||||
pkgver=1.0.2
|
||||
pkgver=1.0.3
|
||||
pkgrel=1
|
||||
pkgdesc='The Linux MultiMedia Studio.'
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -24,17 +24,17 @@ provides=('lmms-extras')
|
|||
conflicts=('lmms-extras')
|
||||
options=('!makeflags')
|
||||
install=lmms.install
|
||||
source=("${pkgname}-${pkgver}-src.tar.bz2::http://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgver}/${pkgname}-${pkgver}-src.tar.bz2/download"
|
||||
lmms-1.0.2-build-fix.patch
|
||||
source=("https://github.com/LMMS/${pkgname}/releases/download/v{$pkgver}/${pkgname}-${pkgver}-src.tar.bz2"
|
||||
lmms-1.0.3-build-fix.patch
|
||||
zynaddsubfx_unlink.patch)
|
||||
md5sums=('db1c3e432cad933c9fd124c4840c0bf1'
|
||||
'2ff166311a02cf6220dda5cac660528a'
|
||||
md5sums=('1f63ad9abd1781206d852e79b2191638'
|
||||
'fa8ab5c48b021b87f80444440479190a'
|
||||
'd2ea78ac0cf2979505f140c6845617cf')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
|
||||
patch -Np1 -i ../lmms-1.0.2-build-fix.patch
|
||||
patch -Np1 -i ../lmms-1.0.3-build-fix.patch
|
||||
patch -Np1 -i ../zynaddsubfx_unlink.patch
|
||||
}
|
||||
|
||||
|
|
|
@ -1,30 +1,3 @@
|
|||
From ab55b26e4b1521e5401f60a2f618f31579e9cc5c Mon Sep 17 00:00:00 2001
|
||||
From: Tobias Doerffel <tobias.doerffel@gmail.com>
|
||||
Date: Sat, 5 Jul 2014 17:46:10 +0200
|
||||
Subject: [PATCH] SWH/BodeShifterCV: fix out-of-bounds array access
|
||||
|
||||
The xcoeffs array only has 100 elements and thus accessing xcoeffs[100]
|
||||
leads to undefined behaviour.
|
||||
---
|
||||
plugins/LadspaEffect/swh/bode_shifter_cv_1432.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c b/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
|
||||
index 41fb4f0..967edf6 100644
|
||||
--- a/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
|
||||
+++ b/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
|
||||
@@ -247,7 +247,7 @@ static void runBodeShifterCV(LADSPA_Handle instance, unsigned long sample_count)
|
||||
/* Perform the Hilbert FIR convolution
|
||||
* (probably FFT would be faster) */
|
||||
hilb = 0.0f;
|
||||
- for (i = 0; i <= NZEROS/2; i++) {
|
||||
+ for (i = 0; i < NZEROS/2; i++) {
|
||||
hilb += (xcoeffs[i] * delay[(dptr - i*2) & (D_SIZE - 1)]);
|
||||
}
|
||||
|
||||
--
|
||||
1.9.3
|
||||
|
||||
From f91925f34aa1ee8ecacb12b8c4943c7e8aaabbfe Mon Sep 17 00:00:00 2001
|
||||
From: Rafael Ruggiero <rafael46w@gmail.com>
|
||||
Date: Tue, 15 Jul 2014 17:41:07 -0300
|
50
community/python-certifi/PKGBUILD
Normal file
50
community/python-certifi/PKGBUILD
Normal file
|
@ -0,0 +1,50 @@
|
|||
# $Id$
|
||||
# Maintainer: Felix Yan <felixonmars@gmail.com>
|
||||
# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
|
||||
# Contributor: William J Bowman <bluephoenix47@gmail.com>
|
||||
|
||||
# remove when bumped upstream
|
||||
|
||||
pkgbase=python-certifi
|
||||
pkgname=('python-certifi' 'python2-certifi')
|
||||
_libname=${pkgbase/python-/}
|
||||
pkgver=14.05.14
|
||||
pkgrel=1
|
||||
pkgdesc="Mozilla's SSL Certs"
|
||||
arch=(any)
|
||||
url="http://pypi.python.org/pypi/certifi"
|
||||
license=('GPL')
|
||||
makedepends=('python-setuptools' 'python2-setuptools')
|
||||
source=("http://pypi.python.org/packages/source/${_libname:0:1}/$_libname/$_libname-$pkgver.tar.gz")
|
||||
sha512sums=('5edba0cc432c27212e31085fb3c2f2ded6fa177d716116111517c25b980d9fc206a9a6d47e2c001762e951ff50203b269d0eb245a039df20188b1136f3b700b2')
|
||||
|
||||
prepare() {
|
||||
cp -a $_libname-$pkgver{,-py2}
|
||||
|
||||
cd $_libname-$pkgver-py2
|
||||
sed -i '1s|python$|python2|' certifi/core.py
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$_libname-$pkgver"
|
||||
python setup.py build
|
||||
|
||||
cd "$srcdir/$_libname-$pkgver-py2"
|
||||
python2 setup.py build
|
||||
}
|
||||
|
||||
package_python-certifi() {
|
||||
depends=('python')
|
||||
|
||||
cd "$srcdir/$_libname-$pkgver"
|
||||
python setup.py install --skip-build -O1 --root="$pkgdir"
|
||||
install -m0644 -D "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
}
|
||||
|
||||
package_python2-certifi() {
|
||||
depends=('python2')
|
||||
|
||||
cd "$srcdir/$_libname-$pkgver-py2"
|
||||
python2 setup.py install --skip-build -O1 --root="$pkgdir"
|
||||
install -m0644 -D "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
}
|
|
@ -14,10 +14,10 @@
|
|||
noautobuild=1
|
||||
|
||||
pkgname=('gcc' 'gcc-libs' 'gcc-fortran' 'gcc-objc' 'gcc-go')
|
||||
pkgver=4.9.0
|
||||
pkgver=4.9.1
|
||||
_pkgver=4.9
|
||||
pkgrel=5
|
||||
_snapshot=4.9-20140604
|
||||
pkgrel=1
|
||||
#_snapshot=4.9-20140604
|
||||
pkgdesc="The GNU Compiler Collection"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL' 'LGPL' 'FDL' 'custom')
|
||||
|
@ -25,11 +25,11 @@ url="http://gcc.gnu.org"
|
|||
makedepends=('binutils>=2.24' 'libmpc' 'cloog' 'doxygen')
|
||||
checkdepends=('dejagnu' 'inetutils')
|
||||
options=('!emptydirs' '!distcc')
|
||||
source=(#ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
|
||||
ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
|
||||
source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
|
||||
#ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
|
||||
gcc-4.8-filename-output.patch
|
||||
gcc-4.9-isl-0.13-hack.patch)
|
||||
md5sums=('57aa4ff81c56262dc89994853c4d0149'
|
||||
md5sums=('fddf71348546af523353bd43d34919c1'
|
||||
'40cb437805e2f7a006aa0d0c3098ab0f'
|
||||
'f26ae06b9cbc8abe86f5ee4dc5737da8')
|
||||
|
||||
|
|
|
@ -11,8 +11,8 @@ noautobuild=1
|
|||
|
||||
pkgname=('libtool' 'libltdl')
|
||||
pkgver=2.4.2
|
||||
_gccver=4.9.0
|
||||
pkgrel=13
|
||||
_gccver=4.9.1
|
||||
pkgrel=14
|
||||
pkgdesc="A generic library support script"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.gnu.org/software/libtool"
|
||||
|
|
|
@ -36,7 +36,7 @@ sha256sums=('571f8cca980f077ae81999aea69a78153422a75e9e6c07ab74ec6659fe0d6ef4'
|
|||
'd506b771e765e09e2e039b975e25befade8eec97e8950813a32463604955ab4e'
|
||||
'9049ab3f9600a1592a54c41a166c76e046c393e1cfe7c4e769155b7317d197ee'
|
||||
'e4ea8e6788163d9f8db8f1f40023db3ea0a1358f9a4510169f2d4c4fe6a887ed'
|
||||
'e9c75dbc86d96efec6f8bb4fea949fafe20d72bfefacc427decbd7fab801bd00')
|
||||
'014a2f160c2f21b854d21c0ae5cd6ad7493586f03cae4399960f75570ee2ce92')
|
||||
|
||||
prepare() {
|
||||
cd comm-esr31
|
||||
|
|
|
@ -1,23 +1,23 @@
|
|||
--- mozilla/configure.orig 2014-02-16 19:18:34.782768334 -0700
|
||||
+++ mozilla/configure 2014-02-16 19:18:53.287522296 -0700
|
||||
@@ -6675,91 +6675,9 @@
|
||||
--- mozilla/configure.orig 2014-07-22 18:38:00.711218733 -0600
|
||||
+++ mozilla/configure 2014-07-22 18:40:37.355699369 -0600
|
||||
@@ -6970,98 +6970,10 @@
|
||||
|
||||
|
||||
|
||||
-if test "$CPU_ARCH" = "arm"; then
|
||||
- echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:6681: checking for ARM SIMD support in compiler" >&5
|
||||
-echo "configure:6976: checking for ARM SIMD support in compiler" >&5
|
||||
- # We try to link so that this also fails when
|
||||
- # building with LTO.
|
||||
- cat > conftest.$ac_ext <<EOF
|
||||
-#line 6685 "configure"
|
||||
-#line 6980 "configure"
|
||||
-#include "confdefs.h"
|
||||
-
|
||||
-int main() {
|
||||
-asm("uqadd8 r1, r1, r2");
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:6692: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
-if { (eval echo configure:6987: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
- rm -rf conftest*
|
||||
- result="yes"
|
||||
-else
|
||||
|
@ -40,23 +40,23 @@
|
|||
- fi
|
||||
-
|
||||
- echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:6715: checking ARM version support in compiler" >&5
|
||||
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9]*\).*/\1/p'`
|
||||
-echo "configure:7010: checking ARM version support in compiler" >&5
|
||||
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9][0-9]*\).*/\1/p'`
|
||||
- echo "$ac_t"""$ARM_ARCH"" 1>&6
|
||||
-
|
||||
- echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:6720: checking for ARM NEON support in compiler" >&5
|
||||
-echo "configure:7015: checking for ARM NEON support in compiler" >&5
|
||||
- # We try to link so that this also fails when
|
||||
- # building with LTO.
|
||||
- cat > conftest.$ac_ext <<EOF
|
||||
-#line 6724 "configure"
|
||||
-#line 7019 "configure"
|
||||
-#include "confdefs.h"
|
||||
-
|
||||
-int main() {
|
||||
-asm(".fpu neon\n vadd.i8 d0, d0, d0");
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:6731: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
-if { (eval echo configure:7026: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
- rm -rf conftest*
|
||||
- result="yes"
|
||||
-else
|
||||
|
@ -79,8 +79,15 @@
|
|||
-
|
||||
- if test -n "$ARM_ARCH"; then
|
||||
- if test "$ARM_ARCH" -lt 7; then
|
||||
- BUILD_ARM_NEON=0
|
||||
- BUILD_ARM_NEON=
|
||||
- else
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' BUILD_ARM_NEON ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define BUILD_ARM_NEON 1
|
||||
-EOF
|
||||
-
|
||||
- BUILD_ARM_NEON=1
|
||||
- fi
|
||||
- fi
|
||||
|
@ -88,33 +95,33 @@
|
|||
-
|
||||
-fi # CPU_ARCH = arm
|
||||
-
|
||||
-
|
||||
|
||||
+HAVE_ARM_NEON=0
|
||||
+BUILD_ARM_NEON=0
|
||||
+HAVE_ARM_SIMD=0
|
||||
|
||||
|
||||
|
||||
--- mozilla/js/src/configure.orig 2014-02-16 19:15:10.325465791 -0700
|
||||
+++ mozilla/js/src/configure 2014-02-16 19:15:28.820223476 -0700
|
||||
@@ -5900,90 +5900,9 @@
|
||||
--- mozilla/js/src/configure.orig 2014-07-22 18:38:00.736218651 -0600
|
||||
+++ mozilla/js/src/configure 2014-07-22 18:41:43.420479891 -0600
|
||||
@@ -6153,99 +6153,9 @@
|
||||
|
||||
|
||||
|
||||
-if test "$CPU_ARCH" = "arm"; then
|
||||
- echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:5906: checking for ARM SIMD support in compiler" >&5
|
||||
-echo "configure:6159: checking for ARM SIMD support in compiler" >&5
|
||||
- # We try to link so that this also fails when
|
||||
- # building with LTO.
|
||||
- cat > conftest.$ac_ext <<EOF
|
||||
-#line 5910 "configure"
|
||||
-#line 6163 "configure"
|
||||
-#include "confdefs.h"
|
||||
-
|
||||
-int main() {
|
||||
-asm("uqadd8 r1, r1, r2");
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:5917: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
-if { (eval echo configure:6170: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
- rm -rf conftest*
|
||||
- result="yes"
|
||||
-else
|
||||
|
@ -137,23 +144,23 @@
|
|||
- fi
|
||||
-
|
||||
- echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:5940: checking ARM version support in compiler" >&5
|
||||
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9]*\).*/\1/p'`
|
||||
-echo "configure:6193: checking ARM version support in compiler" >&5
|
||||
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9][0-9]*\).*/\1/p'`
|
||||
- echo "$ac_t"""$ARM_ARCH"" 1>&6
|
||||
-
|
||||
- echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:5945: checking for ARM NEON support in compiler" >&5
|
||||
-echo "configure:6198: checking for ARM NEON support in compiler" >&5
|
||||
- # We try to link so that this also fails when
|
||||
- # building with LTO.
|
||||
- cat > conftest.$ac_ext <<EOF
|
||||
-#line 5949 "configure"
|
||||
-#line 6202 "configure"
|
||||
-#include "confdefs.h"
|
||||
-
|
||||
-int main() {
|
||||
-asm(".fpu neon\n vadd.i8 d0, d0, d0");
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:5956: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
-if { (eval echo configure:6209: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
- rm -rf conftest*
|
||||
- result="yes"
|
||||
-else
|
||||
|
@ -176,8 +183,15 @@
|
|||
-
|
||||
- if test -n "$ARM_ARCH"; then
|
||||
- if test "$ARM_ARCH" -lt 7; then
|
||||
- BUILD_ARM_NEON=0
|
||||
- BUILD_ARM_NEON=
|
||||
- else
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' BUILD_ARM_NEON ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define BUILD_ARM_NEON 1
|
||||
-EOF
|
||||
-
|
||||
- BUILD_ARM_NEON=1
|
||||
- fi
|
||||
- fi
|
||||
|
@ -185,6 +199,8 @@
|
|||
-
|
||||
-fi # CPU_ARCH = arm
|
||||
-
|
||||
-
|
||||
-
|
||||
+HAVE_ARM_NEON=0
|
||||
+BUILD_ARM_NEON=0
|
||||
+HAVE_ARM_SIMD=0
|
||||
|
|
Loading…
Reference in a new issue