extra/chromium to 67.0.3396.62-1

This commit is contained in:
Kevin Mihelich 2018-05-30 13:06:55 +00:00
parent ce7f45c5de
commit 219e6cc5fc
3 changed files with 79 additions and 27 deletions

View file

@ -0,0 +1,74 @@
From dda2408df2d378873ec2e18c8f20074968d265cf Mon Sep 17 00:00:00 2001
From: Tom Anderson <thomasanderson@chromium.org>
Date: Wed, 16 May 2018 03:23:04 +0000
Subject: [PATCH] Ensure all targets build when target_arch="arm" and
target_os="linux"
Also requires these third party changes:
https://chromium-review.googlesource.com/c/crashpad/crashpad/+/1060155
https://chromium-review.googlesource.com/c/native_client/src/native_client/+/1060158
BUG=843240
R=thakis
TBR=wfh
Change-Id: I9288967e238ab5319e1c963fffd58b9fe4be3692
Reviewed-on: https://chromium-review.googlesource.com/1060129
Commit-Queue: Thomas Anderson <thomasanderson@chromium.org>
Reviewed-by: Nico Weber <thakis@chromium.org>
Cr-Commit-Position: refs/heads/master@{#558953}
---
chrome/installer/linux/rpm/build.sh | 1 +
sandbox/win/src/crosscall_client.h | 3 ++-
third_party/crashpad/crashpad/compat/linux/sys/ptrace.h | 2 +-
3 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/chrome/installer/linux/rpm/build.sh b/chrome/installer/linux/rpm/build.sh
index 261faeaf26f3..67faf75787c6 100755
--- a/chrome/installer/linux/rpm/build.sh
+++ b/chrome/installer/linux/rpm/build.sh
@@ -252,6 +252,7 @@ cd "${OUTPUTDIR}"
case "$TARGETARCH" in
arm )
export ARCHITECTURE="armhf"
+ stage_install_rpm
;;
ia32 )
export ARCHITECTURE="i386"
diff --git a/sandbox/win/src/crosscall_client.h b/sandbox/win/src/crosscall_client.h
index c05e4978c0f1..7bcfb3cfd94e 100644
--- a/sandbox/win/src/crosscall_client.h
+++ b/sandbox/win/src/crosscall_client.h
@@ -8,6 +8,7 @@
#include <stddef.h>
#include <stdint.h>
+#include "base/compiler_specific.h"
#include "sandbox/win/src/crosscall_params.h"
#include "sandbox/win/src/sandbox.h"
@@ -150,7 +151,7 @@ class CopyHelper<const wchar_t*> {
// We provide our not very optimized version of wcslen(), since we don't
// want to risk having the linker use the version in the CRT since the CRT
// might not be present when we do an early IPC call.
- static size_t __cdecl StringLength(const wchar_t* wcs) {
+ static size_t CDECL StringLength(const wchar_t* wcs) {
const wchar_t* eos = wcs;
while (*eos++)
;
diff --git a/third_party/crashpad/crashpad/compat/linux/sys/ptrace.h b/third_party/crashpad/crashpad/compat/linux/sys/ptrace.h
index 73861576d61e..e5c95c7cc859 100644
--- a/third_party/crashpad/crashpad/compat/linux/sys/ptrace.h
+++ b/third_party/crashpad/crashpad/compat/linux/sys/ptrace.h
@@ -34,7 +34,7 @@ static constexpr __ptrace_request PTRACE_GET_THREAD_AREA =
#endif // !PTRACE_GET_THREAD_AREA && !PT_GET_THREAD_AREA && defined(__GLIBC__)
// https://sourceware.org/bugzilla/show_bug.cgi?id=22433
-#if !defined(PTRACE_GETVFPREGS) && \
+#if !defined(PTRACE_GETVFPREGS) && !defined(PT_GETVFPREGS) && \
defined(__GLIBC__) && (defined(__arm__) || defined(__arm64__))
static constexpr __ptrace_request PTRACE_GETVFPREGS =
static_cast<__ptrace_request>(27);
--
2.17.0

View file

@ -16,7 +16,7 @@ highmem=1
noautobuild=1
pkgname=chromium
pkgver=67.0.3396.56
pkgver=67.0.3396.62
pkgrel=1
_launcher_ver=6
pkgdesc="A web browser built for speed, simplicity, and security"
@ -38,14 +38,14 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
chromium-ffmpeg-r1.patch
chromium-widevine-r2.patch
chromium-skia-harmony.patch
skia_buildfix.patch)
sha256sums=('bae1f4b66d9fb219d5217c2f7db661ebf17e995bccd4b2b5f119c90af4c49123'
0001-Ensure-all-targets-build-when-target_arch-arm-and-ta.patch)
sha256sums=('d5ee63932ff1c8c4a5f69c834f6577e7127b416681eddd23bc54886caffd770d'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
'2cc80f5ed8a9b42495a0f3ab3c1bae026b9081972269a1b6d407331d33f7d257'
'aa885330bc4180b78d915f9dfdfc3210038a0acab7b16735ea9828ab6a633bde'
'02c69bb3954087db599def7f5b6d65cf8f7cf2ed81dfbdaa4bb7b51863b4df15'
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
'3da0ab55bf92307fe80ed7c9cce6443f5bebc96ba50e751d24f7302786a0406e')
'9e4d63c582b316edaa550aae6fe6623f0df1a94c53f97bae4b0d7826e0779a32')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
@ -91,7 +91,7 @@ prepare() {
tools/generate_shim_headers/generate_shim_headers.py
# Arch Linux ARM fixes
patch -Np1 -i ../skia_buildfix.patch
patch -p1 -i ../0001-Ensure-all-targets-build-when-target_arch-arm-and-ta.patch
# Build ARMv7 with NEON
[[ $CARCH == "armv7h" ]] && MAKEFLAGS="-j4" && CFLAGS=`echo $CFLAGS | sed -e 's/vfpv3-d16/neon/'` && CXXFLAGS="$CFLAGS"

View file

@ -1,22 +0,0 @@
Index: chromium-browser-65.0.3325.73/third_party/skia/src/jumper/SkJumper_stages.cpp
===================================================================
--- chromium-browser-65.0.3325.73.orig/third_party/skia/src/jumper/SkJumper_stages.cpp
+++ chromium-browser-65.0.3325.73/third_party/skia/src/jumper/SkJumper_stages.cpp
@@ -666,7 +666,7 @@ SI F approx_powf(F x, F y) {
}
SI F from_half(U16 h) {
-#if defined(__aarch64__) && !defined(SK_BUILD_FOR_GOOGLE3) // Temporary workaround for some Google3 builds.
+#if defined(JUMPER_IS_NEON) && defined(__aarch64__) && !defined(SK_BUILD_FOR_GOOGLE3) // Temporary workaround for some Google3 builds.
return vcvt_f32_f16(h);
#elif defined(JUMPER_IS_HSW) || defined(JUMPER_IS_AVX512)
@@ -686,7 +686,7 @@ SI F from_half(U16 h) {
}
SI U16 to_half(F f) {
-#if defined(__aarch64__) && !defined(SK_BUILD_FOR_GOOGLE3) // Temporary workaround for some Google3 builds.
+#if defined(JUMPER_IS_NEON) && defined(__aarch64__) && !defined(SK_BUILD_FOR_GOOGLE3) // Temporary workaround for some Google3 builds.
return vcvt_f16_f32(f);
#elif defined(JUMPER_IS_HSW) || defined(JUMPER_IS_AVX512)