mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
added community/qtcreator, fixes #435
This commit is contained in:
parent
efe8c35d6e
commit
21b42bf96c
5 changed files with 5105 additions and 0 deletions
63
community/qtcreator/PKGBUILD
Normal file
63
community/qtcreator/PKGBUILD
Normal file
|
@ -0,0 +1,63 @@
|
|||
# $Id: PKGBUILD 86795 2013-03-22 10:46:14Z svenstaro $
|
||||
# Maintainer: Imanol Celaya <ornitorrincos@archlinux-es.org>
|
||||
# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
|
||||
# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
|
||||
# Contributor: Dan Vratil <progdan@progdansoft.com>
|
||||
# Contributor: thotypous <matiasΘarchlinux-br·org>
|
||||
# Contributor: delor <bartekpiech gmail com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to upgrade included botan version so it builds on ARM
|
||||
|
||||
pkgname=qtcreator
|
||||
pkgver=2.7.0
|
||||
_pkgver=2.7.0
|
||||
pkgrel=1
|
||||
pkgdesc='Lightweight, cross-platform integrated development environment'
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org'
|
||||
license=('LGPL')
|
||||
depends=('qt5-quick1' 'qt5-tools')
|
||||
makedepends=('git')
|
||||
options=('docs')
|
||||
optdepends=('qt5-doc: for the integrated Qt documentation'
|
||||
'gdb: for the debugger'
|
||||
'cmake: for cmake project support'
|
||||
'openssh-askpass: for ssh support'
|
||||
'git: for git support'
|
||||
'mercurial: for mercurial support'
|
||||
'bzr: for bazaar support'
|
||||
'valgrind: for analyze support')
|
||||
install=qtcreator.install
|
||||
source=("http://releases.qt-project.org/qtcreator/${_pkgver}/qt-creator-${_pkgver}-src.tar.gz"
|
||||
'qtcreator.desktop'
|
||||
'fix-build.patch'
|
||||
'botan-upgrade.patch')
|
||||
md5sums=('7bf25d211ff8babea47c2034f1b93d08'
|
||||
'82888d4be900e7833d768050a135cd37'
|
||||
'4087c00d853addf97ca329d304e9a0a5'
|
||||
'7d71e58bdb7a918adb779b0e527fbba5')
|
||||
|
||||
build() {
|
||||
cd qt-creator-${_pkgver}-src
|
||||
patch -p1 -i "${srcdir}"/fix-build.patch
|
||||
patch -p1 -i "${srcdir}"/botan-upgrade.patch
|
||||
cd ../
|
||||
|
||||
[[ -d build ]] && rm -r build
|
||||
mkdir build && cd build
|
||||
|
||||
qmake ../qt-creator-${_pkgver}-src/qtcreator.pro
|
||||
make
|
||||
make docs -j1
|
||||
}
|
||||
|
||||
package() {
|
||||
cd build
|
||||
|
||||
make INSTALL_ROOT="${pkgdir}/usr/" install
|
||||
make INSTALL_ROOT="${pkgdir}/usr/" install_docs
|
||||
|
||||
install -Dm644 ${srcdir}/qtcreator.desktop ${pkgdir}/usr/share/applications/qtcreator.desktop
|
||||
install -Dm644 ${srcdir}/qt-creator-${_pkgver}-src/LGPL_EXCEPTION.TXT ${pkgdir}/usr/share/licenses/qtcreator/LGPL_EXCEPTION.TXT
|
||||
}
|
5011
community/qtcreator/botan-upgrade.patch
Normal file
5011
community/qtcreator/botan-upgrade.patch
Normal file
File diff suppressed because it is too large
Load diff
10
community/qtcreator/fix-build.patch
Normal file
10
community/qtcreator/fix-build.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- qt-creator-2.6.2-src/qtcreator.pri~ 2013-02-27 13:55:23.818990553 +0000
|
||||
+++ qt-creator-2.6.2-src/qtcreator.pri 2013-02-27 13:55:52.335454428 +0000
|
||||
@@ -147,6 +147,7 @@
|
||||
}
|
||||
|
||||
INCLUDEPATH += \
|
||||
+ /usr/include \
|
||||
$$IDE_BUILD_TREE/src \ # for <app/app_version.h>
|
||||
$$IDE_SOURCE_TREE/src/libs \
|
||||
$$IDE_SOURCE_TREE/tools \
|
9
community/qtcreator/qtcreator.desktop
Normal file
9
community/qtcreator/qtcreator.desktop
Normal file
|
@ -0,0 +1,9 @@
|
|||
[Desktop Entry]
|
||||
Exec=/usr/bin/qtcreator
|
||||
Name=Qt Creator
|
||||
GenericName=C++ IDE
|
||||
X-KDE-StartupNotify=true
|
||||
Icon=/usr/share/icons/hicolor/512x512/apps/QtProject-qtcreator.png
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Categories=Qt;Development;
|
12
community/qtcreator/qtcreator.install
Normal file
12
community/qtcreator/qtcreator.install
Normal file
|
@ -0,0 +1,12 @@
|
|||
post_install() {
|
||||
update-desktop-database -q
|
||||
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
Loading…
Reference in a new issue