extra/qtcreator to 4.10.1-1

This commit is contained in:
Kevin Mihelich 2019-10-08 12:38:48 +00:00
parent 87fa51669c
commit 21ef84ae8e
2 changed files with 21 additions and 5 deletions

View file

@ -12,8 +12,8 @@
buildarch=12
pkgname=qtcreator
pkgver=4.10.0
_clangver=8.0.1
pkgver=4.10.1
_clangver=9.0.0
pkgrel=1
pkgdesc='Lightweight, cross-platform integrated development environment'
arch=(x86_64)
@ -33,9 +33,11 @@ optdepends=('qt5-doc: integrated Qt documentation'
'bzr: bazaar support'
'perf: performer analyzer')
source=("https://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.xz"
qtcreator-preload-plugins.patch)
sha256sums=('8f5d3abc522d8b8879adfa098e037f751b4311173f5f443fd1b5800f5feb0f8a'
'150c444e76ec969fc8765774b648984037829623300d0ce9d41a915b2afa792d')
qtcreator-preload-plugins.patch
qtcreator-clang-9.patch)
sha256sums=('5098d87027bec3296bd93a7e112588759ccb0511fbfdc5558c1a1e83dff8d2a9'
'150c444e76ec969fc8765774b648984037829623300d0ce9d41a915b2afa792d'
'1d66eb008e84459f6570e6e72acedcf80d2f0bb82650df3b733f7ca0a3f08a3d')
prepare() {
mkdir -p build
@ -50,6 +52,8 @@ prepare() {
# see http://code.qt.io/cgit/clang/clang.git/commit/?id=7f349701d3ea0c47be3a43e265699dddd3fd55cf
# and https://bugs.archlinux.org/task/59492
patch -p1 -i ../qtcreator-preload-plugins.patch
# Fix build with clang 9 (Fedora)
patch -p1 -i ../qtcreator-clang-9.patch
}
build() {

View file

@ -0,0 +1,12 @@
diff -rupN qt-creator-opensource-src-4.10.0/src/plugins/clangformat/clangformatutils.cpp qt-creator-opensource-src-4.10.0-new/src/plugins/clangformat/clangformatutils.cpp
--- qt-creator-opensource-src-4.10.0/src/plugins/clangformat/clangformatutils.cpp 2019-09-03 16:36:38.000000000 +0200
+++ qt-creator-opensource-src-4.10.0-new/src/plugins/clangformat/clangformatutils.cpp 2019-09-25 13:33:27.230835047 +0200
@@ -60,7 +60,7 @@ static clang::format::FormatStyle qtcSty
style.AllowShortBlocksOnASingleLine = false;
style.AllowShortCaseLabelsOnASingleLine = false;
style.AllowShortFunctionsOnASingleLine = FormatStyle::SFS_Inline;
- style.AllowShortIfStatementsOnASingleLine = false;
+ style.AllowShortIfStatementsOnASingleLine = FormatStyle::SIS_Never;
style.AllowShortLoopsOnASingleLine = false;
style.AlwaysBreakAfterReturnType = FormatStyle::RTBS_None;
style.AlwaysBreakBeforeMultilineStrings = false;