linux-parallela: kernel-CVE-2016-0728.patch

This commit is contained in:
Jason Plum 2016-01-20 13:40:58 -05:00
parent 59da5e24a8
commit 223da03f57
2 changed files with 85 additions and 1 deletions

View file

@ -10,7 +10,7 @@ _srcname=parallella-linux-${_commit}
_kernelname=${pkgbase#linux}
_desc="Parallella"
pkgver=3.14.12
pkgrel=1
pkgrel=2
arch=('armv7h')
url="https://github.com/parallella/parallella-linux"
license=('GPL2')
@ -20,11 +20,13 @@ source=("https://github.com/parallella/parallella-linux/archive/${_commit}.tar.g
'0001-kernel-add-support-for-gcc-5.patch'
'0002-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch'
'0003-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch'
'kernel-CVE-2016-0728.patch'
'config')
sha256sums=('4b19478f7932294c92c749843c7f68c3d35deb28937f76f4154bec68f83076eb'
'caac03c6d5f8563c80ac7149565c78ee8e452b5a26b97142f98f5951d609eb1d'
'b2056fd871ce391de06cefdb71cdd82f21e4e12694492345e8b89c12d5186611'
'63cf874b765bb8981f15a83a53eb069ee2824f37dbbb4eedce63dbbde0bfb6f8'
'c11bf7442041f2ddaf6aea62b897c0753200aa64ca0e7b9f2c9700ea16326997'
'22ae77f1912b90b4efd38d1dbd417b35111c53bc2dc29c0e89ef17fb2577091b')
prepare() {
@ -33,6 +35,7 @@ prepare() {
git apply ../0001-kernel-add-support-for-gcc-5.patch
git apply ../0002-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch
git apply ../0003-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch
git apply ../kernel-CVE-2016-0728.patch
cat "${srcdir}/config" > ./.config

View file

@ -0,0 +1,81 @@
From 23567fd052a9abb6d67fe8e7a9ccdd9800a540f2 Mon Sep 17 00:00:00 2001
From: Yevgeny Pats <yevgeny@perception-point.io>
Date: Tue, 19 Jan 2016 22:09:04 +0000
Subject: KEYS: Fix keyring ref leak in join_session_keyring()
This fixes CVE-2016-0728.
If a thread is asked to join as a session keyring the keyring that's already
set as its session, we leak a keyring reference.
This can be tested with the following program:
#include <stddef.h>
#include <stdio.h>
#include <sys/types.h>
#include <keyutils.h>
int main(int argc, const char *argv[])
{
int i = 0;
key_serial_t serial;
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
"leaked-keyring");
if (serial < 0) {
perror("keyctl");
return -1;
}
if (keyctl(KEYCTL_SETPERM, serial,
KEY_POS_ALL | KEY_USR_ALL) < 0) {
perror("keyctl");
return -1;
}
for (i = 0; i < 100; i++) {
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
"leaked-keyring");
if (serial < 0) {
perror("keyctl");
return -1;
}
}
return 0;
}
If, after the program has run, there something like the following line in
/proc/keys:
3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
with a usage count of 100 * the number of times the program has been run,
then the kernel is malfunctioning. If leaked-keyring has zero usages or
has been garbage collected, then the problem is fixed.
Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
Signed-off-by: David Howells <dhowells@redhat.com>
Acked-by: Don Zickus <dzickus@redhat.com>
Acked-by: Prarit Bhargava <prarit@redhat.com>
Acked-by: Jarod Wilson <jarod@redhat.com>
Signed-off-by: James Morris <james.l.morris@oracle.com>
---
security/keys/process_keys.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
index a3f85d2..e6d50172 100644
--- a/security/keys/process_keys.c
+++ b/security/keys/process_keys.c
@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
ret = PTR_ERR(keyring);
goto error2;
} else if (keyring == new->session_keyring) {
+ key_put(keyring);
ret = 0;
goto error2;
}
--
cgit v0.12