extra/firefox: fix patch

This commit is contained in:
Kevin Mihelich 2016-06-08 12:58:52 +00:00
parent 81035429e7
commit 226d7bc2b2
2 changed files with 35 additions and 80 deletions

View file

@ -47,7 +47,7 @@ sha256sums=('51936fcf86c5f84e7fdd377d07658a02a1c99d2ebdc3c8aae01d70f947331d12'
'05574c7d0f259da161bcd0e2e8bc9a19401e620ff29439da935d349eebb60efa'
'6e7cba25c52b246da183b8309e7b56208bd991d1a7adb40063c5702a6f3722ea'
'e4ebdd14096d177d264a7993dbd5df46463605ff45f783732c26d30b9caa53a7'
'6d0c1c9ca28b20d206ce24ca84f4d4e3f5d062a2e9cb7445fcb6c2cfea959b4a'
'c1cceeb8875eee7c61289e82c6c6b0f338c045152f3a5e1a8d87bad67548397f'
'32e116fcd3ede2b4074fa169453216ca8ed71f93e67fbdc78e14c308b3f2a99c'
'fb5f84100e01f127160a82797860cb0e04bb6da860a8343963ed45c44740ef0e'
'b73d92a6e96b84464e1f675f8cac730a12cfc9701318a3a9ba46b3d34bfe7cb4')
@ -101,7 +101,7 @@ prepare() {
ln -s /usr/bin/python2 "$srcdir/path/python"
[[ $CARCH == "aarch64" ]] && echo "ac_add_options --disable-gold" >> .mozconfig
patch -Np0 -i ../no-neon.patch
patch -p1 -i ../no-neon.patch
# AArch64 patches
patch -p1 -i ../69f237c2cf91.patch

View file

@ -1,6 +1,35 @@
--- configure.orig 2015-08-07 06:32:41.988366320 -0600
+++ configure 2015-08-08 18:23:31.316475879 -0600
@@ -7137,14 +7137,7 @@
diff -urN a/build/gyp.mozbuild b/build/gyp.mozbuild
--- a/build/gyp.mozbuild 2016-05-12 11:13:12.000000000 -0600
+++ b/build/gyp.mozbuild 2016-06-08 06:53:25.183006599 -0600
@@ -42,7 +42,7 @@
# turn off mandatory use of NEON and instead use NEON detection
'arm_neon': 0,
- 'arm_neon_optional': 1,
+ 'arm_neon_optional': 0,
'moz_widget_toolkit_gonk': 0,
'moz_webrtc_omx': 0,
diff -urN a/mozglue/build/arm.h b/mozglue/build/arm.h
--- a/mozglue/build/arm.h 2016-05-12 11:13:28.000000000 -0600
+++ b/mozglue/build/arm.h 2016-06-08 06:53:25.183006599 -0600
@@ -69,12 +69,6 @@
# endif
# endif
- // When using -mfpu=neon, gcc generates neon instructions.
-
-# if defined(__ARM_NEON__)
-# define MOZILLA_PRESUME_NEON 1
-# endif
-
// Currently we only have CPU detection for Linux via /proc/cpuinfo
# if defined(__linux__) || defined(ANDROID)
# define MOZILLA_ARM_HAVE_CPUID_DETECTION 1
diff -urN a/old-configure b/old-configure
--- a/old-configure 2016-06-04 20:01:04.000000000 -0600
+++ b/old-configure 2016-06-08 06:53:22.463107876 -0600
@@ -7480,14 +7480,7 @@
rm -f conftest*
echo "$ac_t"""$result"" 1>&6
if test "$result" = "yes"; then
@ -16,7 +45,7 @@
fi
echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
@@ -7176,27 +7169,13 @@
@@ -7519,27 +7512,13 @@
rm -f conftest*
echo "$ac_t"""$result"" 1>&6
if test "$result" = "yes"; then
@ -47,77 +76,3 @@
fi
fi
fi
--- js/src/configure.orig 2015-08-07 06:33:02.108365042 -0600
+++ js/src/configure 2015-08-08 18:24:00.676479200 -0600
@@ -6267,14 +6267,7 @@
rm -f conftest*
echo "$ac_t"""$result"" 1>&6
if test "$result" = "yes"; then
- cat >> confdefs.pytmp <<\EOF
- (''' HAVE_ARM_SIMD ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define HAVE_ARM_SIMD 1
-EOF
-
- HAVE_ARM_SIMD=1
+ HAVE_ARM_SIMD=
fi
echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
@@ -6306,27 +6299,13 @@
rm -f conftest*
echo "$ac_t"""$result"" 1>&6
if test "$result" = "yes"; then
- cat >> confdefs.pytmp <<\EOF
- (''' HAVE_ARM_NEON ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define HAVE_ARM_NEON 1
-EOF
-
- HAVE_ARM_NEON=1
+ HAVE_ARM_NEON=
if test -n "$ARM_ARCH"; then
if test "$ARM_ARCH" -lt 7; then
BUILD_ARM_NEON=
else
- cat >> confdefs.pytmp <<\EOF
- (''' BUILD_ARM_NEON ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define BUILD_ARM_NEON 1
-EOF
-
- BUILD_ARM_NEON=1
+ BUILD_ARM_NEON=
fi
fi
fi
--- mozglue/build/arm.h.orig 2015-08-08 18:21:03.686458059 -0600
+++ mozglue/build/arm.h 2015-08-08 18:21:16.781459724 -0600
@@ -69,12 +69,6 @@
# endif
# endif
- // When using -mfpu=neon, gcc generates neon instructions.
-
-# if defined(__ARM_NEON__)
-# define MOZILLA_PRESUME_NEON 1
-# endif
-
// Currently we only have CPU detection for Linux via /proc/cpuinfo
# if defined(__linux__) || defined(ANDROID)
# define MOZILLA_ARM_HAVE_CPUID_DETECTION 1
--- build/gyp.mozbuild.orig 2015-08-08 20:00:38.026946903 -0600
+++ build/gyp.mozbuild 2015-08-08 20:00:45.321915167 -0600
@@ -40,7 +40,7 @@
# turn off mandatory use of NEON and instead use NEON detection
'arm_neon': 0,
- 'arm_neon_optional': 1,
+ 'arm_neon_optional': 0,
'moz_widget_toolkit_gonk': 0,
'moz_webrtc_omx': 0,