mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
alarm/kodi-c1 to 15.alpha2-1
This commit is contained in:
parent
7d624fc9ea
commit
229fc67b80
2 changed files with 5 additions and 88 deletions
|
@ -1,78 +0,0 @@
|
|||
From dbbbf5c4a207d51727b341b6768f76dbe99cb769 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 22 Jan 2015 16:17:02 -0700
|
||||
Subject: [PATCH] Fixes for using giflib 5.1 in GifHelper.cpp
|
||||
|
||||
---
|
||||
.../native/TexturePacker/src/decoder/GifHelper.cpp | 19 ++++++++++++++-----
|
||||
1 file changed, 14 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/tools/depends/native/TexturePacker/src/decoder/GifHelper.cpp b/tools/depends/native/TexturePacker/src/decoder/GifHelper.cpp
|
||||
index 8b65cf6..5529160 100644
|
||||
--- a/tools/depends/native/TexturePacker/src/decoder/GifHelper.cpp
|
||||
+++ b/tools/depends/native/TexturePacker/src/decoder/GifHelper.cpp
|
||||
@@ -82,7 +82,12 @@ GifHelper::GifHelper() :
|
||||
|
||||
GifHelper::~GifHelper()
|
||||
{
|
||||
- int err = DGifCloseFile(m_gif);
|
||||
+ int err;
|
||||
+#if GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
|
||||
+ DGifCloseFile(m_gif, &err);
|
||||
+#else
|
||||
+ err = DGifCloseFile(m_gif);
|
||||
+#endif
|
||||
if (err == D_GIF_ERR_CLOSE_FAILED)
|
||||
{
|
||||
fprintf(stderr, "Gif::~Gif(): D_GIF_ERR_CLOSE_FAILED\n");
|
||||
@@ -119,7 +124,7 @@ bool GifHelper::LoadGifMetaData(GifFileType* file)
|
||||
if (DGifSlurp(m_gif) == GIF_ERROR)
|
||||
{
|
||||
#if GIFLIB_MAJOR >= 5
|
||||
- char* error = GifErrorString(m_gif->Error);
|
||||
+ const char* error = GifErrorString(m_gif->Error);
|
||||
if (error)
|
||||
fprintf(stderr, "Gif::LoadGif(): Could not read file %s - %s\n", m_filename.c_str(), error);
|
||||
#else
|
||||
@@ -190,7 +195,7 @@ bool GifHelper::LoadGifMetaData(const char* file)
|
||||
if (!m_gif)
|
||||
{
|
||||
#if GIFLIB_MAJOR >= 5
|
||||
- char* error = GifErrorString(err);
|
||||
+ const char* error = GifErrorString(err);
|
||||
if (error)
|
||||
fprintf(stderr, "Gif::LoadGif(): Could not open file %s - %s\n", m_filename.c_str(), error);
|
||||
#else
|
||||
@@ -248,7 +253,11 @@ bool GifHelper::IsAnimated(const char* file)
|
||||
{
|
||||
if (DGifSlurp(gif) && gif->ImageCount > 1)
|
||||
m_isAnimated = 1;
|
||||
+#if GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
|
||||
+ DGifCloseFile(gif, NULL);
|
||||
+#else
|
||||
DGifCloseFile(gif);
|
||||
+#endif
|
||||
fclose(gifFile);
|
||||
}
|
||||
}
|
||||
@@ -290,7 +299,7 @@ bool GifHelper::gcbToFrame(GifFrame &frame, unsigned int imgIdx)
|
||||
GraphicsControlBlock gcb;
|
||||
if (!DGifSavedExtensionToGCB(m_gif, imgIdx, &gcb))
|
||||
{
|
||||
- char* error = GifErrorString(m_gif->Error);
|
||||
+ const char* error = GifErrorString(m_gif->Error);
|
||||
if (error)
|
||||
fprintf(stderr, "Gif::ExtractFrames(): Could not read GraphicsControlBlock of frame %d - %s\n", imgIdx, error);
|
||||
else
|
||||
@@ -495,7 +504,7 @@ bool GifHelper::LoadImageFromMemory(unsigned char* buffer, unsigned int bufSize,
|
||||
if (!m_gif)
|
||||
{
|
||||
#if GIFLIB_MAJOR >= 5
|
||||
- char* error = GifErrorString(err);
|
||||
+ const char* error = GifErrorString(err);
|
||||
if (error)
|
||||
fprintf(stderr, "Gif::LoadImageFromMemory(): Could not open gif from memory - %s\n", error);
|
||||
#else
|
||||
--
|
||||
2.2.2
|
||||
|
|
@ -14,10 +14,9 @@ _prefix=/usr
|
|||
|
||||
pkgbase=kodi-c1
|
||||
pkgname=('kodi-c1' 'kodi-c1-eventclients')
|
||||
_commit=92759dc745082bc3a890ce4648e02a37bf221118
|
||||
pkgver=14.0
|
||||
_codename=Helix
|
||||
pkgrel=5
|
||||
_commit=bd5505a1bf162d15b31f67584bfeef3d5b30b1a1
|
||||
pkgver=15.alpha2
|
||||
pkgrel=1
|
||||
arch=('armv7h')
|
||||
url="http://kodi.tv"
|
||||
license=('GPL2')
|
||||
|
@ -30,16 +29,12 @@ makedepends=(
|
|||
'python2-pybluez' 'python2-simplejson' 'rtmpdump' 'sdl2' 'sdl_image'
|
||||
'shairplay' 'smbclient' 'swig' 'taglib' 'tinyxml' 'unzip' 'upower' 'yajl' 'zip'
|
||||
)
|
||||
source=("https://github.com/mdrjr/xbmc/archive/${_commit}.tar.gz"
|
||||
'0001-Fixes-for-using-giflib-5.1-in-GifHelper.cpp.patch')
|
||||
sha256sums=('b644aa417593aa6a2aacee61b856e3419a7bef20a93f5adb0c4b2102c3f5e31d'
|
||||
'54831a777aa6d5f0ca376e4bc0fc52ba0a7cbc074a24793cc0d2c0b02fac551d')
|
||||
source=("https://github.com/mdrjr/xbmc/archive/${_commit}.tar.gz")
|
||||
sha256sums=('f7916ec6da57d6c17fb6b64619b6d820d230c79221c5656089626bfe44762d5c')
|
||||
|
||||
prepare() {
|
||||
cd xbmc-${_commit}
|
||||
|
||||
patch -p1 -i ../0001-Fixes-for-using-giflib-5.1-in-GifHelper.cpp.patch
|
||||
|
||||
find -type f -name *.py -exec sed 's|^#!.*python$|#!/usr/bin/python2|' -i "{}" +
|
||||
sed 's|^#!.*python$|#!/usr/bin/python2|' -i tools/depends/native/rpl-native/rpl
|
||||
sed 's/python/python2/' -i tools/Linux/kodi.sh.in
|
||||
|
|
Loading…
Reference in a new issue