mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/claws-mail to 3.12.0-1
This commit is contained in:
parent
98ebd1c9c0
commit
22a1be7ecd
2 changed files with 6 additions and 69 deletions
|
@ -5,8 +5,8 @@
|
||||||
# - drop valgrind makedepend
|
# - drop valgrind makedepend
|
||||||
|
|
||||||
pkgname=claws-mail
|
pkgname=claws-mail
|
||||||
pkgver=3.11.1
|
pkgver=3.12.0
|
||||||
pkgrel=4
|
pkgrel=1
|
||||||
pkgdesc="A GTK+ based e-mail client."
|
pkgdesc="A GTK+ based e-mail client."
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
license=('GPL3')
|
license=('GPL3')
|
||||||
|
@ -37,20 +37,12 @@ replaces=('sylpheed-claws' 'claws-mail-extra-plugins')
|
||||||
conflicts=('claws-mail-extra-plugins')
|
conflicts=('claws-mail-extra-plugins')
|
||||||
provides=('claws')
|
provides=('claws')
|
||||||
install=claws-mail.install
|
install=claws-mail.install
|
||||||
source=(http://downloads.sourceforge.net/sourceforge/claws-mail/${pkgname}-${pkgver}.tar.xz{,.asc}
|
source=(#http://downloads.sourceforge.net/sourceforge/claws-mail/${pkgname}-${pkgver}.tar.xz{,.asc}
|
||||||
git_fixes.diff)
|
http://www.claws-mail.org/download.php?file=releases/claws-mail-3.12.0.tar.xz{,.asc})
|
||||||
sha1sums=('b0c07906043f7a3ec726c7a96d6dcfc3c148b9cc'
|
md5sums=('73c11bf9f260473abe0e888af19e23b8'
|
||||||
'SKIP'
|
'SKIP')
|
||||||
'0e1bd9d696d531040f7b15b5b6164fc44784fdfc')
|
|
||||||
validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
|
validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd ${pkgname}-${pkgver}
|
|
||||||
# fix .desktop file creation
|
|
||||||
patch -Np1 -i $srcdir/git_fixes.diff
|
|
||||||
autoreconf -vfi
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd ${pkgname}-${pkgver}
|
cd ${pkgname}-${pkgver}
|
||||||
|
|
||||||
|
|
|
@ -1,55 +0,0 @@
|
||||||
From cfde37a35a8b9d54bd680245a7d37a63d6779706 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ricardo Mones <ricardo@mones.org>
|
|
||||||
Date: Tue, 28 Oct 2014 16:59:16 +0100
|
|
||||||
Subject: [PATCH] Fix categories and recover keywords in desktop file
|
|
||||||
|
|
||||||
---
|
|
||||||
claws-mail.desktop | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/claws-mail.desktop b/claws-mail.desktop
|
|
||||||
index 116c9cb..df0bb00 100644
|
|
||||||
--- a/claws-mail.desktop
|
|
||||||
+++ b/claws-mail.desktop
|
|
||||||
@@ -18,7 +18,8 @@ GenericName[sk]=Poštový klient
|
|
||||||
GenericName[sv]=E-postklient
|
|
||||||
Exec=claws-mail %u
|
|
||||||
Icon=claws-mail
|
|
||||||
-Categories=Network;Office;Email;
|
|
||||||
+Categories=Network;Email;
|
|
||||||
+Keywords=lightweight;fast;gui;extensible;plugin;pop;pop3;imap;imap4;nntp;news;
|
|
||||||
Comment=Lightweight and Fast GTK+ based Mail Client
|
|
||||||
Comment[ca]=Client de correu electrònic rà pid i lleuger basat en GTK+
|
|
||||||
Comment[cs]=Lehký a rychlý mailový klient založený na GTK+
|
|
||||||
--
|
|
||||||
1.7.10.4
|
|
||||||
|
|
||||||
From 44131ac697f1a55f65cf3916b0ca09ff8d3c1af8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ricardo Mones <ricardo@mones.org>
|
|
||||||
Date: Tue, 28 Oct 2014 17:20:23 +0100
|
|
||||||
Subject: [PATCH] Recover desktop file installation
|
|
||||||
|
|
||||||
---
|
|
||||||
Makefile.am | 5 +++++
|
|
||||||
1 file changed, 5 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
|
||||||
index 6b221fc..3fdb4aa 100644
|
|
||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -34,6 +34,11 @@ pixmap64_DATA=claws-mail-64x64.png
|
|
||||||
pixmap128dir=$(datadir)/icons/hicolor/128x128/apps
|
|
||||||
pixmap128_DATA=claws-mail-128x128.png
|
|
||||||
|
|
||||||
+# when changing the name or location of the .desktop file,
|
|
||||||
+# also update src/common/Makefile.am
|
|
||||||
+gnomapdir = $(datadir)/applications
|
|
||||||
+gnomap_DATA=claws-mail.desktop
|
|
||||||
+
|
|
||||||
rename-icons:
|
|
||||||
@cd $(DESTDIR)$(datadir)/icons/hicolor/64x64/apps && \
|
|
||||||
mv claws-mail-64x64.png claws-mail.png
|
|
||||||
--
|
|
||||||
1.7.10.4
|
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue