extra/firefox: remove other unneeded patch

This commit is contained in:
Kevin Mihelich 2015-01-14 13:45:46 +00:00
parent 85f7427c37
commit 22f6b94c41
2 changed files with 3 additions and 55 deletions

View file

@ -3,7 +3,7 @@
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix building webrtc
# - remove when bumped upstream
buildarch=20
@ -27,8 +27,7 @@ install=firefox.install
options=('!emptydirs' '!makeflags')
source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.bz2{,.asc}
mozconfig firefox.desktop firefox-install-dir.patch vendor.js rhbz-966424.patch
firefox-fixed-loading-icon.png
arm-webrtc-fix.patch)
firefox-fixed-loading-icon.png)
sha256sums=('bedeb5bbd8b49e5b286497ef7732542c6e7441088fd8cd577d7ca8af4c871e81'
'SKIP'
'ffcb2a0ba2ed08f74931a11043717391ef380234cadccc6f0c13f1186ad80e8b'
@ -36,8 +35,7 @@ sha256sums=('bedeb5bbd8b49e5b286497ef7732542c6e7441088fd8cd577d7ca8af4c871e81'
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
'4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4'
'4f0046b39a8d98f6e4fc3360ec490cb2416e38c7b3e92699f7e511c206c2c961'
'68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213'
'6f81cd3c1d5d96aaeae9882cc24da4fd42ff7ebf25113d9516d5e7c94d375090')
'68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213')
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)

View file

@ -1,50 +0,0 @@
--- media/webrtc/trunk/webrtc/system_wrappers/source/cpu_features.cc.orig 2014-10-17 07:13:02.350686313 -0600
+++ media/webrtc/trunk/webrtc/system_wrappers/source/cpu_features.cc 2014-10-17 07:13:10.430678420 -0600
@@ -18,6 +18,47 @@
#include "webrtc/typedefs.h"
+#include <elf.h>
+#ifdef __arm__
+#include <fcntl.h>
+#include <unistd.h>
+#include <linux/auxvec.h>
+#include <asm/hwcap.h>
+#endif
+
+#ifdef __arm__
+uint64_t WebRtc_GetCPUFeaturesARM() {
+ static bool detected = false;
+ static uint64_t have_neon = 0;
+
+ int fd;
+ Elf32_auxv_t auxv;
+ unsigned int hwcaps;
+
+ if (!detected) {
+ int fd;
+ Elf32_auxv_t auxv;
+ unsigned int hwcaps;
+
+ fd = open("/proc/self/auxv", O_RDONLY);
+ if (fd >= 0) {
+ while (read(fd, &auxv, sizeof(Elf32_auxv_t)) == sizeof(Elf32_auxv_t)) {
+ if (auxv.a_type == AT_HWCAP) {
+ have_neon = (auxv.a_un.a_val & HWCAP_NEON) ? kCPUFeatureNEON : 0;
+ break;
+ }
+ }
+ close (fd);
+ } else {
+ have_neon = 0;
+ }
+ detected = true;
+ }
+
+ return 0 | have_neon; // others here as we need them
+}
+#endif
+
// No CPU feature is available => straight C path.
int GetCPUInfoNoASM(CPUFeature feature) {
(void)feature;