removed community/higan

This commit is contained in:
Kevin Mihelich 2020-03-18 19:39:31 +00:00
parent 8ff115da6c
commit 2306a028d0
4 changed files with 0 additions and 173 deletions

View file

@ -1,38 +0,0 @@
From 26ded571425d3f5b651bdd956013b049bacd718d Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 29 Jan 2017 11:07:56 -0700
Subject: [PATCH] AArch64 fixes
---
libco/sjlj.c | 1 +
nall/intrinsics.hpp | 2 +-
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/libco/sjlj.c b/libco/sjlj.c
index 1d0cb59a..885b1d36 100644
--- a/libco/sjlj.c
+++ b/libco/sjlj.c
@@ -4,6 +4,7 @@
*/
#define LIBCO_C
+#define _XOPEN_SOURCE 700
#include "libco.h"
#include "settings.h"
diff --git a/nall/intrinsics.hpp b/nall/intrinsics.hpp
index e5dcaf64..20ed3460 100644
--- a/nall/intrinsics.hpp
+++ b/nall/intrinsics.hpp
@@ -122,7 +122,7 @@ namespace nall {
#elif defined(__amd64__) || defined(_M_AMD64)
#define PROCESSOR_AMD64
auto Intrinsics::processor() -> Processor { return Processor::amd64; }
-#elif defined(__arm__)
+#elif defined(__arm__) || defined(__aarch64__)
#define PROCESSOR_ARM
auto Intrinsics::processor() -> Processor { return Processor::ARM; }
#elif defined(__ppc64__) || defined(_ARCH_PPC64)
--
2.13.3

View file

@ -1,60 +0,0 @@
# $Id$
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch for AArch64
pkgname=higan
pkgver=106
pkgrel=1
pkgdesc='Nintendo multi-system emulator'
arch=('x86_64')
url='http://byuu.org/'
license=('GPL3')
depends=('alsa-lib' 'cairo' 'gcc-libs' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk2'
'gtksourceview2' 'libao' 'libgl' 'libpulse' 'libx11' 'libxext' 'libxv'
'openal' 'pango' 'sdl'
'libudev.so')
makedepends=('mesa')
conflicts=('higan-gtk' 'higan-qt')
replaces=('higan-gtk' 'higan-qt')
source=("https://download.byuu.org/higan_v${pkgver}-source.7z"
'higan-flags.patch'
'higan-paths.patch'
'0001-AArch64-fixes.patch')
sha256sums=('6564f91f232040c46c052de763dc139e94005e0f2376959fdacbb6ccd3fd6d18'
'6cff6f9570de186bdfa4620d3a2b6e315118b6f6be45b35f3346995865f1718e'
'6d0bf69e00c9ea5c5155b52b5ee59c253f2bacbc64f044826f53d4d6ae175c68'
'0855c62824138ca02a9e775b7a6cca08b2cb20f99ce2713112be1a9d62e23509')
prepare() {
cd higan_v${pkgver}-source
patch -Np1 -i ../higan-flags.patch
patch -Np1 -i ../higan-paths.patch
patch -Np1 -i ../0001-AArch64-fixes.patch
}
build() {
cd higan_v${pkgver}-source
make -C higan
make -C icarus
}
package() {
cd higan_v${pkgver}-source
install -Dm 755 higan/out/higan -t "${pkgdir}"/usr/bin/
install -Dm 644 higan/data/higan.desktop -t "${pkgdir}"/usr/share/applications/
install -Dm 644 higan/data/higan.png -t "${pkgdir}"/usr/share/pixmaps/
cp -dr --no-preserve='ownership' higan/systems "${pkgdir}"/usr/share/higan
install -Dm 755 icarus/out/icarus -t "${pkgdir}"/usr/bin/
install -Dm 644 icarus/data/icarus.desktop -t "${pkgdir}"/usr/share/applications/
install -Dm 644 icarus/data/icarus.png -t "${pkgdir}"/usr/share/pixmaps/
install -dm 755 "${pkgdir}"/usr/share/icarus
cp -dr --no-preserve='ownership' icarus/Database "${pkgdir}"/usr/share/icarus/
}
# vim: ts=2 sw=2 et:

View file

@ -1,49 +0,0 @@
diff -rupN higan_v106-source.orig/higan/GNUmakefile higan_v106-source/higan/GNUmakefile
--- higan_v106-source.orig/higan/GNUmakefile 2017-12-27 23:12:21.263872763 +0100
+++ higan_v106-source/higan/GNUmakefile 2017-12-27 23:12:30.243627883 +0100
@@ -1,4 +1,4 @@
-build := optimize
+build := release
include ../nall/GNUmakefile
binary := application
@@ -26,7 +26,6 @@ else ifneq ($(filter $(platform),linux b
flags += -fopenmp
link += -fopenmp
ifeq ($(binary),application)
- flags += -march=native
link += -Wl,-export-dynamic
link += -lX11 -lXext
else ifeq ($(binary),library)
diff -rupN higan_v106-source.orig/icarus/GNUmakefile higan_v106-source/icarus/GNUmakefile
--- higan_v106-source.orig/icarus/GNUmakefile 2017-12-27 23:12:21.280538976 +0100
+++ higan_v106-source/icarus/GNUmakefile 2017-12-27 23:12:30.243627883 +0100
@@ -1,4 +1,4 @@
-build := optimize
+build := release
include ../nall/GNUmakefile
include ../hiro/GNUmakefile
diff -rupN higan_v106-source.orig/nall/GNUmakefile higan_v106-source/nall/GNUmakefile
--- higan_v106-source.orig/nall/GNUmakefile 2017-12-27 23:12:21.283872217 +0100
+++ higan_v106-source/nall/GNUmakefile 2017-12-27 23:12:44.326577547 +0100
@@ -40,8 +40,8 @@ cflags := -x c -std=c11
objcflags := -x objective-c -std=c11
cppflags := -x c++ -std=c++14
objcppflags := -x objective-c++ -std=c++14
-flags :=
-link :=
+flags := $(CXXFLAGS)
+link := $(LDFLAGS)
# compiler detection
ifeq ($(compiler),)
@@ -120,7 +120,7 @@ ifeq ($(threaded),true)
endif
# paths
-prefix := $(HOME)/.local
+prefix := /usr
# function rwildcard(directory, pattern)
rwildcard = \

View file

@ -1,26 +0,0 @@
diff -rupN higan_v106-source.orig/higan/target-tomoko/tomoko.cpp higan_v106-source/higan/target-tomoko/tomoko.cpp
--- higan_v106-source.orig/higan/target-tomoko/tomoko.cpp 2017-12-27 23:48:31.103245742 +0100
+++ higan_v106-source/higan/target-tomoko/tomoko.cpp 2017-12-27 23:49:19.728586352 +0100
@@ -11,6 +11,9 @@ auto locate(string name) -> string {
location = {Path::config(), "higan/", name};
if(inode::exists(location)) return location;
+ location = {Path::shared(), "higan/", name};
+ if(inode::exists(location)) return location;
+
directory::create({Path::local(), "higan/"});
return {Path::local(), "higan/", name};
}
diff -rupN higan_v106-source.orig/icarus/icarus.cpp higan_v106-source/icarus/icarus.cpp
--- higan_v106-source.orig/icarus/icarus.cpp 2017-12-27 23:48:31.109912227 +0100
+++ higan_v106-source/icarus/icarus.cpp 2017-12-27 23:49:02.672384569 +0100
@@ -11,6 +11,9 @@ auto locate(string name) -> string {
location = {Path::config(), "icarus/", name};
if(inode::exists(location)) return location;
+ location = {Path::shared(), "icarus/", name};
+ if(inode::exists(location)) return location;
+
directory::create({Path::local(), "icarus/"});
return {Path::local(), "icarus/", name};
}