community/openimageio: fix

This commit is contained in:
Kevin Mihelich 2018-03-30 00:32:56 +00:00
parent bed88ac229
commit 23496e2491
2 changed files with 13 additions and 15 deletions

View file

@ -20,7 +20,7 @@ optdepends=('qt4: iv image viewer'
source=(git+git://github.com/OpenImageIO/oiio.git#tag=Release-${pkgver}
atomic.patch)
md5sums=('SKIP'
'883358fbfb7d156f92de3368adbdc488')
'a495ba4917d4a100dab54738c092e029')
prepare() {
cd oiio

View file

@ -1,21 +1,19 @@
diff --git a/src/libOpenImageIO/CMakeLists.txt b/src/libOpenImageIO/CMakeLists.txt
index cedb2f5b..98b8d1fc 100644
--- a/src/libOpenImageIO/CMakeLists.txt
+++ b/src/libOpenImageIO/CMakeLists.txt
@@ -100,7 +100,7 @@ endif ()
target_link_libraries (OpenImageIO
${VISIBILITY_COMMAND} ${VISIBILITY_MAP_COMMAND}
diff -urN a/src/libOpenImageIO/CMakeLists.txt b/src/libOpenImageIO/CMakeLists.txt
--- a/src/libOpenImageIO/CMakeLists.txt 2018-03-29 18:30:02.061880022 -0600
+++ b/src/libOpenImageIO/CMakeLists.txt 2018-03-29 18:31:08.701755694 -0600
@@ -109,7 +109,7 @@
${SANITIZE_LIBRARIES}
${format_plugin_libs} # Add all the target link libraries from the plugins
- ${Boost_LIBRARIES})
+ ${Boost_LIBRARIES} atomic)
${Boost_LIBRARIES}
- ${CMAKE_DL_LIBS})
+ ${CMAKE_DL_LIBS} atomic)
# Include OpenColorIO if using it
diff --git a/src/libutil/CMakeLists.txt b/src/libutil/CMakeLists.txt
index cb00a42c..ef847c20 100644
--- a/src/libutil/CMakeLists.txt
+++ b/src/libutil/CMakeLists.txt
@@ -40,7 +40,7 @@ if (OIIO_BUILD_TESTS)
diff -urN a/src/libutil/CMakeLists.txt b/src/libutil/CMakeLists.txt
--- a/src/libutil/CMakeLists.txt 2018-03-29 18:30:01.021881953 -0600
+++ b/src/libutil/CMakeLists.txt 2018-03-29 18:30:19.753847129 -0600
@@ -46,7 +46,7 @@
add_executable (atomic_test atomic_test.cpp)
set_target_properties (atomic_test PROPERTIES FOLDER "Unit Tests")