removed alarm/xf86-video-armsoc-odroid

This commit is contained in:
Kevin Mihelich 2022-01-01 03:18:31 +00:00
parent 442b58c33b
commit 2376475436
4 changed files with 0 additions and 226 deletions

View file

@ -1,33 +0,0 @@
From 4163e125900d2d24f546f8c9416f6fef1f9e95d1 Mon Sep 17 00:00:00 2001
From: Adam Jackson <ajax@redhat.com>
Date: Tue, 19 Jul 2016 10:21:03 -0400
Subject: [PATCH 1/3] Adapt Block/WakeupHandler signature for ABI 23
Signed-off-by: Adam Jackson <ajax@redhat.com>
---
src/compat-api.h | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/src/compat-api.h b/src/compat-api.h
index fefbc59..78d3c91 100644
--- a/src/compat-api.h
+++ b/src/compat-api.h
@@ -77,9 +77,15 @@
#define SCREEN_INIT_ARGS_DECL ScreenPtr pScreen, int argc, char **argv
+#if ABI_VIDEODRV_VERSION >= SET_ABI_VERSION(23, 0)
+#define BLOCKHANDLER_ARGS_DECL \
+ ScreenPtr arg, pointer pTimeout
+#define BLOCKHANDLER_ARGS arg, pTimeout
+#else
#define BLOCKHANDLER_ARGS_DECL \
ScreenPtr arg, pointer pTimeout, pointer pReadmask
#define BLOCKHANDLER_ARGS arg, pTimeout, pReadmask
+#endif
#define CLOSE_SCREEN_ARGS_DECL ScreenPtr pScreen
#define CLOSE_SCREEN_ARGS pScreen
--
2.17.1

View file

@ -1,101 +0,0 @@
From b24ee793b6c4eb2ae5c5ddb770cb9043f5d22a9d Mon Sep 17 00:00:00 2001
From: Keith Packard <keithp@keithp.com>
Date: Tue, 19 Jul 2016 08:51:12 -0700
Subject: [PATCH 2/3] Use NotifyFd for drm fd
NotifyFd is available after API 22, and must be used after API 23.
Signed-off-by: Keith Packard <keithp@keithp.com>
---
src/compat-api.h | 5 +++++
src/drmmode_display.c | 24 ++++++++++++++++++++++++
2 files changed, 29 insertions(+)
diff --git a/src/compat-api.h b/src/compat-api.h
index 78d3c91..54f9f64 100644
--- a/src/compat-api.h
+++ b/src/compat-api.h
@@ -77,7 +77,12 @@
#define SCREEN_INIT_ARGS_DECL ScreenPtr pScreen, int argc, char **argv
+#if ABI_VIDEODRV_VERSION >= SET_ABI_VERSION(22,0)
+#define HAVE_NOTIFY_FD 1
+#endif
+
#if ABI_VIDEODRV_VERSION >= SET_ABI_VERSION(23, 0)
+#define RELOAD_CURSORS_DEPRECATED 1
#define BLOCKHANDLER_ARGS_DECL \
ScreenPtr arg, pointer pTimeout
#define BLOCKHANDLER_ARGS arg, pTimeout
diff --git a/src/drmmode_display.c b/src/drmmode_display.c
index 1b47632..b64bf71 100644
--- a/src/drmmode_display.c
+++ b/src/drmmode_display.c
@@ -376,9 +376,11 @@ done_setting:
drmmode_output_dpms(output, DPMSModeOn);
}
+#if !RELOAD_CURSORS_DEPRECATED
/* if hw cursor is initialized, reload it */
if (drmmode->cursor)
xf86_reload_cursors(pScrn->pScreen);
+#endif
cleanup:
if (newcrtc)
@@ -1846,6 +1848,13 @@ drmmode_uevent_fini(ScrnInfoPtr pScrn)
TRACE_EXIT();
}
+#if HAVE_NOTIFY_FD
+static void
+drmmode_notify_fd(int fd, int notify, void *data)
+{
+ drmHandleEvent(fd, &event_context);
+}
+#else
static void
drmmode_wakeup_handler(pointer data, int err, pointer p)
{
@@ -1861,6 +1870,7 @@ drmmode_wakeup_handler(pointer data, int err, pointer p)
if (FD_ISSET(drmmode->fd, read_mask))
drmHandleEvent(drmmode->fd, &event_context);
}
+#endif
void
drmmode_wait_for_event(ScrnInfoPtr pScrn)
@@ -1876,15 +1886,29 @@ drmmode_screen_init(ScrnInfoPtr pScrn)
drmmode_uevent_init(pScrn);
+#if HAVE_NOTIFY_FD
+ SetNotifyFd(drmmode->fd, drmmode_notify_fd, X_NOTIFY_READ, NULL);
+#else
AddGeneralSocket(drmmode->fd);
/* Register a wakeup handler to get informed on DRM events */
RegisterBlockAndWakeupHandlers((BlockHandlerProcPtr)NoopDDA,
drmmode_wakeup_handler, pScrn);
+#endif
}
void
drmmode_screen_fini(ScrnInfoPtr pScrn)
{
+ struct drmmode_rec *drmmode = drmmode_from_scrn(pScrn);
+
+#if HAVE_NOTIFY_FD
+ RemoveNotifyFd(drmmode->fd);
+#else
+ RemoveBlockAndWakeupHandlers((BlockHandlerProcPtr)NoopDDA,
+ drmmode_wakeup_handler, pScrn);
+ RemoveGeneralSocket(drmmode->fd);
+#endif
+
drmmode_uevent_fini(pScrn);
}
--
2.17.1

View file

@ -1,36 +0,0 @@
From f83caedccd856db42de89d265b96b912fa02fd69 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 14 Jun 2018 11:59:02 -0600
Subject: [PATCH 3/3] Initialize XRandR before EnterVT
---
src/armsoc_driver.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/armsoc_driver.c b/src/armsoc_driver.c
index 7e70f34..5ffb64a 100644
--- a/src/armsoc_driver.c
+++ b/src/armsoc_driver.c
@@ -1105,6 +1105,9 @@ ARMSOCScreenInit(SCREEN_INIT_ARGS_DECL)
*/
pScrn->vtSema = TRUE;
+ /* Do some XRandR initialization. Return value is not useful */
+ (void)xf86CrtcScreenInit(pScreen);
+
/* Take over the virtual terminal from the console, set the
* desired mode, etc.:
*/
@@ -1113,9 +1116,6 @@ ARMSOCScreenInit(SCREEN_INIT_ARGS_DECL)
goto fail6;
}
- /* Do some XRandR initialization. Return value is not useful */
- (void)xf86CrtcScreenInit(pScreen);
-
if (!miCreateDefColormap(pScreen)) {
ERROR_MSG("Cannot create colormap!");
goto fail7;
--
2.17.1

View file

@ -1,56 +0,0 @@
# ARMSoC Mali FrameBuffer driver for ODROID
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
buildarch=4
pkgname=xf86-video-armsoc-odroid
pkgver=240.78c3cda
pkgrel=4
pkgdesc='X.org graphics driver for ARM graphics - Exynos ODROID'
arch=('armv7h')
url="https://github.com/mdrjr/xf86-video-armsoc/tree/r4p0"
license=('GPL2')
makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=24.0' 'git')
conflicts=('xorg-server<1.20' 'X-ABI-VIDEODRV_VERSION<24' 'X-ABI-VIDEODRV_VERSION>=25' 'xf86-video-armsoc')
provides=(xf86-video-armsoc)
source=("$pkgname::git+https://github.com/mdrjr/xf86-video-armsoc.git#branch=r4p0"
'0001-Adapt-Block-WakeupHandler-signature-for-ABI-23.patch'
'0002-Use-NotifyFd-for-drm-fd.patch'
'0003-Initialize-XRandR-before-EnterVT.patch')
md5sums=('SKIP'
'2cf86d77a14940d24e6aacfb22cd3432'
'abaa79ea09ebf88151e8c74b75f48ac4'
'17d36d2a9c29b9ae467f67dba64ce524')
pkgver() {
cd $pkgname
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
prepare() {
cd $pkgname
git apply ../0001-Adapt-Block-WakeupHandler-signature-for-ABI-23.patch
git apply ../0002-Use-NotifyFd-for-drm-fd.patch
git apply ../0003-Initialize-XRandR-before-EnterVT.patch
}
build() {
cd $pkgname
# Since pacman 5.0.2-2, hardened flags are now enabled in makepkg.conf
# With them, module fail to load with undefined symbol.
# See https://bugs.archlinux.org/task/55102 / https://bugs.archlinux.org/task/54845
export CFLAGS=${CFLAGS/-fno-plt}
export CXXFLAGS=${CXXFLAGS/-fno-plt}
export LDFLAGS=${LDFLAGS/,-z,now}
CFLAGS=`echo $CFLAGS | sed -e 's/vfpv3-d16/neon/'` && CXXFLAGS="$CFLAGS"
./autogen.sh --prefix=/usr --with-drmmode=exynos
make
}
package() {
cd $pkgname
make DESTDIR="${pkgdir}" install
}