extra/gstreamer0.10-bad to 0.10.23-6

This commit is contained in:
WarheadsSE 2013-12-12 16:22:46 -05:00
parent 63fefc6450
commit 2390588395
3 changed files with 46 additions and 15 deletions

View file

@ -7,22 +7,33 @@
pkgbase=gstreamer0.10-bad
pkgname=('gstreamer0.10-bad' 'gstreamer0.10-bad-plugins')
pkgver=0.10.23
pkgrel=5
pkgrel=6
arch=('i686' 'x86_64')
license=('LGPL' 'GPL')
makedepends=('pkgconfig' 'gstreamer0.10-base>=0.10.36' 'xvidcore' 'libdca' 'bzip2' 'libdc1394' 'neon' 'faac' 'musicbrainz' 'faad2' 'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa' 'soundtouch' 'libvdpau' 'schroedinger' 'libass' 'libvpx' 'gsm' 'libgme' 'rtmpdump' 'libsndfile' 'librsvg' 'wildmidi' 'opus')
makedepends=('pkgconfig' 'gstreamer0.10-base>=0.10.36' 'xvidcore' 'libdca' 'bzip2' 'libdc1394' 'neon' 'faac' 'musicbrainz' 'faad2' 'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa' 'soundtouch' 'libvdpau' 'schroedinger' 'libass' 'libvpx' 'gsm' 'libgme' 'rtmpdump' 'libsndfile' 'librsvg' 'wildmidi' 'opus' 'git' 'spandsp' 'celt')
url="http://gstreamer.freedesktop.org/"
options=(!libtool !emptydirs)
source=(${url}/src/gst-plugins-bad/gst-plugins-bad-${pkgver}.tar.xz)
md5sums=('e4822fa2cc933768e2998311a1565979')
source=("git://anongit.freedesktop.org/gstreamer-sdk/gst-plugins-bad#commit=57569a4854a0f2d14ef19a8264a4ae9a7a1d1125"
disable-assrender-test.patch
disable-camerabin-test.patch)
sha256sums=('SKIP'
'e66642affa6c0e69837d37615010e67e59ef3d672663303d46c1e2591e2ddfc6'
'01e780ddf1f8161a6115dded9dc5bf4bdd4d09a9eee00fa423b1330e90e76c68')
prepare() {
cd gst-plugins-bad
sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' -i configure.ac
patch -Np1 -i ../disable-assrender-test.patch
patch -Np1 -i ../disable-camerabin-test.patch
}
build() {
cd "${srcdir}/gst-plugins-bad-${pkgver}"
cd gst-plugins-bad
NOCONFIGURE=1 ./autogen.sh
[[ $CARCH == 'arm' ]] && CONFIG="--disable-soundtouch"
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--disable-static --enable-experimental \
--disable-static --enable-experimental --disable-gtk-doc \
--with-package-name="GStreamer Bad Plugins (Archlinux)" \
--with-package-origin="http://www.archlinux.org/" $CONFIG
@ -30,27 +41,26 @@ build() {
sed -e 's/gst sys ext/gst/' -i Makefile
}
# Disable for now: 2 tests fail, one of them is because of not having a camera during build.
#check() {
# cd "${srcdir}/gst-plugins-bad-${pkgver}"
# make check
#}
check() {
cd gst-plugins-bad
make check
}
package_gstreamer0.10-bad() {
pkgdesc="GStreamer Multimedia Framework Bad Plugin libraries (gst-plugins-bad)"
depends=('gstreamer0.10-base>=0.10.34')
cd "${srcdir}/gst-plugins-bad-${pkgver}"
cd gst-plugins-bad
make DESTDIR="${pkgdir}" install
}
package_gstreamer0.10-bad-plugins() {
pkgdesc="GStreamer Multimedia Framework Bad Plugins (gst-plugins-bad)"
depends=("gstreamer0.10-bad=${pkgver}" 'xvidcore' 'libdca' 'bzip2' 'libdc1394' 'neon' 'faac' 'musicbrainz' 'faad2' 'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa' 'libvdpau' 'soundtouch' 'libass' 'schroedinger' 'libvpx' 'gsm' 'rtmpdump' 'libgme' 'libsndfile' 'librsvg' 'wildmidi' 'opus')
depends=("gstreamer0.10-bad=${pkgver}" 'xvidcore' 'libdca' 'bzip2' 'libdc1394' 'neon' 'faac' 'musicbrainz' 'faad2' 'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa' 'libvdpau' 'soundtouch' 'libass' 'schroedinger' 'libvpx' 'gsm' 'rtmpdump' 'libgme' 'libsndfile' 'librsvg' 'wildmidi' 'opus' 'celt' 'spandsp')
groups=('gstreamer0.10-plugins')
install=gstreamer0.10-bad-plugins.install
cd "${srcdir}/gst-plugins-bad-${pkgver}"
cd gst-plugins-bad
make -C gst-libs DESTDIR="${pkgdir}" install
make -C ext DESTDIR="${pkgdir}" install
make -C sys DESTDIR="${pkgdir}" install

View file

@ -0,0 +1,11 @@
--- a/tests/check/elements/assrender.c
+++ b/tests/check/elements/assrender.c
@@ -289,8 +289,6 @@ assrender_suite (void)
tcase_set_timeout (tc_chain, 120);
suite_add_tcase (s, tc_chain);
- tcase_add_test (tc_chain, test_assrender_basic_xRGB);
- tcase_add_test (tc_chain, test_assrender_basic_I420);
return s;
}

View file

@ -0,0 +1,10 @@
--- gst-plugins-bad/tests/check/Makefile.am.orig 2013-12-10 22:01:50.504567189 +0000
+++ gst-plugins-bad/tests/check/Makefile.am 2013-12-10 22:02:17.081058500 +0000
@@ -181,7 +181,6 @@
elements/autovideoconvert \
elements/asfmux \
elements/baseaudiovisualizer \
- elements/camerabin \
elements/camerabin2 \
elements/dataurisrc \
elements/legacyresample \