|
|
|
@ -1,17 +1,17 @@
|
|
|
|
|
From 42930e86f6f0d4be217c6822507e1ef739a1ae00 Mon Sep 17 00:00:00 2001
|
|
|
|
|
From 9bfd3e6c96c0886b17c2b7bbd41d6a57d1739e73 Mon Sep 17 00:00:00 2001
|
|
|
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
|
|
|
Date: Sat, 7 Feb 2015 12:32:27 +0100
|
|
|
|
|
Subject: [PATCH 8/8] USB armory support
|
|
|
|
|
|
|
|
|
|
---
|
|
|
|
|
arch/arm/boot/dts/Makefile | 5 +
|
|
|
|
|
arch/arm/boot/dts/imx53-usbarmory-common.dtsi | 241 ++++++++++++++++++++++++++
|
|
|
|
|
arch/arm/boot/dts/imx53-usbarmory-gpio.dts | 26 +++
|
|
|
|
|
arch/arm/boot/dts/imx53-usbarmory-host.dts | 18 ++
|
|
|
|
|
arch/arm/boot/dts/imx53-usbarmory-i2c.dts | 32 ++++
|
|
|
|
|
arch/arm/boot/dts/imx53-usbarmory-spi.dts | 45 +++++
|
|
|
|
|
arch/arm/boot/dts/imx53-usbarmory.dts | 18 ++
|
|
|
|
|
7 files changed, 385 insertions(+)
|
|
|
|
|
arch/arm/boot/dts/imx53-usbarmory-common.dtsi | 286 ++++++++++++++++++++++++++
|
|
|
|
|
arch/arm/boot/dts/imx53-usbarmory-gpio.dts | 62 ++++++
|
|
|
|
|
arch/arm/boot/dts/imx53-usbarmory-host.dts | 54 +++++
|
|
|
|
|
arch/arm/boot/dts/imx53-usbarmory-i2c.dts | 68 ++++++
|
|
|
|
|
arch/arm/boot/dts/imx53-usbarmory-spi.dts | 81 ++++++++
|
|
|
|
|
arch/arm/boot/dts/imx53-usbarmory.dts | 54 +++++
|
|
|
|
|
7 files changed, 610 insertions(+)
|
|
|
|
|
create mode 100644 arch/arm/boot/dts/imx53-usbarmory-common.dtsi
|
|
|
|
|
create mode 100644 arch/arm/boot/dts/imx53-usbarmory-gpio.dts
|
|
|
|
|
create mode 100644 arch/arm/boot/dts/imx53-usbarmory-host.dts
|
|
|
|
@ -20,7 +20,7 @@ Subject: [PATCH 8/8] USB armory support
|
|
|
|
|
create mode 100644 arch/arm/boot/dts/imx53-usbarmory.dts
|
|
|
|
|
|
|
|
|
|
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
|
|
|
|
index 2878a62..f6b3d97 100644
|
|
|
|
|
index 939686c..e5cc351 100644
|
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
|
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
|
|
|
@@ -303,6 +303,11 @@ dtb-$(CONFIG_SOC_IMX53) += \
|
|
|
|
@ -37,18 +37,54 @@ index 2878a62..f6b3d97 100644
|
|
|
|
|
imx6dl-apf6dev.dtb \
|
|
|
|
|
diff --git a/arch/arm/boot/dts/imx53-usbarmory-common.dtsi b/arch/arm/boot/dts/imx53-usbarmory-common.dtsi
|
|
|
|
|
new file mode 100644
|
|
|
|
|
index 0000000..6f9ca1d
|
|
|
|
|
index 0000000..87621a5
|
|
|
|
|
--- /dev/null
|
|
|
|
|
+++ b/arch/arm/boot/dts/imx53-usbarmory-common.dtsi
|
|
|
|
|
@@ -0,0 +1,241 @@
|
|
|
|
|
@@ -0,0 +1,286 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * USB armory MkI device tree include file
|
|
|
|
|
+ * http://inversepath.com/usbarmory
|
|
|
|
|
+ * https://inversepath.com/usbarmory
|
|
|
|
|
+ *
|
|
|
|
|
+ * Copyright (C) 2015, Inverse Path
|
|
|
|
|
+ * Andrej Rosano <andrej@inversepath.com>
|
|
|
|
|
+ *
|
|
|
|
|
+ * Licensed under GPLv2
|
|
|
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
|
|
|
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
|
|
|
+ * licensing only applies to this file, and not this project as a
|
|
|
|
|
+ * whole.
|
|
|
|
|
+ *
|
|
|
|
|
+ * a) This file is free software; you can redistribute it and/or
|
|
|
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
|
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
|
|
|
+ * License, or (at your option) any later version.
|
|
|
|
|
+ *
|
|
|
|
|
+ * This file is distributed in the hope that it will be useful,
|
|
|
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
|
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
|
|
|
+ * GNU General Public License for more details.
|
|
|
|
|
+ *
|
|
|
|
|
+ * Or, alternatively,
|
|
|
|
|
+ *
|
|
|
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
|
|
|
+ * obtaining a copy of this software and associated documentation
|
|
|
|
|
+ * files (the "Software"), to deal in the Software without
|
|
|
|
|
+ * restriction, including without limitation the rights to use,
|
|
|
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
|
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
|
|
|
+ * Software is furnished to do so, subject to the following
|
|
|
|
|
+ * conditions:
|
|
|
|
|
+ *
|
|
|
|
|
+ * The above copyright notice and this permission notice shall be
|
|
|
|
|
+ * included in all copies or substantial portions of the Software.
|
|
|
|
|
+ *
|
|
|
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
|
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
|
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
|
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
|
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
|
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
|
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
|
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
|
|
|
+ */
|
|
|
|
|
+
|
|
|
|
|
+#include "imx53.dtsi"
|
|
|
|
@ -74,20 +110,18 @@ index 0000000..6f9ca1d
|
|
|
|
|
+
|
|
|
|
|
+ user {
|
|
|
|
|
+ label = "LED";
|
|
|
|
|
+ gpios = <&gpio4 27 GPIO_ACTIVE_LOW>;
|
|
|
|
|
+ gpios = <&gpio4 27 0>;
|
|
|
|
|
+ linux,default-trigger = "heartbeat";
|
|
|
|
|
+ };
|
|
|
|
|
+ };
|
|
|
|
|
+
|
|
|
|
|
+ soc {
|
|
|
|
|
+ aips@60000000 {
|
|
|
|
|
+ sahara: crypto@63ff8000 {
|
|
|
|
|
+ compatible = "fsl,imx53-sahara";
|
|
|
|
|
+ reg = <0x63ff8000 0x4000>;
|
|
|
|
|
+ interrupts = <19 20>;
|
|
|
|
|
+ clocks = <&clks IMX5_CLK_SAHARA_IPG_GATE>,
|
|
|
|
|
+ <&clks IMX5_CLK_SAHARA_IPG_GATE>;
|
|
|
|
|
+ clock-names = "ipg", "ahb";
|
|
|
|
|
+ scc2: scc2@63fb4000 {
|
|
|
|
|
+ compatible = "fsl,imx53-scc2";
|
|
|
|
|
+ reg = <0x63fb4000 0x4000>,
|
|
|
|
|
+ <0x07000000 0x4000>;
|
|
|
|
|
+ interrupts = <21 23>;
|
|
|
|
|
+ };
|
|
|
|
|
+ };
|
|
|
|
|
+ };
|
|
|
|
@ -120,7 +154,7 @@ index 0000000..6f9ca1d
|
|
|
|
|
+ imx53-usbarmory {
|
|
|
|
|
+ led_pin_gpio4_27: led_gpio4_27@0 {
|
|
|
|
|
+ fsl,pins = <
|
|
|
|
|
+ MX53_PAD_DISP0_DAT6__GPIO4_27 0x80000000
|
|
|
|
|
+ MX53_PAD_DISP0_DAT6__GPIO4_27 0x0
|
|
|
|
|
+ >;
|
|
|
|
|
+ };
|
|
|
|
|
+
|
|
|
|
@ -137,8 +171,8 @@ index 0000000..6f9ca1d
|
|
|
|
|
+
|
|
|
|
|
+ pinctrl_i2c1_pmic: i2c1grp_pmic {
|
|
|
|
|
+ fsl,pins = <
|
|
|
|
|
+ MX53_PAD_EIM_D21__I2C1_SCL 0xc0000000
|
|
|
|
|
+ MX53_PAD_EIM_D28__I2C1_SDA 0xc0000000
|
|
|
|
|
+ MX53_PAD_EIM_D21__I2C1_SCL 0x0
|
|
|
|
|
+ MX53_PAD_EIM_D28__I2C1_SDA 0x0
|
|
|
|
|
+ >;
|
|
|
|
|
+ };
|
|
|
|
|
+
|
|
|
|
@ -176,11 +210,26 @@ index 0000000..6f9ca1d
|
|
|
|
|
+ */
|
|
|
|
|
+ pinctrl_ecspi2: ecspi2grp {
|
|
|
|
|
+ fsl,pins = <
|
|
|
|
|
+ MX53_PAD_CSI0_DAT8__ECSPI2_SCLK 0x80000000
|
|
|
|
|
+ MX53_PAD_CSI0_DAT9__ECSPI2_MOSI 0x80000000
|
|
|
|
|
+ MX53_PAD_CSI0_DAT10__ECSPI2_MISO 0x80000000
|
|
|
|
|
+ MX53_PAD_CSI0_DAT11__GPIO5_29 0x80000000
|
|
|
|
|
+ MX53_PAD_CSI0_DAT12__GPIO5_30 0x80000000
|
|
|
|
|
+ MX53_PAD_CSI0_DAT8__ECSPI2_SCLK 0x0
|
|
|
|
|
+ MX53_PAD_CSI0_DAT9__ECSPI2_MOSI 0x0
|
|
|
|
|
+ MX53_PAD_CSI0_DAT10__ECSPI2_MISO 0x0
|
|
|
|
|
+ MX53_PAD_CSI0_DAT11__GPIO5_29 0x0
|
|
|
|
|
+ MX53_PAD_CSI0_DAT12__GPIO5_30 0x0
|
|
|
|
|
+ >;
|
|
|
|
|
+ };
|
|
|
|
|
+
|
|
|
|
|
+ /*
|
|
|
|
|
+ WILC1000 wifi module pin header configuration:
|
|
|
|
|
+ 1 2 3 4 5 6 7
|
|
|
|
|
+ GND 5V SCLK MOSI MISO /SS0 GPIO_IRQ
|
|
|
|
|
+ */
|
|
|
|
|
+ pinctrl_wilc1000: wilc1000grp {
|
|
|
|
|
+ fsl,pins = <
|
|
|
|
|
+ MX53_PAD_CSI0_DAT8__ECSPI2_SCLK 0x0
|
|
|
|
|
+ MX53_PAD_CSI0_DAT9__ECSPI2_MOSI 0x0
|
|
|
|
|
+ MX53_PAD_CSI0_DAT10__ECSPI2_MISO 0x0
|
|
|
|
|
+ MX53_PAD_CSI0_DAT11__GPIO5_29 0x0
|
|
|
|
|
+ MX53_PAD_CSI0_DAT12__GPIO5_30 0xc0
|
|
|
|
|
+ >;
|
|
|
|
|
+ };
|
|
|
|
|
+
|
|
|
|
@ -191,11 +240,11 @@ index 0000000..6f9ca1d
|
|
|
|
|
+ */
|
|
|
|
|
+ pinctrl_i2c1_pinheader: i2c1grp_pinheader {
|
|
|
|
|
+ fsl,pins = <
|
|
|
|
|
+ MX53_PAD_CSI0_DAT8__I2C1_SDA 0xc0000000
|
|
|
|
|
+ MX53_PAD_CSI0_DAT9__I2C1_SCL 0xc0000000
|
|
|
|
|
+ MX53_PAD_CSI0_DAT10__GPIO5_28 0x80000000
|
|
|
|
|
+ MX53_PAD_CSI0_DAT11__GPIO5_29 0x80000000
|
|
|
|
|
+ MX53_PAD_CSI0_DAT12__GPIO5_30 0x80000000
|
|
|
|
|
+ MX53_PAD_CSI0_DAT8__I2C1_SDA 0x0
|
|
|
|
|
+ MX53_PAD_CSI0_DAT9__I2C1_SCL 0x0
|
|
|
|
|
+ MX53_PAD_CSI0_DAT10__GPIO5_28 0xc0
|
|
|
|
|
+ MX53_PAD_CSI0_DAT11__GPIO5_29 0xc0
|
|
|
|
|
+ MX53_PAD_CSI0_DAT12__GPIO5_30 0xc0
|
|
|
|
|
+ >;
|
|
|
|
|
+ };
|
|
|
|
|
+ };
|
|
|
|
@ -207,10 +256,6 @@ index 0000000..6f9ca1d
|
|
|
|
|
+ status = "okay";
|
|
|
|
|
+};
|
|
|
|
|
+
|
|
|
|
|
+&vpu {
|
|
|
|
|
+ status = "okay";
|
|
|
|
|
+};
|
|
|
|
|
+
|
|
|
|
|
+&i2c1 {
|
|
|
|
|
+ pinctrl-0 = <&pinctrl_i2c1_pmic>;
|
|
|
|
|
+ status = "okay";
|
|
|
|
@ -284,18 +329,54 @@ index 0000000..6f9ca1d
|
|
|
|
|
+};
|
|
|
|
|
diff --git a/arch/arm/boot/dts/imx53-usbarmory-gpio.dts b/arch/arm/boot/dts/imx53-usbarmory-gpio.dts
|
|
|
|
|
new file mode 100644
|
|
|
|
|
index 0000000..a27c759
|
|
|
|
|
index 0000000..8d54dd2
|
|
|
|
|
--- /dev/null
|
|
|
|
|
+++ b/arch/arm/boot/dts/imx53-usbarmory-gpio.dts
|
|
|
|
|
@@ -0,0 +1,26 @@
|
|
|
|
|
@@ -0,0 +1,62 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * USB armory MkI device mode device tree file
|
|
|
|
|
+ * http://inversepath.com/usbarmory
|
|
|
|
|
+ * USB armory MkI device tree file
|
|
|
|
|
+ * https://inversepath.com/usbarmory
|
|
|
|
|
+ *
|
|
|
|
|
+ * Copyright (C) 2015, Inverse Path
|
|
|
|
|
+ * Andrej Rosano <andrej@inversepath.com>
|
|
|
|
|
+ *
|
|
|
|
|
+ * Licensed under GPLv2
|
|
|
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
|
|
|
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
|
|
|
+ * licensing only applies to this file, and not this project as a
|
|
|
|
|
+ * whole.
|
|
|
|
|
+ *
|
|
|
|
|
+ * a) This file is free software; you can redistribute it and/or
|
|
|
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
|
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
|
|
|
+ * License, or (at your option) any later version.
|
|
|
|
|
+ *
|
|
|
|
|
+ * This file is distributed in the hope that it will be useful,
|
|
|
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
|
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
|
|
|
+ * GNU General Public License for more details.
|
|
|
|
|
+ *
|
|
|
|
|
+ * Or, alternatively,
|
|
|
|
|
+ *
|
|
|
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
|
|
|
+ * obtaining a copy of this software and associated documentation
|
|
|
|
|
+ * files (the "Software"), to deal in the Software without
|
|
|
|
|
+ * restriction, including without limitation the rights to use,
|
|
|
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
|
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
|
|
|
+ * Software is furnished to do so, subject to the following
|
|
|
|
|
+ * conditions:
|
|
|
|
|
+ *
|
|
|
|
|
+ * The above copyright notice and this permission notice shall be
|
|
|
|
|
+ * included in all copies or substantial portions of the Software.
|
|
|
|
|
+ *
|
|
|
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
|
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
|
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
|
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
|
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
|
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
|
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
|
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
|
|
|
+ */
|
|
|
|
|
+
|
|
|
|
|
+/dts-v1/;
|
|
|
|
@ -316,18 +397,54 @@ index 0000000..a27c759
|
|
|
|
|
+};
|
|
|
|
|
diff --git a/arch/arm/boot/dts/imx53-usbarmory-host.dts b/arch/arm/boot/dts/imx53-usbarmory-host.dts
|
|
|
|
|
new file mode 100644
|
|
|
|
|
index 0000000..ea2ea45
|
|
|
|
|
index 0000000..d4e3b4c
|
|
|
|
|
--- /dev/null
|
|
|
|
|
+++ b/arch/arm/boot/dts/imx53-usbarmory-host.dts
|
|
|
|
|
@@ -0,0 +1,18 @@
|
|
|
|
|
@@ -0,0 +1,54 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * USB armory MkI host mode device tree file
|
|
|
|
|
+ * http://inversepath.com/usbarmory
|
|
|
|
|
+ * USB armory MkI device tree file
|
|
|
|
|
+ * https://inversepath.com/usbarmory
|
|
|
|
|
+ *
|
|
|
|
|
+ * Copyright (C) 2015, Inverse Path
|
|
|
|
|
+ * Andrej Rosano <andrej@inversepath.com>
|
|
|
|
|
+ *
|
|
|
|
|
+ * Licensed under GPLv2
|
|
|
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
|
|
|
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
|
|
|
+ * licensing only applies to this file, and not this project as a
|
|
|
|
|
+ * whole.
|
|
|
|
|
+ *
|
|
|
|
|
+ * a) This file is free software; you can redistribute it and/or
|
|
|
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
|
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
|
|
|
+ * License, or (at your option) any later version.
|
|
|
|
|
+ *
|
|
|
|
|
+ * This file is distributed in the hope that it will be useful,
|
|
|
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
|
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
|
|
|
+ * GNU General Public License for more details.
|
|
|
|
|
+ *
|
|
|
|
|
+ * Or, alternatively,
|
|
|
|
|
+ *
|
|
|
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
|
|
|
+ * obtaining a copy of this software and associated documentation
|
|
|
|
|
+ * files (the "Software"), to deal in the Software without
|
|
|
|
|
+ * restriction, including without limitation the rights to use,
|
|
|
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
|
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
|
|
|
+ * Software is furnished to do so, subject to the following
|
|
|
|
|
+ * conditions:
|
|
|
|
|
+ *
|
|
|
|
|
+ * The above copyright notice and this permission notice shall be
|
|
|
|
|
+ * included in all copies or substantial portions of the Software.
|
|
|
|
|
+ *
|
|
|
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
|
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
|
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
|
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
|
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
|
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
|
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
|
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
|
|
|
+ */
|
|
|
|
|
+
|
|
|
|
|
+/dts-v1/;
|
|
|
|
@ -340,18 +457,54 @@ index 0000000..ea2ea45
|
|
|
|
|
+};
|
|
|
|
|
diff --git a/arch/arm/boot/dts/imx53-usbarmory-i2c.dts b/arch/arm/boot/dts/imx53-usbarmory-i2c.dts
|
|
|
|
|
new file mode 100644
|
|
|
|
|
index 0000000..c66bbb5
|
|
|
|
|
index 0000000..158fbac
|
|
|
|
|
--- /dev/null
|
|
|
|
|
+++ b/arch/arm/boot/dts/imx53-usbarmory-i2c.dts
|
|
|
|
|
@@ -0,0 +1,32 @@
|
|
|
|
|
@@ -0,0 +1,68 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * USB armory MkI device mode device tree file
|
|
|
|
|
+ * http://inversepath.com/usbarmory
|
|
|
|
|
+ * USB armory MkI device tree file
|
|
|
|
|
+ * https://inversepath.com/usbarmory
|
|
|
|
|
+ *
|
|
|
|
|
+ * Copyright (C) 2015, Inverse Path
|
|
|
|
|
+ * Andrej Rosano <andrej@inversepath.com>
|
|
|
|
|
+ *
|
|
|
|
|
+ * Licensed under GPLv2
|
|
|
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
|
|
|
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
|
|
|
+ * licensing only applies to this file, and not this project as a
|
|
|
|
|
+ * whole.
|
|
|
|
|
+ *
|
|
|
|
|
+ * a) This file is free software; you can redistribute it and/or
|
|
|
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
|
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
|
|
|
+ * License, or (at your option) any later version.
|
|
|
|
|
+ *
|
|
|
|
|
+ * This file is distributed in the hope that it will be useful,
|
|
|
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
|
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
|
|
|
+ * GNU General Public License for more details.
|
|
|
|
|
+ *
|
|
|
|
|
+ * Or, alternatively,
|
|
|
|
|
+ *
|
|
|
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
|
|
|
+ * obtaining a copy of this software and associated documentation
|
|
|
|
|
+ * files (the "Software"), to deal in the Software without
|
|
|
|
|
+ * restriction, including without limitation the rights to use,
|
|
|
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
|
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
|
|
|
+ * Software is furnished to do so, subject to the following
|
|
|
|
|
+ * conditions:
|
|
|
|
|
+ *
|
|
|
|
|
+ * The above copyright notice and this permission notice shall be
|
|
|
|
|
+ * included in all copies or substantial portions of the Software.
|
|
|
|
|
+ *
|
|
|
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
|
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
|
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
|
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
|
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
|
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
|
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
|
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
|
|
|
+ */
|
|
|
|
|
+
|
|
|
|
|
+/dts-v1/;
|
|
|
|
@ -378,18 +531,54 @@ index 0000000..c66bbb5
|
|
|
|
|
+};
|
|
|
|
|
diff --git a/arch/arm/boot/dts/imx53-usbarmory-spi.dts b/arch/arm/boot/dts/imx53-usbarmory-spi.dts
|
|
|
|
|
new file mode 100644
|
|
|
|
|
index 0000000..414d641
|
|
|
|
|
index 0000000..f26f7ec
|
|
|
|
|
--- /dev/null
|
|
|
|
|
+++ b/arch/arm/boot/dts/imx53-usbarmory-spi.dts
|
|
|
|
|
@@ -0,0 +1,45 @@
|
|
|
|
|
@@ -0,0 +1,81 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * USB armory MkI device mode device tree file
|
|
|
|
|
+ * http://inversepath.com/usbarmory
|
|
|
|
|
+ * USB armory MkI device tree file
|
|
|
|
|
+ * https://inversepath.com/usbarmory
|
|
|
|
|
+ *
|
|
|
|
|
+ * Copyright (C) 2015, Inverse Path
|
|
|
|
|
+ * Andrej Rosano <andrej@inversepath.com>
|
|
|
|
|
+ *
|
|
|
|
|
+ * Licensed under GPLv2
|
|
|
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
|
|
|
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
|
|
|
+ * licensing only applies to this file, and not this project as a
|
|
|
|
|
+ * whole.
|
|
|
|
|
+ *
|
|
|
|
|
+ * a) This file is free software; you can redistribute it and/or
|
|
|
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
|
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
|
|
|
+ * License, or (at your option) any later version.
|
|
|
|
|
+ *
|
|
|
|
|
+ * This file is distributed in the hope that it will be useful,
|
|
|
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
|
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
|
|
|
+ * GNU General Public License for more details.
|
|
|
|
|
+ *
|
|
|
|
|
+ * Or, alternatively,
|
|
|
|
|
+ *
|
|
|
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
|
|
|
+ * obtaining a copy of this software and associated documentation
|
|
|
|
|
+ * files (the "Software"), to deal in the Software without
|
|
|
|
|
+ * restriction, including without limitation the rights to use,
|
|
|
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
|
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
|
|
|
+ * Software is furnished to do so, subject to the following
|
|
|
|
|
+ * conditions:
|
|
|
|
|
+ *
|
|
|
|
|
+ * The above copyright notice and this permission notice shall be
|
|
|
|
|
+ * included in all copies or substantial portions of the Software.
|
|
|
|
|
+ *
|
|
|
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
|
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
|
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
|
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
|
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
|
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
|
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
|
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
|
|
|
+ */
|
|
|
|
|
+
|
|
|
|
|
+/dts-v1/;
|
|
|
|
@ -429,18 +618,54 @@ index 0000000..414d641
|
|
|
|
|
+};
|
|
|
|
|
diff --git a/arch/arm/boot/dts/imx53-usbarmory.dts b/arch/arm/boot/dts/imx53-usbarmory.dts
|
|
|
|
|
new file mode 100644
|
|
|
|
|
index 0000000..902a73b
|
|
|
|
|
index 0000000..33719f7
|
|
|
|
|
--- /dev/null
|
|
|
|
|
+++ b/arch/arm/boot/dts/imx53-usbarmory.dts
|
|
|
|
|
@@ -0,0 +1,18 @@
|
|
|
|
|
@@ -0,0 +1,54 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * USB armory MkI device mode device tree file
|
|
|
|
|
+ * http://inversepath.com/usbarmory
|
|
|
|
|
+ * USB armory MkI device tree file
|
|
|
|
|
+ * https://inversepath.com/usbarmory
|
|
|
|
|
+ *
|
|
|
|
|
+ * Copyright (C) 2015, Inverse Path
|
|
|
|
|
+ * Andrej Rosano <andrej@inversepath.com>
|
|
|
|
|
+ *
|
|
|
|
|
+ * Licensed under GPLv2
|
|
|
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
|
|
|
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
|
|
|
+ * licensing only applies to this file, and not this project as a
|
|
|
|
|
+ * whole.
|
|
|
|
|
+ *
|
|
|
|
|
+ * a) This file is free software; you can redistribute it and/or
|
|
|
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
|
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
|
|
|
+ * License, or (at your option) any later version.
|
|
|
|
|
+ *
|
|
|
|
|
+ * This file is distributed in the hope that it will be useful,
|
|
|
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
|
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
|
|
|
+ * GNU General Public License for more details.
|
|
|
|
|
+ *
|
|
|
|
|
+ * Or, alternatively,
|
|
|
|
|
+ *
|
|
|
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
|
|
|
+ * obtaining a copy of this software and associated documentation
|
|
|
|
|
+ * files (the "Software"), to deal in the Software without
|
|
|
|
|
+ * restriction, including without limitation the rights to use,
|
|
|
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
|
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
|
|
|
+ * Software is furnished to do so, subject to the following
|
|
|
|
|
+ * conditions:
|
|
|
|
|
+ *
|
|
|
|
|
+ * The above copyright notice and this permission notice shall be
|
|
|
|
|
+ * included in all copies or substantial portions of the Software.
|
|
|
|
|
+ *
|
|
|
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
|
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
|
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
|
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
|
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
|
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
|
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
|
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
|
|
|
+ */
|
|
|
|
|
+
|
|
|
|
|
+/dts-v1/;
|
|
|
|
@ -452,5 +677,5 @@ index 0000000..902a73b
|
|
|
|
|
+ status = "okay";
|
|
|
|
|
+};
|
|
|
|
|
--
|
|
|
|
|
2.8.3
|
|
|
|
|
2.9.0
|
|
|
|
|
|
|
|
|
|