core/linux-armv7-rc to 4.7.rc5-1

This commit is contained in:
Kevin Mihelich 2016-06-30 02:42:05 +00:00
parent a1619b9599
commit 239d6d445f
9 changed files with 317 additions and 92 deletions

View file

@ -1,4 +1,4 @@
From c70ce57c9b88dda1a839b211a9ca29712a0a9bce Mon Sep 17 00:00:00 2001
From afbbc877305527e93d244824e0a3dca819973d94 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/8] ARM: atags: add support for Marvell's u-boot
@ -47,5 +47,5 @@ index 979ff40..d1d0c19 100644
};
--
2.8.3
2.9.0

View file

@ -1,4 +1,4 @@
From 7fa60a4b808762904700d462241ec591adbd60c1 Mon Sep 17 00:00:00 2001
From 14e8a69247c12df417aa4f2d5088f153d164d6a4 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/8] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
@ -43,5 +43,5 @@ index 9448aa0..ac7b6ae 100644
}
--
2.8.3
2.9.0

View file

@ -1,4 +1,4 @@
From 0788f6d154807b5340cdbaf76b990ec78f188da2 Mon Sep 17 00:00:00 2001
From 0371fbb17b99b7a34cd3620667fb4ec0dc13509f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 3/8] SMILE Plug device tree file
@ -14,10 +14,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 06b6c2d..2878a62 100644
index 414b427..939686c 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -843,6 +843,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
@@ -844,6 +844,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
armada-370-db.dtb \
armada-370-dlink-dns327l.dtb \
armada-370-mirabox.dtb \
@ -205,5 +205,5 @@ index 0000000..d01308a
+ };
+};
--
2.8.3
2.9.0

View file

@ -1,4 +1,4 @@
From bd521172b389468129e3d513cc40f20a64313c91 Mon Sep 17 00:00:00 2001
From 741fabedf4045b35dbebccfa80d89c24fad4f2bf Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 4/8] fix mvsdio eMMC timing
@ -34,5 +34,5 @@ index 42296e5..e5ce6d2 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.8.3
2.9.0

View file

@ -1,4 +1,4 @@
From dfde3f815866d3d5456f82a54775d9872968e12b Mon Sep 17 00:00:00 2001
From 5f270a18f5c0df790ab877d901f904f117d93c5d Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 5/8] net/smsc95xx: Allow mac address to be set as a parameter
@ -91,5 +91,5 @@ index dc989a8..912be75 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.8.3
2.9.0

View file

@ -1,4 +1,4 @@
From 19696cf9f73cdbb589358e1bb0bcbb47f2770e3c Mon Sep 17 00:00:00 2001
From d5be5ef162a931a20c5084a1ba8b1ee7d2d4d9f0 Mon Sep 17 00:00:00 2001
From: dobatog <dobatog@gmail.com>
Date: Thu, 26 Feb 2015 12:32:27 +0100
Subject: [PATCH 6/8] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
@ -45,5 +45,5 @@ index cd8c02b..95e6b11 100644
/* input mux */
{"Capture Source", "Line", "Line Input"},
--
2.8.3
2.9.0

View file

@ -1,4 +1,4 @@
From a13b9f0aa86aa2a77b683739456540afd40da81c Mon Sep 17 00:00:00 2001
From 87f2ae3fe4ac7b94d44c4cdcb3ea10a75ca7c447 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 7/8] set default cubietruck led triggers
@ -29,5 +29,5 @@ index 83f39b0..15e9626 100644
};
--
2.8.3
2.9.0

View file

@ -1,17 +1,17 @@
From 42930e86f6f0d4be217c6822507e1ef739a1ae00 Mon Sep 17 00:00:00 2001
From 9bfd3e6c96c0886b17c2b7bbd41d6a57d1739e73 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 7 Feb 2015 12:32:27 +0100
Subject: [PATCH 8/8] USB armory support
---
arch/arm/boot/dts/Makefile | 5 +
arch/arm/boot/dts/imx53-usbarmory-common.dtsi | 241 ++++++++++++++++++++++++++
arch/arm/boot/dts/imx53-usbarmory-gpio.dts | 26 +++
arch/arm/boot/dts/imx53-usbarmory-host.dts | 18 ++
arch/arm/boot/dts/imx53-usbarmory-i2c.dts | 32 ++++
arch/arm/boot/dts/imx53-usbarmory-spi.dts | 45 +++++
arch/arm/boot/dts/imx53-usbarmory.dts | 18 ++
7 files changed, 385 insertions(+)
arch/arm/boot/dts/imx53-usbarmory-common.dtsi | 286 ++++++++++++++++++++++++++
arch/arm/boot/dts/imx53-usbarmory-gpio.dts | 62 ++++++
arch/arm/boot/dts/imx53-usbarmory-host.dts | 54 +++++
arch/arm/boot/dts/imx53-usbarmory-i2c.dts | 68 ++++++
arch/arm/boot/dts/imx53-usbarmory-spi.dts | 81 ++++++++
arch/arm/boot/dts/imx53-usbarmory.dts | 54 +++++
7 files changed, 610 insertions(+)
create mode 100644 arch/arm/boot/dts/imx53-usbarmory-common.dtsi
create mode 100644 arch/arm/boot/dts/imx53-usbarmory-gpio.dts
create mode 100644 arch/arm/boot/dts/imx53-usbarmory-host.dts
@ -20,7 +20,7 @@ Subject: [PATCH 8/8] USB armory support
create mode 100644 arch/arm/boot/dts/imx53-usbarmory.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 2878a62..f6b3d97 100644
index 939686c..e5cc351 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -303,6 +303,11 @@ dtb-$(CONFIG_SOC_IMX53) += \
@ -37,18 +37,54 @@ index 2878a62..f6b3d97 100644
imx6dl-apf6dev.dtb \
diff --git a/arch/arm/boot/dts/imx53-usbarmory-common.dtsi b/arch/arm/boot/dts/imx53-usbarmory-common.dtsi
new file mode 100644
index 0000000..6f9ca1d
index 0000000..87621a5
--- /dev/null
+++ b/arch/arm/boot/dts/imx53-usbarmory-common.dtsi
@@ -0,0 +1,241 @@
@@ -0,0 +1,286 @@
+/*
+ * USB armory MkI device tree include file
+ * http://inversepath.com/usbarmory
+ * https://inversepath.com/usbarmory
+ *
+ * Copyright (C) 2015, Inverse Path
+ * Andrej Rosano <andrej@inversepath.com>
+ *
+ * Licensed under GPLv2
+ * This file is dual-licensed: you can use it either under the terms
+ * of the GPL or the X11 license, at your option. Note that this dual
+ * licensing only applies to this file, and not this project as a
+ * whole.
+ *
+ * a) This file is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+ * published by the Free Software Foundation; either version 2 of the
+ * License, or (at your option) any later version.
+ *
+ * This file is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * Or, alternatively,
+ *
+ * b) Permission is hereby granted, free of charge, to any person
+ * obtaining a copy of this software and associated documentation
+ * files (the "Software"), to deal in the Software without
+ * restriction, including without limitation the rights to use,
+ * copy, modify, merge, publish, distribute, sublicense, and/or
+ * sell copies of the Software, and to permit persons to whom the
+ * Software is furnished to do so, subject to the following
+ * conditions:
+ *
+ * The above copyright notice and this permission notice shall be
+ * included in all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+ * OTHER DEALINGS IN THE SOFTWARE.
+ */
+
+#include "imx53.dtsi"
@ -74,20 +110,18 @@ index 0000000..6f9ca1d
+
+ user {
+ label = "LED";
+ gpios = <&gpio4 27 GPIO_ACTIVE_LOW>;
+ gpios = <&gpio4 27 0>;
+ linux,default-trigger = "heartbeat";
+ };
+ };
+
+ soc {
+ aips@60000000 {
+ sahara: crypto@63ff8000 {
+ compatible = "fsl,imx53-sahara";
+ reg = <0x63ff8000 0x4000>;
+ interrupts = <19 20>;
+ clocks = <&clks IMX5_CLK_SAHARA_IPG_GATE>,
+ <&clks IMX5_CLK_SAHARA_IPG_GATE>;
+ clock-names = "ipg", "ahb";
+ scc2: scc2@63fb4000 {
+ compatible = "fsl,imx53-scc2";
+ reg = <0x63fb4000 0x4000>,
+ <0x07000000 0x4000>;
+ interrupts = <21 23>;
+ };
+ };
+ };
@ -120,7 +154,7 @@ index 0000000..6f9ca1d
+ imx53-usbarmory {
+ led_pin_gpio4_27: led_gpio4_27@0 {
+ fsl,pins = <
+ MX53_PAD_DISP0_DAT6__GPIO4_27 0x80000000
+ MX53_PAD_DISP0_DAT6__GPIO4_27 0x0
+ >;
+ };
+
@ -137,8 +171,8 @@ index 0000000..6f9ca1d
+
+ pinctrl_i2c1_pmic: i2c1grp_pmic {
+ fsl,pins = <
+ MX53_PAD_EIM_D21__I2C1_SCL 0xc0000000
+ MX53_PAD_EIM_D28__I2C1_SDA 0xc0000000
+ MX53_PAD_EIM_D21__I2C1_SCL 0x0
+ MX53_PAD_EIM_D28__I2C1_SDA 0x0
+ >;
+ };
+
@ -176,11 +210,26 @@ index 0000000..6f9ca1d
+ */
+ pinctrl_ecspi2: ecspi2grp {
+ fsl,pins = <
+ MX53_PAD_CSI0_DAT8__ECSPI2_SCLK 0x80000000
+ MX53_PAD_CSI0_DAT9__ECSPI2_MOSI 0x80000000
+ MX53_PAD_CSI0_DAT10__ECSPI2_MISO 0x80000000
+ MX53_PAD_CSI0_DAT11__GPIO5_29 0x80000000
+ MX53_PAD_CSI0_DAT12__GPIO5_30 0x80000000
+ MX53_PAD_CSI0_DAT8__ECSPI2_SCLK 0x0
+ MX53_PAD_CSI0_DAT9__ECSPI2_MOSI 0x0
+ MX53_PAD_CSI0_DAT10__ECSPI2_MISO 0x0
+ MX53_PAD_CSI0_DAT11__GPIO5_29 0x0
+ MX53_PAD_CSI0_DAT12__GPIO5_30 0x0
+ >;
+ };
+
+ /*
+ WILC1000 wifi module pin header configuration:
+ 1 2 3 4 5 6 7
+ GND 5V SCLK MOSI MISO /SS0 GPIO_IRQ
+ */
+ pinctrl_wilc1000: wilc1000grp {
+ fsl,pins = <
+ MX53_PAD_CSI0_DAT8__ECSPI2_SCLK 0x0
+ MX53_PAD_CSI0_DAT9__ECSPI2_MOSI 0x0
+ MX53_PAD_CSI0_DAT10__ECSPI2_MISO 0x0
+ MX53_PAD_CSI0_DAT11__GPIO5_29 0x0
+ MX53_PAD_CSI0_DAT12__GPIO5_30 0xc0
+ >;
+ };
+
@ -191,11 +240,11 @@ index 0000000..6f9ca1d
+ */
+ pinctrl_i2c1_pinheader: i2c1grp_pinheader {
+ fsl,pins = <
+ MX53_PAD_CSI0_DAT8__I2C1_SDA 0xc0000000
+ MX53_PAD_CSI0_DAT9__I2C1_SCL 0xc0000000
+ MX53_PAD_CSI0_DAT10__GPIO5_28 0x80000000
+ MX53_PAD_CSI0_DAT11__GPIO5_29 0x80000000
+ MX53_PAD_CSI0_DAT12__GPIO5_30 0x80000000
+ MX53_PAD_CSI0_DAT8__I2C1_SDA 0x0
+ MX53_PAD_CSI0_DAT9__I2C1_SCL 0x0
+ MX53_PAD_CSI0_DAT10__GPIO5_28 0xc0
+ MX53_PAD_CSI0_DAT11__GPIO5_29 0xc0
+ MX53_PAD_CSI0_DAT12__GPIO5_30 0xc0
+ >;
+ };
+ };
@ -207,10 +256,6 @@ index 0000000..6f9ca1d
+ status = "okay";
+};
+
+&vpu {
+ status = "okay";
+};
+
+&i2c1 {
+ pinctrl-0 = <&pinctrl_i2c1_pmic>;
+ status = "okay";
@ -284,18 +329,54 @@ index 0000000..6f9ca1d
+};
diff --git a/arch/arm/boot/dts/imx53-usbarmory-gpio.dts b/arch/arm/boot/dts/imx53-usbarmory-gpio.dts
new file mode 100644
index 0000000..a27c759
index 0000000..8d54dd2
--- /dev/null
+++ b/arch/arm/boot/dts/imx53-usbarmory-gpio.dts
@@ -0,0 +1,26 @@
@@ -0,0 +1,62 @@
+/*
+ * USB armory MkI device mode device tree file
+ * http://inversepath.com/usbarmory
+ * USB armory MkI device tree file
+ * https://inversepath.com/usbarmory
+ *
+ * Copyright (C) 2015, Inverse Path
+ * Andrej Rosano <andrej@inversepath.com>
+ *
+ * Licensed under GPLv2
+ * This file is dual-licensed: you can use it either under the terms
+ * of the GPL or the X11 license, at your option. Note that this dual
+ * licensing only applies to this file, and not this project as a
+ * whole.
+ *
+ * a) This file is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+ * published by the Free Software Foundation; either version 2 of the
+ * License, or (at your option) any later version.
+ *
+ * This file is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * Or, alternatively,
+ *
+ * b) Permission is hereby granted, free of charge, to any person
+ * obtaining a copy of this software and associated documentation
+ * files (the "Software"), to deal in the Software without
+ * restriction, including without limitation the rights to use,
+ * copy, modify, merge, publish, distribute, sublicense, and/or
+ * sell copies of the Software, and to permit persons to whom the
+ * Software is furnished to do so, subject to the following
+ * conditions:
+ *
+ * The above copyright notice and this permission notice shall be
+ * included in all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+ * OTHER DEALINGS IN THE SOFTWARE.
+ */
+
+/dts-v1/;
@ -316,18 +397,54 @@ index 0000000..a27c759
+};
diff --git a/arch/arm/boot/dts/imx53-usbarmory-host.dts b/arch/arm/boot/dts/imx53-usbarmory-host.dts
new file mode 100644
index 0000000..ea2ea45
index 0000000..d4e3b4c
--- /dev/null
+++ b/arch/arm/boot/dts/imx53-usbarmory-host.dts
@@ -0,0 +1,18 @@
@@ -0,0 +1,54 @@
+/*
+ * USB armory MkI host mode device tree file
+ * http://inversepath.com/usbarmory
+ * USB armory MkI device tree file
+ * https://inversepath.com/usbarmory
+ *
+ * Copyright (C) 2015, Inverse Path
+ * Andrej Rosano <andrej@inversepath.com>
+ *
+ * Licensed under GPLv2
+ * This file is dual-licensed: you can use it either under the terms
+ * of the GPL or the X11 license, at your option. Note that this dual
+ * licensing only applies to this file, and not this project as a
+ * whole.
+ *
+ * a) This file is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+ * published by the Free Software Foundation; either version 2 of the
+ * License, or (at your option) any later version.
+ *
+ * This file is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * Or, alternatively,
+ *
+ * b) Permission is hereby granted, free of charge, to any person
+ * obtaining a copy of this software and associated documentation
+ * files (the "Software"), to deal in the Software without
+ * restriction, including without limitation the rights to use,
+ * copy, modify, merge, publish, distribute, sublicense, and/or
+ * sell copies of the Software, and to permit persons to whom the
+ * Software is furnished to do so, subject to the following
+ * conditions:
+ *
+ * The above copyright notice and this permission notice shall be
+ * included in all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+ * OTHER DEALINGS IN THE SOFTWARE.
+ */
+
+/dts-v1/;
@ -340,18 +457,54 @@ index 0000000..ea2ea45
+};
diff --git a/arch/arm/boot/dts/imx53-usbarmory-i2c.dts b/arch/arm/boot/dts/imx53-usbarmory-i2c.dts
new file mode 100644
index 0000000..c66bbb5
index 0000000..158fbac
--- /dev/null
+++ b/arch/arm/boot/dts/imx53-usbarmory-i2c.dts
@@ -0,0 +1,32 @@
@@ -0,0 +1,68 @@
+/*
+ * USB armory MkI device mode device tree file
+ * http://inversepath.com/usbarmory
+ * USB armory MkI device tree file
+ * https://inversepath.com/usbarmory
+ *
+ * Copyright (C) 2015, Inverse Path
+ * Andrej Rosano <andrej@inversepath.com>
+ *
+ * Licensed under GPLv2
+ * This file is dual-licensed: you can use it either under the terms
+ * of the GPL or the X11 license, at your option. Note that this dual
+ * licensing only applies to this file, and not this project as a
+ * whole.
+ *
+ * a) This file is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+ * published by the Free Software Foundation; either version 2 of the
+ * License, or (at your option) any later version.
+ *
+ * This file is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * Or, alternatively,
+ *
+ * b) Permission is hereby granted, free of charge, to any person
+ * obtaining a copy of this software and associated documentation
+ * files (the "Software"), to deal in the Software without
+ * restriction, including without limitation the rights to use,
+ * copy, modify, merge, publish, distribute, sublicense, and/or
+ * sell copies of the Software, and to permit persons to whom the
+ * Software is furnished to do so, subject to the following
+ * conditions:
+ *
+ * The above copyright notice and this permission notice shall be
+ * included in all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+ * OTHER DEALINGS IN THE SOFTWARE.
+ */
+
+/dts-v1/;
@ -378,18 +531,54 @@ index 0000000..c66bbb5
+};
diff --git a/arch/arm/boot/dts/imx53-usbarmory-spi.dts b/arch/arm/boot/dts/imx53-usbarmory-spi.dts
new file mode 100644
index 0000000..414d641
index 0000000..f26f7ec
--- /dev/null
+++ b/arch/arm/boot/dts/imx53-usbarmory-spi.dts
@@ -0,0 +1,45 @@
@@ -0,0 +1,81 @@
+/*
+ * USB armory MkI device mode device tree file
+ * http://inversepath.com/usbarmory
+ * USB armory MkI device tree file
+ * https://inversepath.com/usbarmory
+ *
+ * Copyright (C) 2015, Inverse Path
+ * Andrej Rosano <andrej@inversepath.com>
+ *
+ * Licensed under GPLv2
+ * This file is dual-licensed: you can use it either under the terms
+ * of the GPL or the X11 license, at your option. Note that this dual
+ * licensing only applies to this file, and not this project as a
+ * whole.
+ *
+ * a) This file is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+ * published by the Free Software Foundation; either version 2 of the
+ * License, or (at your option) any later version.
+ *
+ * This file is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * Or, alternatively,
+ *
+ * b) Permission is hereby granted, free of charge, to any person
+ * obtaining a copy of this software and associated documentation
+ * files (the "Software"), to deal in the Software without
+ * restriction, including without limitation the rights to use,
+ * copy, modify, merge, publish, distribute, sublicense, and/or
+ * sell copies of the Software, and to permit persons to whom the
+ * Software is furnished to do so, subject to the following
+ * conditions:
+ *
+ * The above copyright notice and this permission notice shall be
+ * included in all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+ * OTHER DEALINGS IN THE SOFTWARE.
+ */
+
+/dts-v1/;
@ -429,18 +618,54 @@ index 0000000..414d641
+};
diff --git a/arch/arm/boot/dts/imx53-usbarmory.dts b/arch/arm/boot/dts/imx53-usbarmory.dts
new file mode 100644
index 0000000..902a73b
index 0000000..33719f7
--- /dev/null
+++ b/arch/arm/boot/dts/imx53-usbarmory.dts
@@ -0,0 +1,18 @@
@@ -0,0 +1,54 @@
+/*
+ * USB armory MkI device mode device tree file
+ * http://inversepath.com/usbarmory
+ * USB armory MkI device tree file
+ * https://inversepath.com/usbarmory
+ *
+ * Copyright (C) 2015, Inverse Path
+ * Andrej Rosano <andrej@inversepath.com>
+ *
+ * Licensed under GPLv2
+ * This file is dual-licensed: you can use it either under the terms
+ * of the GPL or the X11 license, at your option. Note that this dual
+ * licensing only applies to this file, and not this project as a
+ * whole.
+ *
+ * a) This file is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+ * published by the Free Software Foundation; either version 2 of the
+ * License, or (at your option) any later version.
+ *
+ * This file is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * Or, alternatively,
+ *
+ * b) Permission is hereby granted, free of charge, to any person
+ * obtaining a copy of this software and associated documentation
+ * files (the "Software"), to deal in the Software without
+ * restriction, including without limitation the rights to use,
+ * copy, modify, merge, publish, distribute, sublicense, and/or
+ * sell copies of the Software, and to permit persons to whom the
+ * Software is furnished to do so, subject to the following
+ * conditions:
+ *
+ * The above copyright notice and this permission notice shall be
+ * included in all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+ * OTHER DEALINGS IN THE SOFTWARE.
+ */
+
+/dts-v1/;
@ -452,5 +677,5 @@ index 0000000..902a73b
+ status = "okay";
+};
--
2.8.3
2.9.0

View file

@ -4,7 +4,7 @@
buildarch=4
_rcver=4.7
_rcrel=4
_rcrel=5
_rcnrel=armv7-x0
pkgbase=linux-armv7-rc
@ -22,7 +22,7 @@ options=('!strip')
source=(#"http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
#"https://www.kernel.org/pub/linux/kernel/v4.x/testing/patch-${_rcver}-rc${_rcrel}.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_srcname}.tar.xz"
"http://rcn-ee.com/deb/sid-armhf/v${_rcver}.0-rc${_rcrel}-${_rcnrel}/patch-${_rcver}-rc${_rcrel}-${_rcnrel}.diff.gz"
"http://rcn-ee.com/deb/stretch-armhf/v${_rcver}.0-rc${_rcrel}-${_rcnrel}/patch-${_rcver}-rc${_rcrel}-${_rcnrel}.diff.gz"
'0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch'
'0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch'
'0003-SMILE-Plug-device-tree-file.patch'
@ -36,16 +36,16 @@ source=(#"http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'kernel.its'
'kernel.keyblock'
'kernel_data_key.vbprivk')
md5sums=('a9e13186edfc19bc183de7fc6a1b2c59'
'ca1db21a108c291da6be7898858dab82'
'abf9fe78fae0ffd10b6db56670bbb0f1'
'cd9c5400cf4fcd261d19c472d61f7445'
'99bb48b1b02b3ace761633622a315d84'
'914e279e5fabedc2f2d1afb22ddd225c'
'2f4e6922546a4851abdefbfd89f12e00'
'6fdf2b5666d534f83eeec6b43c6838c3'
'e4ff8c1bcdeb833ca1f86802ef03bc35'
'e7e0c12b90941b30ef1f2f6fcda46bf0'
md5sums=('336e52b05f9e69f0937c817ffeace297'
'aa80f5b01e4fb4252b9abaa7f3781551'
'3c7905e0ab610fb761e98b970e878936'
'365ad95a61dd208b73ca63ec9ae1b5ac'
'47f730f34a1869cac8e23ecb318c2160'
'ae965a26a9dfcfa5738bda5409f8176f'
'789334f7f20d3e324bbadaa3215baf6a'
'69ea845025d4a48a6a2acfcb16bbbc43'
'084263ed8f4ec6b142ba62464beca4cd'
'5277e72a05b8ee3260a13d793e01a46c'
'e47277aa8c78f62f1bb1e3a30aeba699'
'7d3061393c215d08f44a46ca48b13b7e'
'4f2379ed84258050edb858ee8d281678'