mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-06 23:47:10 +00:00
extra/libreoffice-still to 7.5.5-1
This commit is contained in:
parent
f5a2e90664
commit
23cdf3bf03
3 changed files with 40 additions and 82 deletions
|
@ -1,59 +0,0 @@
|
|||
From 15e5d86cc55ad94ac946e04d5e25b84be5810970 Mon Sep 17 00:00:00 2001
|
||||
From: "Brett T. Warden" <brett.t.warden@intel.com>
|
||||
Date: Fri, 30 Dec 2022 08:43:25 +0100
|
||||
Subject: Remove dependency on BitArray.h from zxing-1.2.0
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
In zxing-1.4.0, numerous headers are no longer public. Rework the
|
||||
ConvertToSVGFormat method so it uses bitmatrix.get instead of
|
||||
bitmatrix.getRow, similar to the ToSVG method in zxing itself.
|
||||
|
||||
See https://github.com/zxing-cpp/zxing-cpp/issues/361
|
||||
|
||||
Change-Id: Ie25eb8f782e8799fbd57c24ef79bba92acf0f9ff
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/144874
|
||||
Tested-by: René Engelhard <rene@debian.org>
|
||||
Reviewed-by: René Engelhard <rene@debian.org>
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Caolán McNamara <caolanm@redhat.com>
|
||||
---
|
||||
cui/source/dialogs/QrCodeGenDialog.cxx | 5 +----
|
||||
1 file changed, 1 insertion(+), 4 deletions(-)
|
||||
|
||||
diff --git a/cui/source/dialogs/QrCodeGenDialog.cxx b/cui/source/dialogs/QrCodeGenDialog.cxx
|
||||
index f8cbac1d758d..817be7f21ede 100644
|
||||
--- a/cui/source/dialogs/QrCodeGenDialog.cxx
|
||||
+++ b/cui/source/dialogs/QrCodeGenDialog.cxx
|
||||
@@ -27,7 +27,6 @@
|
||||
#endif
|
||||
|
||||
#include <BarcodeFormat.h>
|
||||
-#include <BitArray.h>
|
||||
#include <BitMatrix.h>
|
||||
#include <MultiFormatWriter.h>
|
||||
#include <TextUtfEncoding.h>
|
||||
@@ -79,7 +78,6 @@ OString ConvertToSVGFormat(const ZXing::BitMatrix& bitmatrix)
|
||||
OStringBuffer sb;
|
||||
const int width = bitmatrix.width();
|
||||
const int height = bitmatrix.height();
|
||||
- ZXing::BitArray row(width);
|
||||
sb.append("<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
|
||||
"<svg xmlns=\"http://www.w3.org/2000/svg\" version=\"1.1\" viewBox=\"0 0 "
|
||||
+ OString::number(width) + " " + OString::number(height)
|
||||
@@ -87,10 +85,9 @@ OString ConvertToSVGFormat(const ZXing::BitMatrix& bitmatrix)
|
||||
"<path d=\"");
|
||||
for (int i = 0; i < height; ++i)
|
||||
{
|
||||
- bitmatrix.getRow(i, row);
|
||||
for (int j = 0; j < width; ++j)
|
||||
{
|
||||
- if (row.get(j))
|
||||
+ if (bitmatrix.get(j, i))
|
||||
{
|
||||
sb.append("M" + OString::number(j) + "," + OString::number(i) + "h1v1h-1z");
|
||||
}
|
||||
--
|
||||
cgit v1.2.1
|
||||
|
21
extra/libreoffice-still/623ea5c.diff
Normal file
21
extra/libreoffice-still/623ea5c.diff
Normal file
|
@ -0,0 +1,21 @@
|
|||
From 623ea5c4d2871aba2e3e5114ad7d58d6f910a2f3 Mon Sep 17 00:00:00 2001
|
||||
From: Caolán McNamara <caolanm@redhat.com>
|
||||
Date: Thu, 12 Jan 2023 20:55:27 +0000
|
||||
Subject: [PATCH] Related: tdf#151898 fix gtk4 build in 7-4
|
||||
|
||||
Change-Id: I71b59b7d2eac406817c79bf6911736ad4510771c
|
||||
---
|
||||
|
||||
diff --git a/vcl/unx/gtk3/gtkinst.cxx b/vcl/unx/gtk3/gtkinst.cxx
|
||||
index 8ba6409..b697b0b 100644
|
||||
--- a/vcl/unx/gtk3/gtkinst.cxx
|
||||
+++ b/vcl/unx/gtk3/gtkinst.cxx
|
||||
@@ -5114,7 +5114,7 @@
|
||||
|
||||
void picture_set_from_xgraphic(GtkPicture* pPicture, const css::uno::Reference<css::graphic::XGraphic>& rPicture)
|
||||
{
|
||||
- if (auto xTempFile = getImageFile(rPicture, false))
|
||||
+ if (auto xTempFile = getImageFile(rPicture))
|
||||
gtk_picture_set_filename(pPicture, OUStringToOString(xTempFile->GetFileName(), osl_getThreadTextEncoding()).getStr());
|
||||
else
|
||||
gtk_picture_set_pixbuf(pPicture, nullptr);
|
|
@ -17,9 +17,9 @@ _google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
|
|||
|
||||
pkgbase=libreoffice-still
|
||||
pkgname=('libreoffice-still-sdk' 'libreoffice-still')
|
||||
_LOver=7.4.7.2
|
||||
pkgver=7.4.7
|
||||
pkgrel=5
|
||||
_LOver=7.5.5.2
|
||||
pkgver=7.5.5
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
license=('LGPL3')
|
||||
url="https://www.libreoffice.org/"
|
||||
|
@ -28,8 +28,7 @@ makedepends=('curl>=7.20.0' 'hunspell>=1.2.8' 'python' 'libwpd>=0.9.2' 'libwps'
|
|||
'libxslt' 'redland' 'hyphen' 'lpsolve' 'gcc-libs' 'sh' 'graphite' 'icu'
|
||||
'lcms2' 'poppler>=0.24.0' 'libvisio' 'libetonyek' 'libodfgen' 'libcdr'
|
||||
'libmspub' 'harfbuzz-icu' 'nss' 'hicolor-icon-theme'
|
||||
'desktop-file-utils' 'shared-mime-info' 'gst-plugins-base-libs'
|
||||
'sane' 'perl-archive-zip' 'zip' 'unzip' 'unixodbc' 'ant'
|
||||
'gst-plugins-base-libs' 'sane' 'perl-archive-zip' 'zip' 'unzip' 'unixodbc' 'ant'
|
||||
'gperf' 'gtk3' 'gtk4' 'qt5-base' 'plasma-framework' 'qt6-base' 'cppunit' 'beanshell' 'clucene'
|
||||
'junit' 'libmythes' 'libwpg' 'java-environment=11' 'postgresql-libs' 'mariadb-libs' 'libgl'
|
||||
'bluez-libs' 'gdb' 'doxygen' 'libatomic_ops' 'mdds'
|
||||
|
@ -55,7 +54,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
|
|||
${_additional_source_url}/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
|
||||
${_additional_source_url}/d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
|
||||
${_additional_source_url}/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
|
||||
${_additional_source_url}/pdfium-5058.tar.bz2
|
||||
${_additional_source_url}/pdfium-5778.tar.bz2
|
||||
${_additional_source_url}/dtoa-20180411.tgz
|
||||
${_additional_source_url}/lxml-4.1.1.tgz
|
||||
${_additional_source_url}/skia-m103-b301ff025004c9cd82816c86c547588e6c24b466.tar.xz
|
||||
|
@ -65,9 +64,8 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
|
|||
${_additional_source_url2}/odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies-971c54fd38a968f5860014b44301872706f9e540.jar # for test suite
|
||||
${_additional_source_url2}/f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf
|
||||
${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
|
||||
libreoffice-boost-1.81.0-locale.patch::https://github.com/LibreOffice/core/commit/23dcd4339428.patch
|
||||
make-pyuno-work-with-system-wide-module-install.diff
|
||||
0001_Remove_dependency_on_BitArray.h_from_zxing-1.2.0.patch
|
||||
623ea5c.diff
|
||||
soffice-template.desktop.in
|
||||
libreoffice-still.sh libreoffice-still.csh)
|
||||
noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
|
||||
|
@ -78,7 +76,7 @@ noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
|
|||
17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
|
||||
d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
|
||||
ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
|
||||
pdfium-5058.tar.bz2
|
||||
pdfium-5778.tar.bz2
|
||||
dtoa-20180411.tgz
|
||||
lxml-4.1.1.tgz
|
||||
skia-m103-b301ff025004c9cd82816c86c547588e6c24b466.tar.xz
|
||||
|
@ -90,11 +88,11 @@ noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
|
|||
185d60944ea767075d27247c3162b3bc-unowinreg.dll
|
||||
)
|
||||
validpgpkeys=('C2839ECAD9408FBE9531C3E9F434A1EFAFEEAEA3') # LibreOffice Build Team (CODE SIGNING KEY) <build@documentfoundation.org>
|
||||
sha256sums=('743d91f2a138a678380fa7a8ecb5b2401d994b067b330750f03ad8f523a2fb20'
|
||||
sha256sums=('6628dfd2a21041a7c5bb6d72733e0fd52efa7959c95084fcd4d96cc4a61b0561'
|
||||
'SKIP'
|
||||
'bdc416137981671dac050f4acd387acccef6efb98af6dc1fbf21124f34e2208f'
|
||||
'1de834979bf25c3c6f368362dd20c95d0bee514a42eee903a32188d40488aa62'
|
||||
'SKIP'
|
||||
'ef079ad040a59afc1c3ef8100c66a090e17b78156f613652702104a62add5e71'
|
||||
'24b5c791a17128361b5f3c8538348002a714d0ba2aab37e3bf10e16b7ac049b7'
|
||||
'SKIP'
|
||||
'a49a58e8070ec111cc40efc9cdab32e8a1894d6a7788319306ccc461128e87c0'
|
||||
'1fb458d6aab06932693cc8a9b6e4e70944ee1ff052fa63606e3131df34e21753'
|
||||
|
@ -104,7 +102,7 @@ sha256sums=('743d91f2a138a678380fa7a8ecb5b2401d994b067b330750f03ad8f523a2fb20'
|
|||
'd30b13f4ba2e3b6a2d4f020c0dee0a9fb9fc6fbcc2d561f36b78da4bf3802370'
|
||||
'1b5b24f7bc543c0362b667692f78db8bab4ed6dafc6172f104d0bd3757d8a133'
|
||||
'233f66e8d25c5dd971716d4200203a612a407649686ef3b52075d04b4c9df0dd'
|
||||
'eaf4ce9fad32b5d951c524139df23119b66c67720057defb97acab2dfb2582ac'
|
||||
'b1052ff24e9ffb11af017c444bb0f6ad508d64c9a0fb88cacb0e8210245dde06'
|
||||
'0082d0684f7db6f62361b76c4b7faba19e0c7ce5cb8e36c4b65fea8281e711b4'
|
||||
'940caef1ec7c78e0c34b0f6b94fe42d0f2022915ffc78643d28538a5cfd0f40e'
|
||||
'acb85cedafa10ce106b1823fb236b1b3e5d942a5741e8f8435cc8ccfec0afe76'
|
||||
|
@ -115,9 +113,8 @@ sha256sums=('743d91f2a138a678380fa7a8ecb5b2401d994b067b330750f03ad8f523a2fb20'
|
|||
'984f2a479df79e27e7b01a5815ac53ae64e07746b882262d8a64566494515504'
|
||||
'f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140'
|
||||
'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
|
||||
'9754c1c9025dd34b010b3e9c9c39ef2f850331e486b5d0adbf5c86f554259b04'
|
||||
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
|
||||
'fa0073dee8fc0519b84ed6af6fa9769b88abb24e694c314344c4606478101547'
|
||||
'440c9af5f3d1213d8ed7177282380f25cbc981cabc8b590dcb777aaae84178e5'
|
||||
'd0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879'
|
||||
'cd1b25ff390e436c6bffa65c6e12382236e3ccbf8d3aae51b1b59bcaed79fd8a'
|
||||
'b43ed267643fc5ced803dca010427b12b1f10db485173ccb19efb3395e60c82e'
|
||||
|
@ -139,14 +136,11 @@ prepare() {
|
|||
rm "${srcdir}"/ext_sources/185d60944ea767075d27247c3162b3bc-unowinreg.dll
|
||||
cp -f "${srcdir}"/185d60944ea767075d27247c3162b3bc-unowinreg.dll "${srcdir}"/ext_sources
|
||||
|
||||
# https://gerrit.libreoffice.org/c/core/+/143343
|
||||
patch -Np1 -i "${srcdir}"/libreoffice-boost-1.81.0-locale.patch
|
||||
|
||||
# fix not upstreamable pyuno paths - FS#54250
|
||||
patch -Np1 -i "${srcdir}"/make-pyuno-work-with-system-wide-module-install.diff
|
||||
|
||||
# allow build with recent syytem xzing
|
||||
patch -Np1 -i "${srcdir}"/0001_Remove_dependency_on_BitArray.h_from_zxing-1.2.0.patch
|
||||
# fix build - https://gerrit.libreoffice.org/c/core/+/145421
|
||||
patch -Np1 -i "${srcdir}"/623ea5c.diff
|
||||
|
||||
#use the CFLAGS but remove the LibO overridden ones
|
||||
for i in $CFLAGS; do
|
||||
|
@ -308,8 +302,10 @@ package_libreoffice-still() {
|
|||
'liblangtag' 'libexttextcat' 'liborcus' 'libwebp' # 'libfbclient' 'libcmis'
|
||||
'libtommath' 'libzmf' 'libatomic_ops' 'xmlsec' 'libnumbertext' 'gpgme'
|
||||
'libfreehand' 'libstaroffice' 'libepubgen' 'libqxp' 'libepoxy' 'box2d'
|
||||
'zxing-cpp'
|
||||
'xdg-utils')
|
||||
'zxing-cpp' 'xdg-utils'
|
||||
'libldap' 'fontconfig' 'zlib' 'libpng' 'freetype2' 'raptor' 'libxml2'
|
||||
'cairo' 'libx11' 'expat' 'glib2' 'boost-libs' 'libtiff' 'dbus' 'glibc'
|
||||
'librevenge' 'libxext' 'openjpeg2' )
|
||||
optdepends=('java-runtime: adds java support'
|
||||
'java-environment: required by extension-wiki-publisher and extension-nlpsolver'
|
||||
'pstoedit: translates PostScript and PDF graphics into other vector formats'
|
||||
|
@ -326,7 +322,7 @@ package_libreoffice-still() {
|
|||
'gtk3: for GTK3 integration'
|
||||
'gtk4: for GTK4 integration (experimental)'
|
||||
'kio: for KF5 KDE desktop integration'
|
||||
'qt6-base: for QT6 desktop integration')
|
||||
'qt6-base: for Qt6 desktop integration')
|
||||
backup=(etc/libreoffice/sofficerc
|
||||
etc/libreoffice/bootstraprc
|
||||
etc/libreoffice/psprint.conf
|
||||
|
|
Loading…
Reference in a new issue