mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/linux-am33x to 5.2.0-1
This commit is contained in:
parent
ce7e444e40
commit
23ddd0fc62
3 changed files with 440 additions and 120 deletions
|
@ -1,31 +0,0 @@
|
|||
From b297035577d01cfdffa8d19079fc8c971af5c8da Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 16 Oct 2017 08:00:32 -0600
|
||||
Subject: [PATCH] enable dtc 1.4.5 flags
|
||||
|
||||
---
|
||||
Makefile | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index c723aa7..a3eec98 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -34,10 +34,10 @@ endif
|
||||
|
||||
DTC_FLAGS += -Wno-unit_address_vs_reg
|
||||
#New DTC Flags for v1.4.5 (Debian 9.x (Buster))
|
||||
-#DTC_FLAGS += -Wno-dmas_property
|
||||
-#DTC_FLAGS += -Wno-gpios_property
|
||||
-#DTC_FLAGS += -Wno-pwms_property
|
||||
-#DTC_FLAGS += -Wno-interrupts_property
|
||||
+DTC_FLAGS += -Wno-dmas_property
|
||||
+DTC_FLAGS += -Wno-gpios_property
|
||||
+DTC_FLAGS += -Wno-pwms_property
|
||||
+DTC_FLAGS += -Wno-interrupts_property
|
||||
|
||||
# Beautify output
|
||||
# ---------------------------------------------------------------------------
|
||||
--
|
||||
2.14.1
|
||||
|
|
@ -4,33 +4,30 @@
|
|||
buildarch=4
|
||||
|
||||
pkgbase=linux-am33x
|
||||
_srcname=linux-5.1
|
||||
_srcname=linux-5.2
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="TI AM335x Beaglebone (Black)"
|
||||
pkgver=5.1.15
|
||||
pkgver=5.2.0
|
||||
pkgrel=1
|
||||
rcnrel=bone11
|
||||
rcnrel=bone2
|
||||
arch=('armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'dtc')
|
||||
options=('!strip')
|
||||
source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
|
||||
"http://www.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz"
|
||||
#"http://www.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz"
|
||||
"http://rcn-ee.com/deb/sid-armhf/v${pkgver}-${rcnrel}/patch-${pkgver%.0}-${rcnrel}.diff.gz"
|
||||
"git+https://github.com/RobertCNelson/bb.org-overlays.git"
|
||||
'0001-add-lcd-cape-for-chiliboard.patch'
|
||||
'0001-enable-dtc-1.4.5-flags.patch'
|
||||
'config'
|
||||
'linux.preset'
|
||||
'99-linux.hook')
|
||||
md5sums=('15fbdff95ff98483069ac6e215b9f4f9'
|
||||
'aed4686410e23561f67f5c512d0a6245'
|
||||
'58e044f59d184dd78acf078e74c0d1a6'
|
||||
md5sums=('ddf994de00d7b18395886dd9b30b9262'
|
||||
'26c6315665c926c1d9e9df7d3407facb'
|
||||
'SKIP'
|
||||
'ee16bcdbbf978e714455933ecd6dd8fe'
|
||||
'5698870a716fed205215d258cc71e296'
|
||||
'dc4c746f86b3895867e44938a735c799'
|
||||
'27f190f22ffde835f3a5a1df7749e9f9'
|
||||
'78ccc998f27eec49a9d5490218b1b1ab'
|
||||
'79fa396e3f9a09a85156d6d7c2d34b58')
|
||||
|
||||
|
@ -38,7 +35,7 @@ prepare() {
|
|||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
# add upstream patch
|
||||
git apply --whitespace=nowarn "${srcdir}/patch-${pkgver}"
|
||||
#git apply --whitespace=nowarn "${srcdir}/patch-${pkgver}"
|
||||
|
||||
# RCN patch
|
||||
git apply ../patch-${pkgver%.0}-${rcnrel}.diff
|
||||
|
@ -53,9 +50,6 @@ prepare() {
|
|||
|
||||
# don't run depmod on 'make install'. We'll do this ourselves in packaging
|
||||
sed -i '2iexit 0' scripts/depmod.sh
|
||||
|
||||
cd ../bb.org-overlays
|
||||
git apply ../0001-enable-dtc-1.4.5-flags.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue