mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
Finished core cleanup
This commit is contained in:
parent
d6dd3b75f3
commit
24080d67ed
13 changed files with 0 additions and 505 deletions
|
@ -1,47 +0,0 @@
|
|||
# Maintainer: Mike Staszel <mikestaszel@openpogo.com>
|
||||
|
||||
pkgname=coreutils
|
||||
pkgver=7.4
|
||||
pkgrel=1
|
||||
pkgdesc="The basic file, shell and text manipulation utilities of the GNU operating system"
|
||||
arch=(i686 x86_64 arm)
|
||||
license=('GPL3')
|
||||
url="http://www.gnu.org/software/coreutils"
|
||||
groups=('base')
|
||||
depends=('glibc>=2.9' 'shadow>=4.1.2.1' 'pam>=1.0.3' 'acl>=2.2.47' 'gmp>=4.2.4')
|
||||
provides=('mktemp')
|
||||
conflicts=('mktemp')
|
||||
replaces=('sh-utils' 'fileutils' 'textutils' 'mktemp')
|
||||
backup=('etc/pam.d/su')
|
||||
options=('!emptydirs')
|
||||
source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
|
||||
su)
|
||||
md5sums=('c52f4f64dda9a245c38e74c09fdd86d2'
|
||||
'fa85e5cce5d723275b14365ba71a8aad')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/coreutils-$pkgver"
|
||||
|
||||
./configure --prefix=/usr \
|
||||
--enable-install-program=su \
|
||||
--enable-pam ac_cv_func_openat=no || return 1
|
||||
make || return 1
|
||||
make DESTDIR=$pkgdir install || return 1
|
||||
|
||||
# Remove binaries provided by other packages.
|
||||
for f in hostname uptime groups kill; do
|
||||
rm -f $pkgdir/usr/bin/$f
|
||||
done
|
||||
|
||||
cd $pkgdir/usr/bin
|
||||
install -dm755 $pkgdir/{bin,sbin,usr/sbin}
|
||||
mv su date echo false pwd stty true uname cat tr cut readlink $pkgdir/bin
|
||||
mv dd cp df du ln ls mv rm dir sync vdir chgrp chmod chown $pkgdir/bin
|
||||
mv mkdir mknod rmdir shred touch mkfifo dircolors install sleep $pkgdir/bin
|
||||
mv chroot $pkgdir/usr/sbin
|
||||
ln -sf test [
|
||||
ln -sf /bin/sleep $pkgdir/usr/bin/sleep
|
||||
install -Dm644 $srcdir/su $pkgdir/etc/pam.d/su
|
||||
|
||||
chmod -v 4555 $pkgdir/bin/su
|
||||
}
|
|
@ -1,9 +0,0 @@
|
|||
#%PAM-1.0
|
||||
auth sufficient pam_rootok.so
|
||||
# Uncomment the following line to implicitly trust users in the "wheel" group.
|
||||
#auth sufficient pam_wheel.so trust use_uid
|
||||
# Uncomment the following line to require a user to be in the "wheel" group.
|
||||
#auth required pam_wheel.so use_uid
|
||||
auth required pam_unix.so
|
||||
account required pam_unix.so
|
||||
session required pam_unix.so
|
|
@ -1,28 +0,0 @@
|
|||
# Maintainer: Allan McRae <allan@archlinux.org>
|
||||
# Contributor: Andreas Radke <andyrtr@archlinux.org>
|
||||
|
||||
pkgname=db
|
||||
pkgver=4.8.24
|
||||
_basever=4.8.24
|
||||
pkgrel=1
|
||||
pkgdesc="The Berkeley DB embedded database system"
|
||||
arch=(i686 x86_64 arm)
|
||||
url="http://www.oracle.com/technology/software/products/berkeley-db/index.html"
|
||||
license=('custom')
|
||||
groups=('base')
|
||||
depends=('gcc-libs' 'sh')
|
||||
options=('!libtool')
|
||||
install=db.install
|
||||
source=(http://download-uk.oracle.com/berkeley-db/db-${_basever}.tar.gz)
|
||||
md5sums=('147afdecf438ff99ade105a5272db158')
|
||||
|
||||
build() {
|
||||
cd ${srcdir}/$pkgname-${_basever}/build_unix
|
||||
../dist/configure --prefix=/usr --enable-compat185 \
|
||||
--enable-shared --enable-static --enable-cxx
|
||||
make LIBSO_LIBS=-lpthread || return 1
|
||||
make DESTDIR=${pkgdir} install
|
||||
rm -rf ${pkgdir}/usr/docs
|
||||
install -Dm644 ${srcdir}/${pkgname}-${_basever}/LICENSE \
|
||||
${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
|
||||
}
|
|
@ -1,5 +0,0 @@
|
|||
post_upgrade() {
|
||||
echo "ATTENTION DB PACKAGE:"
|
||||
echo "Please consider to run db_upgrade on Berkeley DB databases with a major db version number update."
|
||||
}
|
||||
|
|
@ -1,53 +0,0 @@
|
|||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||
# Contributor: Link Dupont <link@subpop.net>
|
||||
|
||||
pkgname=dbus-core
|
||||
pkgver=1.2.14
|
||||
pkgrel=1
|
||||
pkgdesc="Freedesktop.org message bus system"
|
||||
url="http://www.freedesktop.org/Software/dbus"
|
||||
arch=('arm')
|
||||
license=('GPL' 'custom')
|
||||
depends=('expat>=2.0' 'coreutils' 'filesystem')
|
||||
conflicts=('dbus<1.2.3-2')
|
||||
options=(!libtool)
|
||||
groups=('base')
|
||||
install=dbus.install
|
||||
source=(http://dbus.freedesktop.org/releases/dbus/dbus-${pkgver}.tar.gz
|
||||
dbus)
|
||||
md5sums=('2c267ccd45d0b18db8c9edacad63ec98'
|
||||
'08f93dd19cffd1b45ab05c1fd4efb560')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/dbus-${pkgver}"
|
||||
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
|
||||
--libexecdir=/usr/lib/dbus-1.0 --with-dbus-user=81 \
|
||||
--with-system-pid-file=/var/run/dbus.pid \
|
||||
--enable-inotify --disable-dnotify \
|
||||
--disable-verbose-mode --disable-static \
|
||||
--disable-tests --disable-asserts --without-x || return 1
|
||||
make || return 1
|
||||
make DESTDIR="${pkgdir}" install || return 1
|
||||
|
||||
rm -f "${pkgdir}/usr/bin/dbus-launch"
|
||||
rm -f "${pkgdir}/usr/share/man/man1/dbus-launch.1"
|
||||
|
||||
chown 81:81 "${pkgdir}/var/run/dbus" || return 1
|
||||
|
||||
install -m755 -d "${pkgdir}/etc/rc.d" || return 1
|
||||
install -m755 "${srcdir}/dbus" "${pkgdir}/etc/rc.d/" || return 1
|
||||
|
||||
#Fix configuration file
|
||||
sed -i -e 's|<user>81</user>|<user>dbus</user>|' "${pkgdir}/etc/dbus-1/system.conf" || return 1
|
||||
|
||||
#install .keep files so pacman doesn't delete empty dirs
|
||||
touch "${pkgdir}/usr/share/dbus-1/services/.keep" || return 1
|
||||
touch "${pkgdir}/usr/share/dbus-1/system-services/.keep" || return 1
|
||||
touch "${pkgdir}/etc/dbus-1/session.d/.keep" || return 1
|
||||
touch "${pkgdir}/etc/dbus-1/system.d/.keep" || return 1
|
||||
|
||||
rmdir "${pkgdir}/usr/lib/dbus-1.0/dbus-1" || return 1
|
||||
|
||||
install -d -m755 "${pkgdir}/usr/share/licenses/dbus-core"
|
||||
install -m644 COPYING "${pkgdir}/usr/share/licenses/dbus-core/" || return 1
|
||||
}
|
|
@ -1,57 +0,0 @@
|
|||
#!/bin/bash
|
||||
|
||||
# general config
|
||||
. /etc/rc.conf
|
||||
. /etc/rc.d/functions
|
||||
|
||||
case "$1" in
|
||||
start)
|
||||
stat_busy "Starting D-BUS system messagebus"
|
||||
if [ ! -x /var/run/dbus ] ; then
|
||||
install -m755 -g 81 -o 81 -d /var/run/dbus
|
||||
fi
|
||||
if [ -x /usr/bin/dbus-uuidgen ] ; then
|
||||
/usr/bin/dbus-uuidgen --ensure
|
||||
fi
|
||||
|
||||
/usr/bin/dbus-daemon --system
|
||||
if [ $? -gt 0 ]; then
|
||||
stat_fail
|
||||
else
|
||||
add_daemon dbus
|
||||
stat_done
|
||||
fi
|
||||
;;
|
||||
stop)
|
||||
stat_busy "Stopping D-BUS system messagebus"
|
||||
[ -f /var/run/dbus.pid ] && kill `cat /var/run/dbus.pid` >/dev/null 2>&1
|
||||
if [ $? -gt 0 ]; then
|
||||
stat_fail
|
||||
else
|
||||
rm -f /var/run/dbus.pid
|
||||
rm_daemon dbus
|
||||
stat_done
|
||||
fi
|
||||
;;
|
||||
restart)
|
||||
$0 stop
|
||||
sleep 1
|
||||
$0 start
|
||||
;;
|
||||
reload)
|
||||
stat_busy "Reloading D-BUS configuration"
|
||||
[ -f /var/run/dbus.pid ] && /usr/bin/dbus-send \
|
||||
--system --type=method_call \
|
||||
--dest=org.freedesktop.DBus \
|
||||
/ org.freedesktop.DBus.ReloadConfig
|
||||
if [ $? -gt 0 ]; then
|
||||
stat_fail
|
||||
else
|
||||
stat_done
|
||||
fi
|
||||
;;
|
||||
*)
|
||||
echo "usage: $0 {start|stop|restart|reload}"
|
||||
;;
|
||||
esac
|
||||
exit 0
|
|
@ -1,20 +0,0 @@
|
|||
post_install() {
|
||||
getent group dbus >/dev/null || usr/sbin/groupadd -g 81 dbus
|
||||
getent passwd dbus >/dev/null || usr/sbin/useradd -c 'System message bus' -u 81 -g dbus -d '/' -s /bin/false dbus
|
||||
usr/bin/passwd -l dbus &>/dev/null
|
||||
dbus-uuidgen --ensure
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
|
||||
#Make sure new rc script can shutdown running dbus
|
||||
if [ -f var/run/dbus/pid ]; then
|
||||
mv var/run/dbus/pid var/run/dbus.pid
|
||||
fi
|
||||
}
|
||||
|
||||
pre_remove() {
|
||||
usr/sbin/userdel dbus &>/dev/null
|
||||
usr/sbin/groupdel dbus &>/dev/null
|
||||
}
|
|
@ -1,62 +0,0 @@
|
|||
# Maintainer: Philipp Scholl <pscholl@bawue.de>
|
||||
pkgname=ncurses
|
||||
pkgver=5.7
|
||||
pkgrel=3
|
||||
pkgdesc="System V Release 4.0 curses emulation library"
|
||||
arch=(arm)
|
||||
url="http://www.gnu.org/software/ncurses/"
|
||||
license=('MIT')
|
||||
groups=('base')
|
||||
depends=('glibc')
|
||||
source=(ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
|
||||
md5sums=('cce05daf61a64501ef6cd8da1f727ec6')
|
||||
|
||||
build() {
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
|
||||
./configure --prefix=/usr --mandir=/usr/share/man \
|
||||
--with-shared --with-normal --without-debug --without-ada \
|
||||
--with-install-prefix=${pkgdir} --enable-widec
|
||||
make || return 1
|
||||
make install
|
||||
|
||||
# move libraries needed for boot to /lib (we call tput in initscripts)
|
||||
install -dm755 ${pkgdir}/lib
|
||||
mv ${pkgdir}/usr/lib/libncursesw.so.5* ${pkgdir}/lib
|
||||
ln -sf ../../lib/libncursesw.so.5 ${pkgdir}/usr/lib/libncursesw.so
|
||||
|
||||
# Fool packages looking to link to non-wide-character ncurses libraries
|
||||
for lib in curses ncurses form panel menu ; do \
|
||||
rm -f ${pkgdir}/usr/lib/lib${lib}.so ; \
|
||||
echo "INPUT(-l${lib}w)" >${pkgdir}/usr/lib/lib${lib}.so ; \
|
||||
ln -sf lib${lib}w.a ${pkgdir}/usr/lib/lib${lib}.a ; \
|
||||
done
|
||||
ln -sf libncurses++w.a ${pkgdir}/usr/lib/libncurses++.a
|
||||
|
||||
# install tput to /bin
|
||||
install -dm755 ${pkgdir}/bin/
|
||||
mv ${pkgdir}/usr/bin/tput ${pkgdir}/bin/tput
|
||||
|
||||
# Some packages look for -lcurses during build
|
||||
rm -f ${pkgdir}/usr/lib/libcursesw.so
|
||||
echo "INPUT(-lncursesw)" >${pkgdir}/usr/lib/libcursesw.so
|
||||
ln -sf libncurses.so ${pkgdir}/usr/lib/libcurses.so
|
||||
ln -sf libncursesw.a ${pkgdir}/usr/lib/libcursesw.a
|
||||
ln -sf libncurses.a ${pkgdir}/usr/lib/libcurses.a
|
||||
|
||||
# Install libncurses.so.5 for external binary support
|
||||
[ $CARCH = "x86_64" ] && CONFIGFLAG="--with-chtype=long"
|
||||
./configure --prefix=/usr \
|
||||
--with-shared --with-normal --without-debug --without-ada \
|
||||
--with-install-prefix=${pkgdir} $CONFIGFLAG
|
||||
make || return 1
|
||||
|
||||
install -Dm755 lib/libncurses.so.${pkgver} ${pkgdir}/usr/lib/libncurses.so.${pkgver}
|
||||
ln -sf libncurses.so.${pkgver} ${pkgdir}/usr/lib/libncurses.so.5
|
||||
|
||||
# install license, rip it from the readme
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
install -dm755 ${pkgdir}/usr/share/licenses/$pkgname
|
||||
grep -B 100 '$Id' README > ${pkgdir}/usr/share/licenses/${pkgname}/license.txt
|
||||
|
||||
}
|
|
@ -1,100 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 20_pidof.dpatch by Petter Reinholdtsen
|
||||
##
|
||||
## All lines beginning with `## DP:' are a description of the patch.
|
||||
## DP: Modify pidof to not print empty line if no pid was found. (bug: #225476)
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad trunk~/src/killall5.c trunk/src/killall5.c
|
||||
--- trunk~/src/killall5.c 2008-03-26 09:30:38.000000000 +0100
|
||||
+++ trunk/src/killall5.c 2008-03-26 09:31:14.000000000 +0100
|
||||
@@ -378,8 +378,8 @@
|
||||
int foundone = 0;
|
||||
int ok = 0;
|
||||
|
||||
- /* Try to stat the executable. */
|
||||
- if (prog[0] == '/' && stat(prog, &st) == 0) dostat++;
|
||||
+ if (! prog)
|
||||
+ return NULL;
|
||||
|
||||
/* Get basename of program. */
|
||||
if ((s = strrchr(prog, '/')) == NULL)
|
||||
@@ -387,9 +387,16 @@
|
||||
else
|
||||
s++;
|
||||
|
||||
+ if (! *s)
|
||||
+ return NULL;
|
||||
+
|
||||
q = (PIDQ_HEAD *)xmalloc(sizeof(PIDQ_HEAD));
|
||||
q = init_pid_q(q);
|
||||
|
||||
+ /* Try to stat the executable. */
|
||||
+ if (prog[0] == '/' && stat(prog, &st) == 0)
|
||||
+ dostat++;
|
||||
+
|
||||
/* First try to find a match based on dev/ino pair. */
|
||||
if (dostat) {
|
||||
for (p = plist; p; p = p->next) {
|
||||
@@ -404,15 +411,35 @@
|
||||
if (!foundone) for (p = plist; p; p = p->next) {
|
||||
ok = 0;
|
||||
|
||||
- /* Compare name (both basename and full path) */
|
||||
- ok += (p->argv0 && strcmp(p->argv0, prog) == 0);
|
||||
- ok += (p->argv0 && strcmp(p->argv0base, s) == 0);
|
||||
+ /* matching nonmatching
|
||||
+ * proc name prog name prog name
|
||||
+ * --- ----------- ------------
|
||||
+ * b b, p/b, q/b
|
||||
+ * p/b b, p/b q/b
|
||||
+ *
|
||||
+ * Algorithm: Match if:
|
||||
+ * cmd = arg
|
||||
+ * or cmd = base(arg)
|
||||
+ * or base(cmd) = arg
|
||||
+ *
|
||||
+ * Specifically, do not match just because base(cmd) = base(arg)
|
||||
+ * as was done in earlier versions of this program, since this
|
||||
+ * allows /aaa/foo to match /bbb/foo .
|
||||
+ */
|
||||
+ ok |=
|
||||
+ (p->argv0 && strcmp(p->argv0, prog) == 0)
|
||||
+ || (p->argv0 && s != prog && strcmp(p->argv0, s) == 0)
|
||||
+ || (p->argv0base && strcmp(p->argv0base, prog) == 0);
|
||||
|
||||
/* For scripts, compare argv[1] as well. */
|
||||
- if (scripts_too && p->argv1 &&
|
||||
- !strncmp(p->statname, p->argv1base, STATNAMELEN)) {
|
||||
- ok += (strcmp(p->argv1, prog) == 0);
|
||||
- ok += (strcmp(p->argv1base, s) == 0);
|
||||
+ if (
|
||||
+ scripts_too && p->statname && p->argv1base
|
||||
+ && !strncmp(p->statname, p->argv1base, STATNAMELEN)
|
||||
+ ) {
|
||||
+ ok |=
|
||||
+ (p->argv1 && strcmp(p->argv1, prog) == 0)
|
||||
+ || (p->argv1 && s != prog && strcmp(p->argv1, s) == 0)
|
||||
+ || (p->argv1base && strcmp(p->argv1base, prog) == 0);
|
||||
}
|
||||
|
||||
/*
|
||||
@@ -423,7 +450,7 @@
|
||||
(p->argv0 == NULL ||
|
||||
p->argv0[0] == 0 ||
|
||||
strchr(p->argv0, ' '))) {
|
||||
- ok += (strcmp(p->statname, s) == 0);
|
||||
+ ok |= (strcmp(p->statname, s) == 0);
|
||||
}
|
||||
if (ok) add_pid_to_q(q, p);
|
||||
}
|
||||
@@ -548,7 +575,8 @@
|
||||
}
|
||||
}
|
||||
}
|
||||
- printf("\n");
|
||||
+ if (!first)
|
||||
+ printf("\n");
|
||||
closelog();
|
||||
return(first ? 1 : 0);
|
||||
}
|
|
@ -1,28 +0,0 @@
|
|||
# Maintainer: Alexander Foremny <alexanderforemny@gmail.com>
|
||||
|
||||
pkgname=sysvinit
|
||||
pkgver=2.86
|
||||
pkgrel=3
|
||||
pkgdesc="Linux System V Init"
|
||||
arch=(arm)
|
||||
license=('GPL')
|
||||
groups=('base' 'small-base')
|
||||
depends=('shadow' 'util-linux' 'coreutils' 'glibc' 'awk')
|
||||
source=(ftp://ftp.cistron.nl/pub/people/miquels/$pkgname/$pkgname-$pkgver.tar.gz)
|
||||
md5sums=('7d5d61c026122ab791ac04c8a84db967')
|
||||
|
||||
build() {
|
||||
cd $srcdir/sysvinit-$pkgver
|
||||
|
||||
cp src/init.c src/init.c.backup
|
||||
sed 's/\(.*\)\(Sending processes\)\(.*\)/\1\2 started by init\3/' \
|
||||
src/init.c > tmp~
|
||||
mv tmp~ src/init.c
|
||||
mkdir -p $startdir/pkg/bin $startdir/pkg/sbin
|
||||
mkdir -p $startdir/pkg/usr/bin
|
||||
mkdir -p $startdir/pkg/usr/man/man5 $startdir/pkg/usr/man/man8
|
||||
mkdir -p $startdir/pkg/usr/man/man1 $startdir/pkg/usr/include
|
||||
make -C src || return 1
|
||||
make -C src MANDIR=/usr/man ROOT=$startdir/pkg install
|
||||
}
|
||||
|
|
@ -1,46 +0,0 @@
|
|||
# Maintainer: Mike Staszel <mikestaszel@openpogo.com>
|
||||
|
||||
pkgname=util-linux-ng
|
||||
pkgver=2.16
|
||||
_loop_date=20090725
|
||||
pkgrel=1
|
||||
pkgdesc="Miscellaneous system utilities for Linux"
|
||||
url="http://userweb.kernel.org/~kzak/util-linux-ng/"
|
||||
arch=(i686 x86_64 arm)
|
||||
groups=('base')
|
||||
depends=('bash' 'ncurses>=5.7' 'zlib')
|
||||
replaces=('linux32' 'util-linux')
|
||||
conflicts=('linux32' 'util-linux')
|
||||
provides=('linux32' 'util-linux')
|
||||
license=('GPL2')
|
||||
options=('!libtool')
|
||||
source=(ftp://ftp.kernel.org/pub/linux/utils/${pkgname}/v2.16/${pkgname}-${pkgver}.tar.bz2
|
||||
http://loop-aes.sourceforge.net/updates/${pkgname}-${pkgver}-${_loop_date}.diff.bz2
|
||||
fsck-static.patch)
|
||||
install=util-linux-ng.install
|
||||
md5sums=('9623380641b0c2e0449f5b1ecc567663'
|
||||
'1752b93df05410a8df8e84d07d41f048'
|
||||
'35c3ba312782f042b594399b50b8de62')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
# Provide static fsck
|
||||
patch -Np1 -i "${srcdir}/fsck-static.patch" || return 1
|
||||
|
||||
# cryptoloop support
|
||||
patch -Np1 -i "${srcdir}/${pkgname}-${pkgver}-${_loop_date}.diff" || return 1
|
||||
# hardware clock
|
||||
sed -e 's%etc/adjtime%var/lib/hwclock/adjtime%' -i hwclock/hwclock.c || return 1
|
||||
mkdir -p "${pkgdir}/var/lib/hwclock" || return 1
|
||||
autoconf || return 1
|
||||
automake || return 1
|
||||
./configure --enable-arch --enable-write --enable-raw --disable-wall --enable-rdev || return 1
|
||||
make HAVE_SLN=yes ADD_RAW=yes || return 1
|
||||
make HAVE_SLN=yes ADD_RAW=yes DESTDIR="${pkgdir}" install || return 1
|
||||
# remove files
|
||||
rm -f "${pkgdir}/bin/kill"
|
||||
rm -f "${pkgdir}/usr/share/man/man1/kill.1"
|
||||
rm -f "${pkgdir}/usr/share/man/man5/nfs.5"
|
||||
rm -f "${pkgdir}/usr/share/info/dir"
|
||||
gzip -9 "${pkgdir}/usr/share/info/ipc.info" || return 1
|
||||
}
|
|
@ -1,29 +0,0 @@
|
|||
--- util-linux-ng-2.16/fsck/Makefile.am 2009-07-04 01:20:01.000000000 +0200
|
||||
+++ util-linux-ng-2.16.new/fsck/Makefile.am 2009-08-01 14:16:31.000000000 +0200
|
||||
@@ -1,17 +1,25 @@
|
||||
include $(top_srcdir)/config/include-Makefile.am
|
||||
|
||||
-sbin_PROGRAMS = fsck
|
||||
+sbin_PROGRAMS = fsck fsck.static
|
||||
dist_man_MANS = fsck.8
|
||||
|
||||
fsck_SOURCES = base_device.c fsck.c fsck.h ../lib/ismounted.c \
|
||||
../lib/fsprobe.c ../lib/canonicalize.c
|
||||
+fsck_static_SOURCES = $(fsck_SOURCES)
|
||||
fsck_LDADD =
|
||||
fsck_CFLAGS =
|
||||
+fsck_static_LDADD =
|
||||
+fsck_static_CFLAGS =
|
||||
+fsck_static_LDFLAGS = -all-static
|
||||
|
||||
if BUILD_LIBBLKID
|
||||
fsck_LDADD += $(ul_libblkid_la)
|
||||
fsck_CFLAGS += -I$(ul_libblkid_srcdir)
|
||||
+fsck_static_LDADD += $(ul_libblkid_la)
|
||||
+fsck_static_CFLAGS += -I$(ul_libblkid_srcdir)
|
||||
else
|
||||
fsck_LDADD += $(BLKID_LIBS)
|
||||
fsck_CFLAGS += $(BLKID_CFLAGS)
|
||||
+fsck_static_LDADD += $(BLKID_LIBS)
|
||||
+fsck_static_CFLAGS += $(BLKID_CFLAGS)
|
||||
endif
|
|
@ -1,21 +0,0 @@
|
|||
infodir=/usr/share/info
|
||||
filelist=(ipc.info.gz)
|
||||
|
||||
post_install() {
|
||||
[ -x usr/bin/install-info ] || return 0
|
||||
for file in ${filelist[@]}; do
|
||||
usr/bin/install-info $infodir/$file $infodir/dir 2> /dev/null
|
||||
done
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install $1
|
||||
}
|
||||
|
||||
pre_remove() {
|
||||
[ -x usr/bin/install-info ] || return 0
|
||||
for file in ${filelist[@]}; do
|
||||
usr/bin/install-info --delete $infodir/$file $infodir/dir 2> /dev/null
|
||||
done
|
||||
}
|
||||
|
Loading…
Reference in a new issue