mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed community/synergy
This commit is contained in:
parent
76d0dd6634
commit
242412796b
4 changed files with 0 additions and 198 deletions
|
@ -1,65 +0,0 @@
|
||||||
# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
|
|
||||||
# Contributor: Jelle van der Waa <jelle vdwaa nl>
|
|
||||||
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
|
|
||||||
# Contributor: Dale Blount <dale@archlinux.org>
|
|
||||||
# Contributor: Michael Düll <mail@akurei.me>
|
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
# - patch to use the system crypto++ library
|
|
||||||
|
|
||||||
pkgname=synergy
|
|
||||||
pkgver=1.4.15
|
|
||||||
pkgrel=1
|
|
||||||
pkgdesc="Share a single mouse and keyboard between multiple computers"
|
|
||||||
url="http://synergy-foss.org"
|
|
||||||
arch=('i686' 'x86_64')
|
|
||||||
depends=('gcc-libs' 'libxtst' 'libxinerama' 'crypto++')
|
|
||||||
makedepends=('libxt' 'cmake' 'qt4' 'unzip')
|
|
||||||
optdepends=('qt4: gui support')
|
|
||||||
license=('GPL2')
|
|
||||||
source=("http://synergy.googlecode.com/files/$pkgname-$pkgver-Source.tar.gz"
|
|
||||||
"system-cryptopp.patch"
|
|
||||||
"synergys.socket"
|
|
||||||
"synergys.service")
|
|
||||||
sha512sums=('857e8cbfb0b32c7dc325de5765f182f4e4fb198443b4a3e26d38c2d3dec3819e57057b91a202b53c86d4fad18154d1d58b401812dd8fabc384255e44d4b4b01a'
|
|
||||||
'6fc79d78c24daaafd7e50c31581788d48fb1591105644a55584282c55c4cdee10e4f374216fecd7253030e692d358165ef349caab1675ed1d1d1f101fb46b8c0'
|
|
||||||
'f7d918faf4a25654786f270fc48b6e4089ecd1b2f504bb90de543b47a862733f7be067e06fd613d621bba48d20dc63214966e2cfbd2cb3fcbfe623d6d41f10ad'
|
|
||||||
'a10dfe5b24ac6f4a2ef3a3a9f8a6a3c432b91d5e59d1fae2258d37c5be00ac8f172656fa0d213012c7dc94ab8c04c3945ae33acfcd5db5fad8b37ccc9f5e980f')
|
|
||||||
|
|
||||||
build() {
|
|
||||||
cd "${srcdir}/${pkgname}-${pkgver}-Source"
|
|
||||||
|
|
||||||
patch -p1 -i ../system-cryptopp.patch
|
|
||||||
|
|
||||||
# Unzip the crypto library
|
|
||||||
unzip -d tools/cryptopp562 tools/cryptopp562.zip
|
|
||||||
|
|
||||||
cmake -D CMAKE_INSTALL_PREFIX=/usr .
|
|
||||||
make
|
|
||||||
|
|
||||||
cd src/gui
|
|
||||||
qmake-qt4
|
|
||||||
make
|
|
||||||
}
|
|
||||||
|
|
||||||
package() {
|
|
||||||
cd "${srcdir}/${pkgname}-${pkgver}-Source/bin"
|
|
||||||
|
|
||||||
# install binary
|
|
||||||
install -Dm755 synergy "$pkgdir/usr/bin/synergy"
|
|
||||||
install -Dm755 synergyc "$pkgdir/usr/bin/synergyc"
|
|
||||||
install -Dm755 synergys "$pkgdir/usr/bin/synergys"
|
|
||||||
|
|
||||||
# install config
|
|
||||||
install -Dm644 "$srcdir/$pkgname-$pkgver-Source/doc/${pkgname}.conf.example" "${pkgdir}/etc/${pkgname}.conf.example"
|
|
||||||
|
|
||||||
# install systemd service and socket
|
|
||||||
install -d "$pkgdir/usr/lib/systemd/system"
|
|
||||||
install -Dm644 "$srcdir/synergys.service" "$pkgdir/usr/lib/systemd/system/"
|
|
||||||
install -Dm644 "$srcdir/synergys.socket" "$pkgdir/usr/lib/systemd/system/"
|
|
||||||
|
|
||||||
# install desktop/icon stuff
|
|
||||||
cd ../res
|
|
||||||
install -Dm644 "synergy.ico" "$pkgdir/usr/share/pixmaps/synergy.ico"
|
|
||||||
install -Dm644 "synergy.desktop" "$pkgdir/usr/share/applications/synergy.desktop"
|
|
||||||
}
|
|
|
@ -1,10 +0,0 @@
|
||||||
[Unit]
|
|
||||||
Description=Synergy Server Daemon
|
|
||||||
After=network.target
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
Type=forking
|
|
||||||
ExecStart=/usr/bin/synergys --config /etc/synergy.conf
|
|
||||||
|
|
||||||
[Install]
|
|
||||||
WantedBy=multi-user.target
|
|
|
@ -1,9 +0,0 @@
|
||||||
[Unit]
|
|
||||||
Conflicts=synergys.service
|
|
||||||
|
|
||||||
[Socket]
|
|
||||||
ListenStream=24800
|
|
||||||
Accept=false
|
|
||||||
|
|
||||||
[Install]
|
|
||||||
WantedBy=sockets.target
|
|
|
@ -1,114 +0,0 @@
|
||||||
diff -urN a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
--- a/CMakeLists.txt 2013-10-08 04:19:02.000000000 -0600
|
|
||||||
+++ b/CMakeLists.txt 2013-10-18 17:46:11.290667774 -0600
|
|
||||||
@@ -75,6 +75,7 @@
|
|
||||||
include(CheckIncludeFileCXX)
|
|
||||||
include(CheckSymbolExists)
|
|
||||||
include(CheckCSourceCompiles)
|
|
||||||
+ include(FindPkgConfig)
|
|
||||||
|
|
||||||
check_include_file_cxx(istream HAVE_ISTREAM)
|
|
||||||
check_include_file_cxx(ostream HAVE_OSTREAM)
|
|
||||||
@@ -204,6 +205,8 @@
|
|
||||||
check_library_exists("Xi" XISelectEvents "" HAVE_Xi)
|
|
||||||
check_library_exists("Xrandr" XRRQueryExtension "" HAVE_Xrandr)
|
|
||||||
|
|
||||||
+ pkg_search_module(CRYPTOPP libcrypto++)
|
|
||||||
+
|
|
||||||
if (HAVE_ICE)
|
|
||||||
|
|
||||||
# Assume we have SM if we have ICE.
|
|
||||||
@@ -241,6 +244,10 @@
|
|
||||||
list(APPEND libs Xrandr)
|
|
||||||
endif()
|
|
||||||
|
|
||||||
+ if (HAVE_CRYPTOPP)
|
|
||||||
+ list(APPEND libs CRYPTOPP_LIBRARIES)
|
|
||||||
+ endif()
|
|
||||||
+
|
|
||||||
endif()
|
|
||||||
|
|
||||||
IF(HAVE_Xi)
|
|
||||||
diff -urN a/src/lib/io/CCryptoMode.h b/src/lib/io/CCryptoMode.h
|
|
||||||
--- a/src/lib/io/CCryptoMode.h 2013-05-30 07:48:08.000000000 -0600
|
|
||||||
+++ b/src/lib/io/CCryptoMode.h 2013-10-18 17:48:48.300057303 -0600
|
|
||||||
@@ -17,9 +17,9 @@
|
|
||||||
|
|
||||||
#pragma once
|
|
||||||
|
|
||||||
-#include <cryptopp562/gcm.h>
|
|
||||||
-#include <cryptopp562/modes.h>
|
|
||||||
-#include <cryptopp562/aes.h>
|
|
||||||
+#include <cryptopp/gcm.h>
|
|
||||||
+#include <cryptopp/modes.h>
|
|
||||||
+#include <cryptopp/aes.h>
|
|
||||||
#include "ECryptoMode.h"
|
|
||||||
#include "CString.h"
|
|
||||||
|
|
||||||
diff -urN a/src/lib/io/CCryptoStream.h b/src/lib/io/CCryptoStream.h
|
|
||||||
--- a/src/lib/io/CCryptoStream.h 2013-06-29 08:17:49.000000000 -0600
|
|
||||||
+++ b/src/lib/io/CCryptoStream.h 2013-10-18 17:49:02.250003064 -0600
|
|
||||||
@@ -20,8 +20,8 @@
|
|
||||||
#include "BasicTypes.h"
|
|
||||||
#include "CStreamFilter.h"
|
|
||||||
#include "CCryptoMode.h"
|
|
||||||
-#include <cryptopp562/osrng.h>
|
|
||||||
-#include <cryptopp562/sha.h>
|
|
||||||
+#include <cryptopp/osrng.h>
|
|
||||||
+#include <cryptopp/sha.h>
|
|
||||||
|
|
||||||
class CCryptoOptions;
|
|
||||||
|
|
||||||
diff -urN a/tools/build/toolchain.py b/tools/build/toolchain.py
|
|
||||||
--- a/tools/build/toolchain.py 2013-08-02 07:21:06.000000000 -0600
|
|
||||||
+++ b/tools/build/toolchain.py 2013-10-18 17:49:32.674884769 -0600
|
|
||||||
@@ -67,7 +67,7 @@
|
|
||||||
macSdk = None
|
|
||||||
|
|
||||||
# cryptoPP dir with version number
|
|
||||||
- cryptoPPDir = 'cryptopp562'
|
|
||||||
+ cryptoPPDir = 'cryptopp'
|
|
||||||
|
|
||||||
win32_generators = {
|
|
||||||
1 : Generator('Visual Studio 10'),
|
|
||||||
diff -urN a/tools/CMakeLists.txt b/tools/CMakeLists.txt
|
|
||||||
--- a/tools/CMakeLists.txt 2013-06-04 12:22:58.000000000 -0600
|
|
||||||
+++ b/tools/CMakeLists.txt 2013-10-18 17:48:12.140197897 -0600
|
|
||||||
@@ -13,7 +13,7 @@
|
|
||||||
# You should have received a copy of the GNU General Public License
|
|
||||||
# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
|
||||||
|
|
||||||
-set(cryptopp_dir cryptopp562)
|
|
||||||
+set(cryptopp_dir cryptopp)
|
|
||||||
|
|
||||||
# only compile the crypto++ files we need.
|
|
||||||
set(cryptopp_src
|
|
||||||
@@ -72,16 +72,20 @@
|
|
||||||
endif()
|
|
||||||
|
|
||||||
if (UNIX)
|
|
||||||
- add_definitions(-DCRYPTOPP_DISABLE_ASM)
|
|
||||||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -pipe")
|
|
||||||
+ if (NOT CRYPTOPP_FOUND)
|
|
||||||
+ add_definitions(-DCRYPTOPP_DISABLE_ASM)
|
|
||||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -pipe")
|
|
||||||
|
|
||||||
- if (APPLE)
|
|
||||||
- if (DARWIN_VERSION GREATER 10)
|
|
||||||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-tautological-compare")
|
|
||||||
+ if (APPLE)
|
|
||||||
+ if (DARWIN_VERSION GREATER 10)
|
|
||||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-tautological-compare")
|
|
||||||
+ endif()
|
|
||||||
+ else()
|
|
||||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=native")
|
|
||||||
endif()
|
|
||||||
- else()
|
|
||||||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=native")
|
|
||||||
endif()
|
|
||||||
endif()
|
|
||||||
|
|
||||||
-add_library(cryptopp STATIC ${cryptopp_src})
|
|
||||||
+if (NOT CRYPTOPP_FOUND)
|
|
||||||
+ add_library(cryptopp STATIC ${cpp_src})
|
|
||||||
+endif()
|
|
Loading…
Reference in a new issue