extra/llvm to 5.0.0-1

This commit is contained in:
Kevin Mihelich 2017-09-16 20:06:50 +00:00
parent 2bc453924a
commit 246b605992
5 changed files with 61 additions and 177 deletions

View file

@ -1,4 +1,4 @@
From ea7d4d81905ff99c5c04388909f501b1da451b79 Mon Sep 17 00:00:00 2001
From fedcf1d9691bf669d8cd771a032e851d8247aff9 Mon Sep 17 00:00:00 2001
From: Evangelos Foutras <evangelos@foutrelis.com>
Date: Thu, 6 Jul 2017 18:53:05 +0300
Subject: [PATCH 1/2] GCC compatibility: Ignore the -fno-plt flag
@ -9,10 +9,10 @@ Subject: [PATCH 1/2] GCC compatibility: Ignore the -fno-plt flag
2 files changed, 2 insertions(+)
diff --git a/include/clang/Driver/Options.td b/include/clang/Driver/Options.td
index 6be159fad6..364296e861 100644
index 05dc9d7eb3..c93e6cc08c 100644
--- a/include/clang/Driver/Options.td
+++ b/include/clang/Driver/Options.td
@@ -2277,6 +2277,7 @@ defm ivopts : BooleanFFlag<"ivopts">, Group<clang_ignored_gcc_optimization_f_Gro
@@ -2505,6 +2505,7 @@ defm ivopts : BooleanFFlag<"ivopts">, Group<clang_ignored_gcc_optimization_f_Gro
defm non_call_exceptions : BooleanFFlag<"non-call-exceptions">, Group<clang_ignored_f_Group>;
defm peel_loops : BooleanFFlag<"peel-loops">, Group<clang_ignored_gcc_optimization_f_Group>;
defm permissive : BooleanFFlag<"permissive">, Group<clang_ignored_f_Group>;
@ -21,7 +21,7 @@ index 6be159fad6..364296e861 100644
defm printf : BooleanFFlag<"printf">, Group<clang_ignored_f_Group>;
defm profile : BooleanFFlag<"profile">, Group<clang_ignored_f_Group>;
diff --git a/test/Driver/clang_f_opts.c b/test/Driver/clang_f_opts.c
index 210e16935d..3999590c47 100644
index c17cec6eba..d9480c915e 100644
--- a/test/Driver/clang_f_opts.c
+++ b/test/Driver/clang_f_opts.c
@@ -277,6 +277,7 @@
@ -33,5 +33,5 @@ index 210e16935d..3999590c47 100644
// RUN: -fno-check-new -fcheck-new \
// RUN: -ffriend-injection \
--
2.13.2
2.14.1

View file

@ -1,4 +1,4 @@
From 7c483b3a7b2d87ae1d0dde1e5c12fa2bdb22d681 Mon Sep 17 00:00:00 2001
From 60fa751da239e592b31bde2533342dac64359e7f Mon Sep 17 00:00:00 2001
From: Evangelos Foutras <evangelos@foutrelis.com>
Date: Thu, 6 Jul 2017 18:15:43 +0300
Subject: [PATCH 2/2] Enable SSP and PIE by default
@ -17,9 +17,9 @@ solution, but a simple temporary fix.
Hopefully these changes will be obsoleted by the introduction upstream
of a compile-time option (https://bugs.llvm.org/show_bug.cgi?id=13410)
---
lib/Driver/ToolChains.cpp | 14 +++++++++++++-
lib/Driver/ToolChains.h | 1 +
lib/Driver/Tools.cpp | 1 +
lib/Driver/ToolChains/Gnu.cpp | 1 +
lib/Driver/ToolChains/Linux.cpp | 14 +++++++++++++-
lib/Driver/ToolChains/Linux.h | 1 +
test/Driver/cross-linux.c | 16 ++++++++--------
test/Driver/env.c | 2 +-
test/Driver/fsanitize.c | 18 ++++++++++--------
@ -30,17 +30,29 @@ of a compile-time option (https://bugs.llvm.org/show_bug.cgi?id=13410)
test/Driver/stack-protector.c | 4 ++--
11 files changed, 42 insertions(+), 24 deletions(-)
diff --git a/lib/Driver/ToolChains.cpp b/lib/Driver/ToolChains.cpp
index 9bc9ae4f6a..add512e0a5 100644
--- a/lib/Driver/ToolChains.cpp
+++ b/lib/Driver/ToolChains.cpp
@@ -4710,7 +4710,19 @@ void Linux::AddIAMCUIncludeArgs(const ArgList &DriverArgs,
diff --git a/lib/Driver/ToolChains/Gnu.cpp b/lib/Driver/ToolChains/Gnu.cpp
index 72a9f85ba3..4fd567b03b 100644
--- a/lib/Driver/ToolChains/Gnu.cpp
+++ b/lib/Driver/ToolChains/Gnu.cpp
@@ -417,6 +417,7 @@ void tools::gnutools::Linker::ConstructJob(Compilation &C, const JobAction &JA,
const bool IsIAMCU = ToolChain.getTriple().isOSIAMCU();
const bool IsPIE =
!Args.hasArg(options::OPT_shared) && !Args.hasArg(options::OPT_static) &&
+ !Args.hasArg(options::OPT_nopie) &&
(Args.hasArg(options::OPT_pie) || ToolChain.isPIEDefault());
const bool HasCRTBeginEndFiles =
ToolChain.getTriple().hasEnvironment() ||
diff --git a/lib/Driver/ToolChains/Linux.cpp b/lib/Driver/ToolChains/Linux.cpp
index 08a27fa7fe..1dd70b115d 100644
--- a/lib/Driver/ToolChains/Linux.cpp
+++ b/lib/Driver/ToolChains/Linux.cpp
@@ -810,7 +810,19 @@ void Linux::AddIAMCUIncludeArgs(const ArgList &DriverArgs,
}
}
-bool Linux::isPIEDefault() const { return getSanitizerArgs().requiresPIE(); }
+bool Linux::isPIEDefault() const {
+ const bool IsMips = isMipsArch(getTriple().getArch());
+ const bool IsMips = tools::isMipsArch(getTriple().getArch());
+ const bool IsAndroid = getTriple().isAndroid();
+
+ if (IsMips || IsAndroid)
@ -55,11 +67,11 @@ index 9bc9ae4f6a..add512e0a5 100644
SanitizerMask Linux::getSupportedSanitizers() const {
const bool IsX86 = getTriple().getArch() == llvm::Triple::x86;
diff --git a/lib/Driver/ToolChains.h b/lib/Driver/ToolChains.h
index 3240357ba6..7afe0fb5da 100644
--- a/lib/Driver/ToolChains.h
+++ b/lib/Driver/ToolChains.h
@@ -880,6 +880,7 @@ public:
diff --git a/lib/Driver/ToolChains/Linux.h b/lib/Driver/ToolChains/Linux.h
index 9778c1832c..ddd46a1d58 100644
--- a/lib/Driver/ToolChains/Linux.h
+++ b/lib/Driver/ToolChains/Linux.h
@@ -36,6 +36,7 @@ public:
void AddIAMCUIncludeArgs(const llvm::opt::ArgList &DriverArgs,
llvm::opt::ArgStringList &CC1Args) const override;
bool isPIEDefault() const override;
@ -67,18 +79,6 @@ index 3240357ba6..7afe0fb5da 100644
SanitizerMask getSupportedSanitizers() const override;
void addProfileRTLibs(const llvm::opt::ArgList &Args,
llvm::opt::ArgStringList &CmdArgs) const override;
diff --git a/lib/Driver/Tools.cpp b/lib/Driver/Tools.cpp
index 4d4a8c2428..5b8e082797 100644
--- a/lib/Driver/Tools.cpp
+++ b/lib/Driver/Tools.cpp
@@ -10068,6 +10068,7 @@ void gnutools::Linker::ConstructJob(Compilation &C, const JobAction &JA,
const bool IsIAMCU = ToolChain.getTriple().isOSIAMCU();
const bool IsPIE =
!Args.hasArg(options::OPT_shared) && !Args.hasArg(options::OPT_static) &&
+ !Args.hasArg(options::OPT_nopie) &&
(Args.hasArg(options::OPT_pie) || ToolChain.isPIEDefault());
const bool HasCRTBeginEndFiles =
ToolChain.getTriple().hasEnvironment() ||
diff --git a/test/Driver/cross-linux.c b/test/Driver/cross-linux.c
index a5ea832e77..1949c05a60 100644
--- a/test/Driver/cross-linux.c
@ -141,10 +141,10 @@ index 0371bc91c4..ea89f52512 100644
// CHECK-LD-32: "-L[[SYSROOT]]/usr/lib/gcc/i386-unknown-linux/4.6.0/../../../../i386-unknown-linux/lib"
// CHECK-LD-32: "-L[[SYSROOT]]/usr/lib/gcc/i386-unknown-linux/4.6.0/../../.."
diff --git a/test/Driver/fsanitize.c b/test/Driver/fsanitize.c
index 25aea01aae..c81da6715c 100644
index 0752ef6df0..5d1e211b24 100644
--- a/test/Driver/fsanitize.c
+++ b/test/Driver/fsanitize.c
@@ -182,13 +182,13 @@
@@ -192,13 +192,13 @@
// RUN: %clang -target x86_64-linux-gnu -fsanitize=vptr -fno-sanitize=vptr -fsanitize=undefined,address %s -### 2>&1
// OK
@ -162,7 +162,7 @@ index 25aea01aae..c81da6715c 100644
// CHECK-NO-PIE-NOT: "-pie"
// CHECK-NO-PIE: "-mrelocation-model" "static"
@@ -424,12 +424,12 @@
@@ -491,12 +491,12 @@
// RUN: %clang -fno-sanitize=safe-stack -### %s 2>&1 | FileCheck %s -check-prefix=NOSP
// NOSP-NOT: "-fsanitize=safe-stack"
@ -179,7 +179,7 @@ index 25aea01aae..c81da6715c 100644
// RUN: %clang -target i386-contiki-unknown -fsanitize=safe-stack -### %s 2>&1 | FileCheck %s -check-prefix=NO-SP
// NO-SP-NOT: stack-protector
// NO-SP: "-fsanitize=safe-stack"
@@ -439,6 +439,8 @@
@@ -506,6 +506,8 @@
// NO-SP-ASAN-NOT: stack-protector
// NO-SP-ASAN: "-fsanitize=address,safe-stack"
@ -201,10 +201,10 @@ index ca96757a2b..ae1c25e989 100644
// CHECK: "-L[[TOOLCHAIN]]/usr/lib/i386-linux-gnu/gcc/i686-linux-gnu/4.5"
// CHECK: "-L[[TOOLCHAIN]]/usr/lib/i386-linux-gnu/gcc/i686-linux-gnu/4.5/../../../.."
diff --git a/test/Driver/hexagon-toolchain-elf.c b/test/Driver/hexagon-toolchain-elf.c
index 827c19186b..a8f0918a8d 100644
index 98582450e3..b2da01eaf5 100644
--- a/test/Driver/hexagon-toolchain-elf.c
+++ b/test/Driver/hexagon-toolchain-elf.c
@@ -425,7 +425,7 @@
@@ -449,7 +449,7 @@
// RUN: %s 2>&1 \
// RUN: | FileCheck -check-prefix=CHECK042 %s
// CHECK042: "-cc1"
@ -214,10 +214,10 @@ index 827c19186b..a8f0918a8d 100644
// CHECK042-NEXT: llvm-mc
// CHECK042: "-gpsize=8"
diff --git a/test/Driver/linux-as.c b/test/Driver/linux-as.c
index a07abc17e5..d7b1a6041d 100644
index c5cb1cd600..1ad86d8ead 100644
--- a/test/Driver/linux-as.c
+++ b/test/Driver/linux-as.c
@@ -106,7 +106,7 @@
@@ -133,7 +133,7 @@
// CHECK-PPC-NO-MCPU-NOT: as{{.*}} "-mcpu=invalid-cpu"
//
// RUN: %clang -target sparc64-linux -mcpu=invalid-cpu -### \
@ -226,7 +226,7 @@ index a07abc17e5..d7b1a6041d 100644
// RUN: | FileCheck -check-prefix=CHECK-SPARCV9 %s
// CHECK-SPARCV9: as
// CHECK-SPARCV9: -64
@@ -115,7 +115,7 @@
@@ -142,7 +142,7 @@
// CHECK-SPARCV9: -o
//
// RUN: %clang -target sparc64-linux -mcpu=invalid-cpu -### \
@ -236,7 +236,7 @@ index a07abc17e5..d7b1a6041d 100644
// CHECK-SPARCV9PIC: as
// CHECK-SPARCV9PIC: -64
diff --git a/test/Driver/linux-ld.c b/test/Driver/linux-ld.c
index 5d1001beb0..f9f0969f1b 100644
index 1c5f1a4556..2885f78045 100644
--- a/test/Driver/linux-ld.c
+++ b/test/Driver/linux-ld.c
@@ -1,3 +1,5 @@
@ -264,5 +264,5 @@ index 6769b65f63..180e26f3ea 100644
// RUN: %clang -target i386-pc-openbsd -### %s 2>&1 | FileCheck %s -check-prefix=OPENBSD
--
2.13.2
2.14.1

View file

@ -14,11 +14,10 @@
buildarch=28
highmem=1
noautobuild=1
pkgname=('llvm' 'llvm-libs' 'llvm-ocaml' 'lld' 'lldb' 'clang' 'clang-tools-extra')
pkgver=4.0.1
pkgrel=5
pkgver=5.0.0
pkgrel=1
_ocaml_ver=4.05.0
arch=('i686' 'x86_64')
url="http://llvm.org/"
@ -28,35 +27,31 @@ makedepends=('cmake' 'libffi' 'python2' "ocaml=$_ocaml_ver" 'python-sphinx'
# Use gcc-multilib to build 32-bit compiler-rt libraries on x86_64 (FS#41911)
makedepends_x86_64=('gcc-multilib')
options=('staticlibs')
source=(http://releases.llvm.org/$pkgver/llvm-$pkgver.src.tar.xz{,.sig}
http://releases.llvm.org/$pkgver/cfe-$pkgver.src.tar.xz{,.sig}
http://releases.llvm.org/$pkgver/clang-tools-extra-$pkgver.src.tar.xz{,.sig}
http://releases.llvm.org/$pkgver/compiler-rt-$pkgver.src.tar.xz{,.sig}
http://releases.llvm.org/$pkgver/lld-$pkgver.src.tar.xz{,.sig}
http://releases.llvm.org/$pkgver/lldb-$pkgver.src.tar.xz{,.sig}
source=(https://releases.llvm.org/$pkgver/llvm-$pkgver.src.tar.xz{,.sig}
https://releases.llvm.org/$pkgver/cfe-$pkgver.src.tar.xz{,.sig}
https://releases.llvm.org/$pkgver/clang-tools-extra-$pkgver.src.tar.xz{,.sig}
https://releases.llvm.org/$pkgver/compiler-rt-$pkgver.src.tar.xz{,.sig}
https://releases.llvm.org/$pkgver/lld-$pkgver.src.tar.xz{,.sig}
https://releases.llvm.org/$pkgver/lldb-$pkgver.src.tar.xz{,.sig}
0001-GCC-compatibility-Ignore-the-fno-plt-flag.patch
0002-Enable-SSP-and-PIE-by-default.patch
disable-llvm-symbolizer-test.patch
lldb-gcc7.patch
lldb-libedit.patch
llvm-config.h)
sha256sums=('da783db1f82d516791179fe103c71706046561f7972b18f0049242dee6712b51'
sha256sums=('e35dcbae6084adcf4abb32514127c5eabd7d63b733852ccdb31e06f1373136da'
'SKIP'
'61738a735852c23c3bdbe52d035488cdb2083013f384d67c1ba36fabebd8769b'
'019f23c2192df793ac746595e94a403908749f8e0c484b403476d2611dd20970'
'SKIP'
'35d1e64efc108076acbe7392566a52c35df9ec19778eb9eb12245fc7d8b915b6'
'87d078b959c4a6e5ff9fd137c2f477cadb1245f93812512996f73986a6d973c6'
'SKIP'
'a3c87794334887b93b7a766c507244a7cdcce1d48b2e9249fc9a94f2c3beb440'
'd5ad5266462134a482b381f1f8115b6cad3473741b3bb7d1acc7f69fd0f0c0b3'
'SKIP'
'63ce10e533276ca353941ce5ab5cc8e8dcd99dbdd9c4fa49f344a212f29d36ed'
'399a7920a5278d42c46a7bf7e4191820ec2301457a7d0d4fcc9a4ac05dd53897'
'SKIP'
'8432d2dfd86044a0fc21713e0b5c1d98e1d8aad863cf67562879f47f841ac47b'
'c0a0ca32105e9881d86b7ca886220147e686edc97fdb9f3657c6659dc6568b7d'
'SKIP'
'd26239d03983fab1f34970b94d727379ca0be689f5826e50503c4d2f314f207a'
'686b2e05a151c9a4b36d5090ddc986432ad746bc6060a00928ee3b52d6b3e723'
'a1ba7fb859ac157c4b4342435cd656e29b1e1d9bddcb8ae0158a91c0a8ba6203'
'186f2d10b013395f2dd6e1fd3baf4961a2e40c403f115517c9b253682934f50f'
'6fff47ab5ede79d45fe64bb4903b7dfc27212a38e6cd5d01e60ebd24b7557359'
'10cca2f593c711b1b547f479f9f783ab88f9a64b356519d9aa1367e0ff6da73a'
'b80bda6dc26792e499b3150e13c3017be4a65280b4b9f5c9f4c07b55a46d93b6'
'597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48')
validpgpkeys=('B6C8F98282B944E3B0D5C2530FC3042E345AD05D'
'11E521D646982372EB577A1F8F0871F202119294')
@ -79,9 +74,8 @@ prepare() {
patch -Np1 -d tools/clang <../0001-GCC-compatibility-Ignore-the-fno-plt-flag.patch
patch -Np1 -d tools/clang <../0002-Enable-SSP-and-PIE-by-default.patch
# Fix LLDB input with recent libedit versions
patch -Np0 -d tools/lldb <../lldb-gcc7.patch
patch -Np1 -d tools/lldb <../lldb-libedit.patch
# https://bugs.llvm.org/show_bug.cgi?id=34123
sed -i '/LLVMSupport/d' tools/clang/tools/extra/clangd/tool/CMakeLists.txt
}
build() {

View file

@ -1,12 +0,0 @@
Index: include/lldb/Utility/TaskPool.h
===================================================================
--- include/lldb/Utility/TaskPool.h
+++ include/lldb/Utility/TaskPool.h
@@ -12,6 +12,7 @@
#include <cassert>
#include <cstdint>
+#include <functional>
#include <future>
#include <list>
#include <queue>

View file

@ -1,98 +0,0 @@
From 9ad9480c3a380a04b3dbe869c0675d6bba37247b Mon Sep 17 00:00:00 2001
From: Kamil Rytarowski <n54@gmx.com>
Date: Thu, 25 May 2017 20:12:30 +0000
Subject: [PATCH] Fix bug #28898 lldb: libedit produces garbled, unusable input
on Linux
Apply patch from Christos Zoulas, upstream libedit developer.
It has been tested on NetBSD/amd64.
New code supports combination of wide libedit and disabled
LLDB_EDITLINE_USE_WCHAR, which was the popular case on Linux
systems.
git-svn-id: https://llvm.org/svn/llvm-project/lldb/trunk@303907 91177308-0d34-0410-b5e6-96231b3b80d8
---
include/lldb/Host/Editline.h | 12 +++++++++---
source/Host/common/Editline.cpp | 8 ++++----
2 files changed, 13 insertions(+), 7 deletions(-)
diff --git a/include/lldb/Host/Editline.h b/include/lldb/Host/Editline.h
index 2b1a8e0..0b75e9c 100644
--- a/include/lldb/Host/Editline.h
+++ b/include/lldb/Host/Editline.h
@@ -82,8 +82,14 @@ using EditLineStringStreamType = std::stringstream;
using EditLineCharType = char;
#endif
+#ifdef EL_CLIENTDATA /* editline with wide support + wide char read function */
+using EditLineGetCharType = wchar_t;
+#else
+using EditLineGetCharType = char;
+#endif
+
typedef int (*EditlineGetCharCallbackType)(::EditLine *editline,
- EditLineCharType *c);
+ EditLineGetCharType *c);
typedef unsigned char (*EditlineCommandCallbackType)(::EditLine *editline,
int ch);
typedef const char *(*EditlinePromptCallbackType)(::EditLine *editline);
@@ -270,7 +276,7 @@ private:
/// Character reading implementation for EditLine that supports our multi-line
/// editing trickery.
- int GetCharacter(EditLineCharType *c);
+ int GetCharacter(EditLineGetCharType *c);
/// Prompt implementation for EditLine.
const char *Prompt();
@@ -323,7 +329,7 @@ private:
/// single or multi-line editing.
void ConfigureEditor(bool multiline);
- bool CompleteCharacter(char ch, EditLineCharType &out);
+ bool CompleteCharacter(char ch, EditLineGetCharType &out);
private:
#if LLDB_EDITLINE_USE_WCHAR
diff --git a/source/Host/common/Editline.cpp b/source/Host/common/Editline.cpp
index 7d4b398..7b580dd 100644
--- a/source/Host/common/Editline.cpp
+++ b/source/Host/common/Editline.cpp
@@ -474,7 +474,7 @@ unsigned char Editline::RecallHistory(bool earlier) {
return CC_NEWLINE;
}
-int Editline::GetCharacter(EditLineCharType *c) {
+int Editline::GetCharacter(EditLineGetCharType *c) {
const LineInfoW *info = el_wline(m_editline);
// Paint a faint version of the desired prompt over the version libedit draws
@@ -969,7 +969,7 @@ void Editline::ConfigureEditor(bool multiline) {
}));
el_wset(m_editline, EL_GETCFN, (EditlineGetCharCallbackType)([](
- EditLine *editline, EditLineCharType *c) {
+ EditLine *editline, EditLineGetCharType *c) {
return Editline::InstanceFor(editline)->GetCharacter(c);
}));
@@ -1360,12 +1360,12 @@ void Editline::PrintAsync(Stream *stream, const char *s, size_t len) {
}
}
-bool Editline::CompleteCharacter(char ch, EditLineCharType &out) {
+bool Editline::CompleteCharacter(char ch, EditLineGetCharType &out) {
#if !LLDB_EDITLINE_USE_WCHAR
if (ch == (char)EOF)
return false;
- out = ch;
+ out = (unsigned char)ch;
return true;
#else
std::codecvt_utf8<wchar_t> cvt;
--
2.13.0