diff --git a/core/linux-rpi/PKGBUILD b/core/linux-rpi/PKGBUILD
index 848729e99..38dfe8021 100644
--- a/core/linux-rpi/PKGBUILD
+++ b/core/linux-rpi/PKGBUILD
@@ -7,11 +7,11 @@
 buildarch=12
 
 pkgbase=linux-rpi
-_commit=606d1fc3bc97a8be1d21e143ca88f3ba085ddef1
+_commit=d261fd9f97da8b6b3ed1fa613cc3fd6abb41f0be
 _srcname=linux-${_commit}
 _kernelname=${pkgbase#linux}
 pkgver=5.10.88
-pkgrel=1
+pkgrel=2
 pkgdesc='Linux'
 url="http://www.kernel.org/"
 arch=(armv7h aarch64)
@@ -25,13 +25,15 @@ source_aarch64=('config8' 'config8.txt')
 source=("linux-$pkgver-$pkgrel-${_commit:0:10}.tar.gz::https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
         cmdline.txt
         0001-Make-proc-cpuinfo-consistent-on-arm64-and-arm.patch
+        0002-revert-gamma.patch::https://gitlab.manjaro.org/manjaro-arm/packages/core/linux-rpi4/-/raw/master/revert-gamma.diff?inline=false
         linux.preset
         60-linux.hook
         90-linux.hook
 )
-md5sums=('4b5442039b1f8faecaedcd9bdcdffbd9'
+md5sums=('2b83b925d6e066f27793613840217867'
          '31c02f4518d46deb5f0c2ad1f8b083cd'
          'f66a7ea3feb708d398ef57e4da4815e9'
+         'e15bac8034085a38ecd4a57584caa819'
          '86d4a35722b5410e3b29fc92dae15d4b'
          '0a5f16bfec6ad982a2f6782724cca8ba'
          '441ec084c47cddc53e592fb0cbce4edf')
@@ -53,6 +55,10 @@ prepare() {
   # consistent behavior of lscpu on arm/arm64
   patch -Np1 -i ../0001-Make-proc-cpuinfo-consistent-on-arm64-and-arm.patch
 
+  # temp fix for https://github.com/raspberrypi/linux/issues/4660
+  # also https://archlinuxarm.org/forum/viewtopic.php?f=65&t=15629
+  patch -Np1 -i ../0002-revert-gamma.patch
+
   echo "Setting version..."
   scripts/setlocalversion --save-scmversion
   echo "-$pkgrel" > localversion.10-pkgrel