community/synergy: update system-cryptopp.patch

This commit is contained in:
Kevin Mihelich 2013-10-18 23:54:17 +00:00
parent b706ce1391
commit 24d6585ab4
2 changed files with 61 additions and 99 deletions

View file

@ -22,7 +22,7 @@ source=("http://synergy.googlecode.com/files/$pkgname-$pkgver-Source.tar.gz"
"synergys.socket"
"synergys.service")
sha512sums=('3e9ca96f36573e400c9694daba026322cbf36bbabdbf69687cbadb6010834d1afd81845533775564ba7aadbf3a8be8582d9e5b9d33abfa483a174b40e084add4'
'1a95d4b704ab4d54a7a9ec64eef3551752432c73540d94b69e2799fe615c5a4c61dc026bf40706030da0e649afa6b8ff3b8c26da245bb7e44846907f308566f1'
'6fc79d78c24daaafd7e50c31581788d48fb1591105644a55584282c55c4cdee10e4f374216fecd7253030e692d358165ef349caab1675ed1d1d1f101fb46b8c0'
'f7d918faf4a25654786f270fc48b6e4089ecd1b2f504bb90de543b47a862733f7be067e06fd613d621bba48d20dc63214966e2cfbd2cb3fcbfe623d6d41f10ad'
'a10dfe5b24ac6f4a2ef3a3a9f8a6a3c432b91d5e59d1fae2258d37c5be00ac8f172656fa0d213012c7dc94ab8c04c3945ae33acfcd5db5fad8b37ccc9f5e980f')

View file

@ -1,15 +1,6 @@
Description: Use system libcrypto++ if available
Rather than always use the included libcrypto++ zipped source, check
for and use the system's libcrypto++.
Author: Jeff Licquia <licquia@debian.org>
Forwarded: no
Last-Update: 2013-06-01
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
Index: synergy-1.4.12/CMakeLists.txt
===================================================================
--- synergy-1.4.12.orig/CMakeLists.txt 2013-06-02 02:22:35.000000000 +0000
+++ synergy-1.4.12/CMakeLists.txt 2013-06-02 02:22:35.000000000 +0000
diff -urN a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt 2013-10-08 04:19:02.000000000 -0600
+++ b/CMakeLists.txt 2013-10-18 17:46:11.290667774 -0600
@@ -75,6 +75,7 @@
include(CheckIncludeFileCXX)
include(CheckSymbolExists)
@ -19,10 +10,10 @@ Index: synergy-1.4.12/CMakeLists.txt
check_include_file_cxx(istream HAVE_ISTREAM)
check_include_file_cxx(ostream HAVE_OSTREAM)
@@ -204,6 +205,8 @@
check_library_exists("Xi" XISelectEvents "" HAVE_Xi)
check_library_exists("Xrandr" XRRQueryExtension "" HAVE_Xrandr)
check_library_exists("Xi" XISelectEvents "" HAVE_Xi)
check_library_exists("Xrandr" XRRQueryExtension "" HAVE_Xrandr)
+ pkg_search_module(CRYPTOPP libcrypto++)
+ pkg_search_module(CRYPTOPP libcrypto++)
+
if (HAVE_ICE)
@ -31,84 +22,16 @@ Index: synergy-1.4.12/CMakeLists.txt
list(APPEND libs Xrandr)
endif()
+ if (HAVE_CRYPTOPP)
+ list(APPEND libs CRYPTOPP_LIBRARIES)
+ endif()
+ if (HAVE_CRYPTOPP)
+ list(APPEND libs CRYPTOPP_LIBRARIES)
+ endif()
+
endif()
IF(HAVE_Xi)
Index: synergy-1.4.12/tools/CMakeLists.txt
===================================================================
--- synergy-1.4.12.orig/tools/CMakeLists.txt 2013-06-02 02:22:35.000000000 +0000
+++ synergy-1.4.12/tools/CMakeLists.txt 2013-06-02 02:25:44.000000000 +0000
@@ -13,7 +13,7 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-set(cpp_dir cryptopp562)
+set(cpp_dir cryptopp)
file(GLOB cpp_src ${cpp_dir}/*.cpp)
@@ -22,14 +22,16 @@
list(APPEND cpp_src ${cpp_hdr})
endif()
-file(GLOB cpp_ignore
- ${cpp_dir}/simple.cpp
- ${cpp_dir}/strciphr.cpp
- ${cpp_dir}/polynomi.cpp
- ${cpp_dir}/eprecomp.cpp
- ${cpp_dir}/eccrypto.cpp
- ${cpp_dir}/algebra.cpp)
-list(REMOVE_ITEM cpp_src ${cpp_ignore})
+if (NOT CRYPTOPP_FOUND)
+ file(GLOB cpp_ignore
+ ${cpp_dir}/simple.cpp
+ ${cpp_dir}/strciphr.cpp
+ ${cpp_dir}/polynomi.cpp
+ ${cpp_dir}/eprecomp.cpp
+ ${cpp_dir}/eccrypto.cpp
+ ${cpp_dir}/algebra.cpp)
+ list(REMOVE_ITEM cpp_src ${cpp_ignore})
+endif()
# if 64-bit windows, compile asm file.
if (CMAKE_CL_64)
@@ -49,16 +51,20 @@
endif()
if (UNIX)
- add_definitions(-DCRYPTOPP_DISABLE_ASM)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -pipe")
+ if (NOT CRYPTOPP_FOUND)
+ add_definitions(-DCRYPTOPP_DISABLE_ASM)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -pipe")
- if (APPLE)
- if (DARWIN_VERSION GREATER 10)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-tautological-compare")
+ if (APPLE)
+ if (DARWIN_VERSION GREATER 10)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-tautological-compare")
+ endif()
+ else()
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=native")
endif()
- else()
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=native")
endif()
endif()
-add_library(cryptopp STATIC ${cpp_src})
+if (NOT CRYPTOPP_FOUND)
+ add_library(cryptopp STATIC ${cpp_src})
+endif()
Index: synergy-1.4.12/src/lib/synergy/CCryptoMode.h
===================================================================
--- synergy-1.4.12.orig/src/lib/synergy/CCryptoMode.h 2013-06-02 02:22:35.000000000 +0000
+++ synergy-1.4.12/src/lib/synergy/CCryptoMode.h 2013-06-02 02:22:35.000000000 +0000
diff -urN a/src/lib/io/CCryptoMode.h b/src/lib/io/CCryptoMode.h
--- a/src/lib/io/CCryptoMode.h 2013-05-30 07:48:08.000000000 -0600
+++ b/src/lib/io/CCryptoMode.h 2013-10-18 17:48:48.300057303 -0600
@@ -17,9 +17,9 @@
#pragma once
@ -122,10 +45,9 @@ Index: synergy-1.4.12/src/lib/synergy/CCryptoMode.h
#include "ECryptoMode.h"
#include "CString.h"
Index: synergy-1.4.12/src/lib/synergy/CCryptoStream.h
===================================================================
--- synergy-1.4.12.orig/src/lib/synergy/CCryptoStream.h 2013-06-02 02:22:35.000000000 +0000
+++ synergy-1.4.12/src/lib/synergy/CCryptoStream.h 2013-06-02 02:22:35.000000000 +0000
diff -urN a/src/lib/io/CCryptoStream.h b/src/lib/io/CCryptoStream.h
--- a/src/lib/io/CCryptoStream.h 2013-06-29 08:17:49.000000000 -0600
+++ b/src/lib/io/CCryptoStream.h 2013-10-18 17:49:02.250003064 -0600
@@ -20,8 +20,8 @@
#include "BasicTypes.h"
#include "CStreamFilter.h"
@ -137,11 +59,10 @@ Index: synergy-1.4.12/src/lib/synergy/CCryptoStream.h
class CCryptoOptions;
Index: synergy-1.4.12/tools/build/toolchain.py
===================================================================
--- synergy-1.4.12.orig/tools/build/toolchain.py 2013-06-01 22:55:47.000000000 +0000
+++ synergy-1.4.12/tools/build/toolchain.py 2013-06-02 02:25:00.000000000 +0000
@@ -73,7 +73,7 @@
diff -urN a/tools/build/toolchain.py b/tools/build/toolchain.py
--- a/tools/build/toolchain.py 2013-08-02 07:21:06.000000000 -0600
+++ b/tools/build/toolchain.py 2013-10-18 17:49:32.674884769 -0600
@@ -67,7 +67,7 @@
macSdk = None
# cryptoPP dir with version number
@ -150,3 +71,44 @@ Index: synergy-1.4.12/tools/build/toolchain.py
win32_generators = {
1 : Generator('Visual Studio 10'),
diff -urN a/tools/CMakeLists.txt b/tools/CMakeLists.txt
--- a/tools/CMakeLists.txt 2013-06-04 12:22:58.000000000 -0600
+++ b/tools/CMakeLists.txt 2013-10-18 17:48:12.140197897 -0600
@@ -13,7 +13,7 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-set(cryptopp_dir cryptopp562)
+set(cryptopp_dir cryptopp)
# only compile the crypto++ files we need.
set(cryptopp_src
@@ -72,16 +72,20 @@
endif()
if (UNIX)
- add_definitions(-DCRYPTOPP_DISABLE_ASM)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -pipe")
+ if (NOT CRYPTOPP_FOUND)
+ add_definitions(-DCRYPTOPP_DISABLE_ASM)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -pipe")
- if (APPLE)
- if (DARWIN_VERSION GREATER 10)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-tautological-compare")
+ if (APPLE)
+ if (DARWIN_VERSION GREATER 10)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-tautological-compare")
+ endif()
+ else()
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=native")
endif()
- else()
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=native")
endif()
endif()
-add_library(cryptopp STATIC ${cryptopp_src})
+if (NOT CRYPTOPP_FOUND)
+ add_library(cryptopp STATIC ${cpp_src})
+endif()