mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/wt to 3.3.6-6
This commit is contained in:
parent
4a7335bc71
commit
24f8aa8f61
2 changed files with 21 additions and 3 deletions
|
@ -9,7 +9,7 @@
|
|||
pkgname=wt
|
||||
pkgver=3.3.6
|
||||
_pkgver=3.3.6
|
||||
pkgrel=5
|
||||
pkgrel=6
|
||||
pkgdesc="a C++ library and application server for developing and deploying web applications"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.webtoolkit.eu/"
|
||||
|
@ -23,8 +23,15 @@ optdepends=('openssl: for SSL support in built-in webserver'
|
|||
'mysql++: for the hangman example'
|
||||
'qt4: for the Wt/Qt interopability example (wtwithqt)')
|
||||
backup=('etc/wt/wt_config.xml')
|
||||
source=(https://github.com/kdeforche/wt/archive/${_pkgver}.tar.gz)
|
||||
md5sums=('a5be5f7efa93c4eae7f1d8812ff78c70')
|
||||
source=(https://github.com/kdeforche/wt/archive/${_pkgver}.tar.gz wt-boost-1.63.patch)
|
||||
md5sums=('a5be5f7efa93c4eae7f1d8812ff78c70'
|
||||
'87a0c637d7014e764892686891393d6b')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$_pkgver
|
||||
# Fix build with boost 1.63 https://github.com/emweb/wt/pull/102
|
||||
patch -p0 -i ../wt-boost-1.63.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir"/${pkgname}-${_pkgver}
|
||||
|
|
11
community/wt/wt-boost-1.63.patch
Normal file
11
community/wt/wt-boost-1.63.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/Wt/Render/CssParser.C.orig 2016-07-13 12:27:26 UTC
|
||||
+++ src/Wt/Render/CssParser.C
|
||||
@@ -372,7 +372,7 @@ CssGrammer<Iterator>::CssGrammer()
|
||||
on_error<qi::fail>
|
||||
(
|
||||
rulesetArray_,
|
||||
- error_report(qi::_2, qi::_3, qi::_4, "styleSheetText()", fs_error_tag())
|
||||
+ error_report(qi::_2, qi::_3, qi::_4, phoenix::val("styleSheetText()"), fs_error_tag())
|
||||
);
|
||||
|
||||
}
|
Loading…
Reference in a new issue