mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
core/linux-armv7 to 4.10.9-1
This commit is contained in:
parent
96a9cfa6a3
commit
250f17bfe0
11 changed files with 42 additions and 69 deletions
|
@ -1,7 +1,7 @@
|
|||
From 2a2ab2b8ed60e043da32ddac674d7c58a63c1c8f Mon Sep 17 00:00:00 2001
|
||||
From 917b58ee1f0fe801d59103e3bb8eb147f256c2f5 Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:59:28 +0100
|
||||
Subject: [PATCH 01/10] ARM: atags: add support for Marvell's u-boot
|
||||
Subject: [PATCH 1/9] ARM: atags: add support for Marvell's u-boot
|
||||
|
||||
Marvell uses a specific atag in its u-boot which includes among other
|
||||
information the MAC addresses for up to 4 network interfaces.
|
||||
|
@ -47,5 +47,5 @@ index 979ff4016404..d1d0c1950fa4 100644
|
|||
};
|
||||
|
||||
--
|
||||
2.11.1
|
||||
2.12.1
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
From 2890deaac9ce485f0b20211872784b0071d82717 Mon Sep 17 00:00:00 2001
|
||||
From 8f2e8ce8901c2da8c69ba68a472e2091be3bb512 Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:56:58 +0100
|
||||
Subject: [PATCH 02/10] ARM: atags/fdt: retrieve MAC addresses from Marvell
|
||||
boot loader
|
||||
Subject: [PATCH 2/9] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
||||
loader
|
||||
|
||||
The atags are parsed and if a Marvell atag is found, up to 4 MAC
|
||||
addresses are extracted there and assigned to node aliases eth0..3
|
||||
|
@ -43,5 +43,5 @@ index 9448aa0c6686..ac7b6ae6c00f 100644
|
|||
}
|
||||
|
||||
--
|
||||
2.11.1
|
||||
2.12.1
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From fcd4be4707777620a01f1b1097fdb8f93e4c1077 Mon Sep 17 00:00:00 2001
|
||||
From 4905eee60c7a744fb9b15ec357dccd01d0caaba9 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:41:19 -0600
|
||||
Subject: [PATCH 03/10] SMILE Plug device tree file
|
||||
Subject: [PATCH 3/9] SMILE Plug device tree file
|
||||
|
||||
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
|
||||
dts with the LED definitions.
|
||||
|
@ -205,5 +205,5 @@ index 000000000000..d01308ab848b
|
|||
+ };
|
||||
+};
|
||||
--
|
||||
2.11.1
|
||||
2.12.1
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 14c522e0476341f7684cef8b1ad0c03a3e4509e6 Mon Sep 17 00:00:00 2001
|
||||
From 0188343b28b4019a7502ca492f55fb2e7f9eb6f2 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:43:56 -0600
|
||||
Subject: [PATCH 04/10] fix mvsdio eMMC timing
|
||||
Subject: [PATCH 4/9] fix mvsdio eMMC timing
|
||||
|
||||
These changes from Globalscale change the MMC timing to allow the eMMC versions
|
||||
of the Mirabox and SMILE Plug to work.
|
||||
|
@ -34,5 +34,5 @@ index 42296e55b9de..e5ce6d27ec82 100644
|
|||
host->clock = ios->clock;
|
||||
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
||||
--
|
||||
2.11.1
|
||||
2.12.1
|
||||
|
||||
|
|
|
@ -1,8 +1,7 @@
|
|||
From 92ba4f4447bc5ed008f449e2d44ed339df3f4d0f Mon Sep 17 00:00:00 2001
|
||||
From d24fd01bc56e4dccfb16826da9cf53e92efc24f7 Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 05/10] net/smsc95xx: Allow mac address to be set as a
|
||||
parameter
|
||||
Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
|
@ -92,5 +91,5 @@ index 831aa33d078a..03625547d794 100644
|
|||
|
||||
/* maybe the boot loader passed the MAC address in devicetree */
|
||||
--
|
||||
2.11.1
|
||||
2.12.1
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 73eeb8c53d5402e318c7414ca89197faacc82a7d Mon Sep 17 00:00:00 2001
|
||||
From e2ee2a2f50947c4bdc4c9d827bd8ae0c383a7549 Mon Sep 17 00:00:00 2001
|
||||
From: dobatog <dobatog@gmail.com>
|
||||
Date: Thu, 26 Feb 2015 12:32:27 +0100
|
||||
Subject: [PATCH 06/10] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
|
||||
Subject: [PATCH 6/9] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
|
||||
related to input routing signals.
|
||||
|
||||
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
|
||||
|
@ -45,5 +45,5 @@ index 410cae0f2060..0bb8e2602d8e 100644
|
|||
/* input mux */
|
||||
{"Capture Source", "Line", "Line Input"},
|
||||
--
|
||||
2.11.1
|
||||
2.12.1
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From ab716cec125455302c0e09ce6709033933b618df Mon Sep 17 00:00:00 2001
|
||||
From 18e61c475bb02949da35cf579737a8bec90ffc64 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 14 Feb 2015 12:32:27 +0100
|
||||
Subject: [PATCH 07/10] set default cubietruck led triggers
|
||||
Subject: [PATCH 7/9] set default cubietruck led triggers
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
@ -29,5 +29,5 @@ index 83f39b0362cb..15e9626ea81b 100644
|
|||
};
|
||||
|
||||
--
|
||||
2.11.1
|
||||
2.12.1
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 357aaf663585092fc717d6bb8397b6ef8764a660 Mon Sep 17 00:00:00 2001
|
||||
From d1adb6eb7ec4898bbca97f7dc4ffdb2f6fdc9b99 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 11 Aug 2016 00:42:37 -0600
|
||||
Subject: [PATCH 08/10] exynos4412-odroid: set higher minimum buck2 regulator
|
||||
Subject: [PATCH 8/9] exynos4412-odroid: set higher minimum buck2 regulator
|
||||
voltage
|
||||
|
||||
Set a higher minimum voltage to help reboot issue.
|
||||
|
@ -26,5 +26,5 @@ index 8aa19ba14436..8e2d94e3af72 100644
|
|||
regulator-always-on;
|
||||
regulator-boot-on;
|
||||
--
|
||||
2.11.1
|
||||
2.12.1
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 891345676e0af18d5d809b8a810db56a363aaf3b Mon Sep 17 00:00:00 2001
|
||||
From 7cc217a4e96f65ef0156b590f9fad5da4958f846 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 25 Feb 2017 19:39:51 -0700
|
||||
Subject: [PATCH 10/10] disable USB3 port on ODROID-XU
|
||||
Subject: [PATCH 9/9] disable USB3 port on ODROID-XU
|
||||
|
||||
Ports report over-current condition and are non-operable.
|
||||
|
||||
|
@ -23,5 +23,5 @@ index c4de1353e5df..f80fa58995c5 100644
|
|||
|
||||
&usbdrd_dwc3_1 {
|
||||
--
|
||||
2.11.1
|
||||
2.12.1
|
||||
|
|
@ -1,23 +0,0 @@
|
|||
From a5f7ae6a9dc41c26bcc0d4e66f18c352435ba4eb Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 26 Dec 2016 12:56:09 -0700
|
||||
Subject: [PATCH 09/10] drm/armada tracing fix
|
||||
|
||||
https://lists.freedesktop.org/archives/dri-devel/2016-December/126212.html
|
||||
---
|
||||
drivers/gpu/drm/armada/Makefile | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/drivers/gpu/drm/armada/Makefile b/drivers/gpu/drm/armada/Makefile
|
||||
index a18f156c8b66..64c0b4546fb2 100644
|
||||
--- a/drivers/gpu/drm/armada/Makefile
|
||||
+++ b/drivers/gpu/drm/armada/Makefile
|
||||
@@ -4,3 +4,5 @@ armada-y += armada_510.o
|
||||
armada-$(CONFIG_DEBUG_FS) += armada_debugfs.o
|
||||
|
||||
obj-$(CONFIG_DRM_ARMADA) := armada.o
|
||||
+
|
||||
+CFLAGS_armada_trace.o := -I$(src)
|
||||
--
|
||||
2.11.1
|
||||
|
|
@ -7,7 +7,7 @@ pkgbase=linux-armv7
|
|||
_srcname=linux-4.10
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="ARMv7 multi-platform"
|
||||
pkgver=4.10.8
|
||||
pkgver=4.10.9
|
||||
pkgrel=1
|
||||
rcnrel=armv7-x1
|
||||
arch=('armv7h')
|
||||
|
@ -26,8 +26,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
|||
'0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch'
|
||||
'0007-set-default-cubietruck-led-triggers.patch'
|
||||
'0008-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch'
|
||||
'0009-drm-armada-tracing-fix.patch'
|
||||
'0010-disable-USB3-port-on-ODROID-XU.patch'
|
||||
'0009-disable-USB3-port-on-ODROID-XU.patch'
|
||||
'config'
|
||||
'kernel.its'
|
||||
'kernel.keyblock'
|
||||
|
@ -35,18 +34,17 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
|||
'linux.preset'
|
||||
'99-linux.hook')
|
||||
md5sums=('b5e7f6b9b2fe1b6cc7bc56a3a0bfc090'
|
||||
'feaec4930aacd966b70c234ce43178c9'
|
||||
'bab8688dba139aad363bae621e559f33'
|
||||
'88ad590a43ebe285c4df6a1c5c298b97'
|
||||
'56e0bd2354406b132cf904c3877506c5'
|
||||
'34a723ffcbef63e9461193061b4461a1'
|
||||
'28bf88b2ad58937d00d2240690e59973'
|
||||
'23fe69ef9a0e3e016eea4529e0db4268'
|
||||
'1204a4c65fe53025bb02042e7ee105cb'
|
||||
'5c0086e99dcc1e84d70d6809d452c52c'
|
||||
'2a92aab5348329756f65933f919bb9ef'
|
||||
'0429d0ffa8ccda0d69ac69dcf7cc49f1'
|
||||
'a6b0eb95998ae11416186728e855c289'
|
||||
'6510be217adcabee724f5b0f00eb7e60'
|
||||
'50523d4cc4235e654e63a81fa2137801'
|
||||
'a34bb1acbb7aa9cd6c485f7552d6c079'
|
||||
'4bff9dfa64302cfe823ac9e8e705f52d'
|
||||
'533c823f8f34acbc510f0f1489780cd0'
|
||||
'93f0ccbd9e80b3ab4804e87364ea9c50'
|
||||
'c99613057280d24911373a6d45bf6421'
|
||||
'7fe3fa1a14b8cf191d648f5e2413baf5'
|
||||
'4a773f2a5d4d271a3dffacbed36ba46d'
|
||||
'352d9956b94696eda4a73d2841da524b'
|
||||
'b5466a24782fbe8b534886cc8ac9aefd'
|
||||
'81fd6c631e3868267ad7d577455606ec'
|
||||
'4f2379ed84258050edb858ee8d281678'
|
||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||
|
@ -72,8 +70,7 @@ prepare() {
|
|||
git apply ../0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch
|
||||
git apply ../0007-set-default-cubietruck-led-triggers.patch
|
||||
git apply ../0008-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
|
||||
git apply ../0009-drm-armada-tracing-fix.patch
|
||||
git apply ../0010-disable-USB3-port-on-ODROID-XU.patch
|
||||
git apply ../0009-disable-USB3-port-on-ODROID-XU.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
|
|
Loading…
Reference in a new issue