extra/libreoffice-still to 7.4.6-1

This commit is contained in:
Kevin Mihelich 2023-03-10 00:02:24 +00:00
parent 7a0b246e0f
commit 25223f24c4
2 changed files with 5 additions and 31 deletions

View file

@ -1,21 +0,0 @@
From 623ea5c4d2871aba2e3e5114ad7d58d6f910a2f3 Mon Sep 17 00:00:00 2001
From: Caolán McNamara <caolanm@redhat.com>
Date: Thu, 12 Jan 2023 20:55:27 +0000
Subject: [PATCH] Related: tdf#151898 fix gtk4 build in 7-4
Change-Id: I71b59b7d2eac406817c79bf6911736ad4510771c
---
diff --git a/vcl/unx/gtk3/gtkinst.cxx b/vcl/unx/gtk3/gtkinst.cxx
index 8ba6409..b697b0b 100644
--- a/vcl/unx/gtk3/gtkinst.cxx
+++ b/vcl/unx/gtk3/gtkinst.cxx
@@ -5114,7 +5114,7 @@
void picture_set_from_xgraphic(GtkPicture* pPicture, const css::uno::Reference<css::graphic::XGraphic>& rPicture)
{
- if (auto xTempFile = getImageFile(rPicture, false))
+ if (auto xTempFile = getImageFile(rPicture))
gtk_picture_set_filename(pPicture, OUStringToOString(xTempFile->GetFileName(), osl_getThreadTextEncoding()).getStr());
else
gtk_picture_set_pixbuf(pPicture, nullptr);

View file

@ -17,8 +17,8 @@ _google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
pkgbase=libreoffice-still
pkgname=('libreoffice-still-sdk' 'libreoffice-still')
_LOver=7.4.5.1
pkgver=7.4.5
_LOver=7.4.6.2
pkgver=7.4.6
pkgrel=1
arch=('x86_64')
license=('LGPL3')
@ -68,7 +68,6 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
libreoffice-boost-1.81.0-locale.patch::https://github.com/LibreOffice/core/commit/23dcd4339428.patch
make-pyuno-work-with-system-wide-module-install.diff
0001_Remove_dependency_on_BitArray.h_from_zxing-1.2.0.patch
623ea5c.diff
soffice-template.desktop.in
libreoffice-still.sh libreoffice-still.csh)
noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
@ -91,11 +90,11 @@ noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
185d60944ea767075d27247c3162b3bc-unowinreg.dll
)
validpgpkeys=('C2839ECAD9408FBE9531C3E9F434A1EFAFEEAEA3') # LibreOffice Build Team (CODE SIGNING KEY) <build@documentfoundation.org>
sha256sums=('380ecf12cb37b94a2f5f210d277fc2d1e14b9f14d1d39e09d49135194e6ce18d'
sha256sums=('1873ae8986f0c3f0d22bf0e94aa01a07f8e0a6929a72319260838fa869e62093'
'SKIP'
'9e6badb999b686fd511db529b85f5e3e31ad991bffa06fb243e4685956bce681'
'a34267c9b86630566171b4eb59196527e27dfad7146c52dc6dfb729a01024fd1'
'SKIP'
'59180fccb1b2c1f408eae15104d84f6761b59e186259af166da098a765d100b9'
'112e2bf4f93b0d87854cf83c88f5d03fce12a469fac7c1b5d0f7ecd564158b13'
'SKIP'
'a49a58e8070ec111cc40efc9cdab32e8a1894d6a7788319306ccc461128e87c0'
'1fb458d6aab06932693cc8a9b6e4e70944ee1ff052fa63606e3131df34e21753'
@ -119,7 +118,6 @@ sha256sums=('380ecf12cb37b94a2f5f210d277fc2d1e14b9f14d1d39e09d49135194e6ce18d'
'9754c1c9025dd34b010b3e9c9c39ef2f850331e486b5d0adbf5c86f554259b04'
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
'fa0073dee8fc0519b84ed6af6fa9769b88abb24e694c314344c4606478101547'
'440c9af5f3d1213d8ed7177282380f25cbc981cabc8b590dcb777aaae84178e5'
'd0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879'
'cd1b25ff390e436c6bffa65c6e12382236e3ccbf8d3aae51b1b59bcaed79fd8a'
'b43ed267643fc5ced803dca010427b12b1f10db485173ccb19efb3395e60c82e'
@ -150,9 +148,6 @@ prepare() {
# allow build with recent syytem xzing
patch -Np1 -i "${srcdir}"/0001_Remove_dependency_on_BitArray.h_from_zxing-1.2.0.patch
# fix build - https://gerrit.libreoffice.org/c/core/+/145421
patch -Np1 -i "${srcdir}"/623ea5c.diff
#use the CFLAGS but remove the LibO overridden ones
for i in $CFLAGS; do
case "$i" in