community/fbreader: fix

This commit is contained in:
Kevin Mihelich 2019-05-01 13:48:08 +00:00
parent b2f40b14fc
commit 263f5580ea
2 changed files with 3 additions and 28 deletions

View file

@ -1,8 +1,7 @@
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: William Rea <sillywilly@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to cast qReal's to double's to work with ARM
# remove when bumped upstream
pkgname=fbreader
pkgver=0.99.4
@ -14,13 +13,11 @@ license=('GPL')
depends=('fribidi' 'bzip2' 'curl' 'qt5-base' 'libunibreak' 'sqlite')
source=(http://www.fbreader.org/files/desktop/fbreader-sources-$pkgver.tgz
"fbreader-0.99.4.patch::https://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-text/fbreader/files/fbreader-0.99.4.patch?revision=1.1"
fbreader-gcc6.patch fbreader-qt5.patch
arm.patch)
fbreader-gcc6.patch fbreader-qt5.patch)
sha256sums=('3d7c31d5ea314589d2a963290ad16f4d3d631a41e802b8b39f8be0c9f71eb8e9'
'cb3aa6795c8f7c694ba296f6f6e6a7939648578a289bc84c10f8302c7e72df86'
'bc67b538c51a5b77468469df6b5e96ce918ee11a5ff4e88e398ad5661d322f9c'
'9d00f95f2a026b7bdafa6ab8519659cd2c293f1b9b00681a62d3f4992399e716'
'10ac99e349344b7b0c882d5c6cf50c535321b529d59935d890596ba00349cc25')
'9d00f95f2a026b7bdafa6ab8519659cd2c293f1b9b00681a62d3f4992399e716')
prepare() {
cd "$srcdir"/fbreader-$pkgver
@ -28,7 +25,6 @@ prepare() {
patch -p0 -i ../fbreader-gcc6.patch # Fix build with GCC6 (Gentoo)
patch -p1 -i ../fbreader-qt5.patch # Port to Qt5 (Gentoo)
patch -p1 -i ../arm.patch
# Use system FLAGS
sed -e "s/^CFLAGS = -pipe/CFLAGS +=/" -i makefiles/arch/desktop.mk

View file

@ -1,21 +0,0 @@
diff -urN a/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp b/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp
--- a/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp 2012-11-30 05:41:25.000000000 -0700
+++ b/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp 2013-04-21 10:17:23.402543440 -0600
@@ -86,7 +86,7 @@
}
void QtWaitingSpinner::setRoundness(qreal roundness) {
- myRoundness = std::max(0.0, std::min(100.0, roundness));
+ myRoundness = std::max(0.0, std::min(100.0, (double)roundness));
}
void QtWaitingSpinner::setColor(QColor color) {
@@ -148,7 +148,7 @@
qreal alphaDiff = color.alphaF() - (qreal)minAlphaF;
qreal gradation = alphaDiff / (qreal)(distanceThreshold + 1);
qreal resultAlpha = color.alphaF() - gradation * distance;
- resultAlpha = std::min(1.0, std::max(0.0, resultAlpha)); //if alpha is out of bound, force it to bounds
+ resultAlpha = std::min(1.0, std::max(0.0, (double)resultAlpha)); //if alpha is out of bound, force it to bounds
color.setAlphaF(resultAlpha);
return color;
}