mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
community/mgba to 0.6.0-1
This commit is contained in:
parent
b6ac3130a1
commit
26819e3673
2 changed files with 4 additions and 21 deletions
|
@ -9,23 +9,18 @@
|
|||
|
||||
pkgbase=mgba
|
||||
pkgname=('libmgba' 'mgba-sdl' 'mgba-qt')
|
||||
pkgver=0.5.2
|
||||
pkgrel=4
|
||||
pkgver=0.6.0
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://mgba.io'
|
||||
license=('custom:MPL2')
|
||||
makedepends=('cmake' 'qt5-multimedia' 'sdl2' 'zlib' 'libpng' 'libzip' 'libedit'
|
||||
'ffmpeg' 'imagemagick' 'desktop-file-utils' 'qt5-tools')
|
||||
source=($pkgbase-$pkgver.tar.gz::https://github.com/mgba-emu/mgba/archive/$pkgver.tar.gz
|
||||
mgba-gcc7.patch)
|
||||
md5sums=('c3d20052503dca08e58030ac4e3f0408'
|
||||
'ea583f6af8cdbfed8f83f16311b9c788')
|
||||
source=($pkgbase-$pkgver.tar.gz::https://github.com/mgba-emu/mgba/archive/$pkgver.tar.gz)
|
||||
md5sums=('cdad6be9a3a01afc5d2e9b53f0321a68')
|
||||
|
||||
prepare() {
|
||||
[[ ! -d build ]] && mkdir build || rm -rf build
|
||||
|
||||
cd $pkgbase-$pkgver
|
||||
patch -p1 -i ../mgba-gcc7.patch # Fix build with GCC7
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
diff --git a/src/platform/qt/GameController.h b/src/platform/qt/GameController.h
|
||||
index 79b18d3bf..7b8d6908b 100644
|
||||
--- a/src/platform/qt/GameController.h
|
||||
+++ b/src/platform/qt/GameController.h
|
||||
@@ -14,6 +14,7 @@
|
||||
#include <QTimer>
|
||||
|
||||
#include <memory>
|
||||
+#include <functional>
|
||||
|
||||
#include <mgba/core/core.h>
|
||||
#include <mgba/core/thread.h>
|
Loading…
Reference in a new issue