extra/firefox to 44.0

This commit is contained in:
Jason Plum 2016-01-26 13:23:00 -05:00
parent 2b8330a2d2
commit 26896d7d79
4 changed files with 5 additions and 85 deletions

View file

@ -10,7 +10,7 @@
highmem=1
pkgname=firefox
pkgver=43.0.4
pkgver=44.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=('i686' 'x86_64')
@ -20,11 +20,9 @@ depends=('gtk3' 'gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-typ
'dbus-glib' 'alsa-lib' 'desktop-file-utils' 'hicolor-icon-theme'
'libvpx' 'icu' 'libevent' 'nss' 'hunspell' 'sqlite' 'ttf-font')
makedepends=('unzip' 'zip' 'diffutils' 'python2' 'yasm' 'mesa' 'imake' 'gconf'
'xorg-server-xvfb' 'libpulse' 'inetutils' 'gst-plugins-base-libs')
'xorg-server-xvfb' 'libpulse' 'inetutils')
optdepends=('networkmanager: Location detection via available WiFi networks'
'ffmpeg: H264/AAC decoding'
'gst-plugins-good: MP3 playback'
'gst-plugins-ugly: MP3 playback'
'upower: Battery API')
install=firefox.install
options=('!emptydirs' '!makeflags')
@ -33,18 +31,14 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/
firefox.desktop
firefox-install-dir.patch
vendor.js
firefox-disable-GMP-PDM.patch
firefox-support-YUV420J-pixel-format.patch
firefox-fixed-loading-icon.png
no-neon.patch
189d4b0f9f23.patch::https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/raw-rev/189d4b0f9f23)
sha256sums=('76cfa99285d49dede4097096ab3e7ee4bdedb64084b1fc23f2de216884245a76'
'968c91780ce92fa27ae443df29ebb7440c26ee89ea3439a5e4ae5fd0ca3fab12'
sha256sums=('ea82b0f4840d320aa4fe8046ba28e686bf6dc60f707a0514a9d68c150d0c4c1d'
'9011ffcd6eb2868d0363c216d0b28faf64bb746e8de200726a6ca7013a99106e'
'c202e5e18da1eeddd2e1d81cb3436813f11e44585ca7357c4c5f1bddd4bec826'
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
'4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4'
'fb1f631363c9b50c8246a0d8738c40570717b3e15b5457dacad9f447449d7e92'
'4a949e5b4281be4df0bece8087ecad0a3debb4828efc6a587bd3bd931ab70c94'
'68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213'
'6d0c1c9ca28b20d206ce24ca84f4d4e3f5d062a2e9cb7445fcb6c2cfea959b4a'
'cbd14ac4839062f4437d1db7cfd5fb9aaadb6786dc63612b219106e01000aafd')
@ -69,12 +63,6 @@ _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
prepare() {
cd $pkgname-$pkgver
# https://bugzilla.mozilla.org/show_bug.cgi?id=1233429
patch -Np1 -i ../firefox-disable-GMP-PDM.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1233340
patch -Np1 -i ../firefox-support-YUV420J-pixel-format.patch
cp ../mozconfig .mozconfig
patch -Np1 -i ../firefox-install-dir.patch

View file

@ -1,34 +0,0 @@
# HG changeset patch
# User Jean-Yves Avenard <jyavenard@mozilla.com>
Bug 1233429: Disable GMP PDM. r=cpearce
Prevent users from shooting themselves in the foot by turning some prefs on.
diff --git a/dom/media/platforms/PlatformDecoderModule.cpp b/dom/media/platforms/PlatformDecoderModule.cpp
index 530c7b9..50933ca 100644
--- a/dom/media/platforms/PlatformDecoderModule.cpp
+++ b/dom/media/platforms/PlatformDecoderModule.cpp
@@ -150,20 +150,22 @@ PlatformDecoderModule::Create()
}
return CreateAgnosticDecoderModule();
}
/* static */
already_AddRefed<PlatformDecoderModule>
PlatformDecoderModule::CreatePDM()
{
+#ifndef RELEASE_BUILD
if (sGMPDecoderEnabled) {
nsRefPtr<PlatformDecoderModule> m(new GMPDecoderModule());
return m.forget();
}
+#endif
#ifdef MOZ_WIDGET_ANDROID
if(sAndroidMCDecoderPreferred && sAndroidMCDecoderEnabled){
nsRefPtr<PlatformDecoderModule> m(new AndroidDecoderModule());
return m.forget();
}
#endif
if (sUseBlankDecoder) {
return CreateBlankDecoderModule();

View file

@ -1,34 +0,0 @@
# HG changeset patch
# User Jean-Yves Avenard <jyavenard@mozilla.com>
# Date 1450657258 -39600
# Node ID 8b0ced62c1957f6da6028af686c32ada1ccb570c
# Parent e1a98377eb38679bda820456ee6d20bdc17eaa8e
Bug 1233340: [ffmpeg] Support YUV420J pixel format. r=kentuckyfriedtakahe
YUV420J is 12bpp YUV420P.
diff --git a/dom/media/platforms/ffmpeg/FFmpegDataDecoder.cpp b/dom/media/platforms/ffmpeg/FFmpegDataDecoder.cpp
--- a/dom/media/platforms/ffmpeg/FFmpegDataDecoder.cpp
+++ b/dom/media/platforms/ffmpeg/FFmpegDataDecoder.cpp
@@ -52,17 +52,17 @@ FFmpegDataDecoder<LIBAV_VER>::~FFmpegDat
* For now, we just look for YUV420P as it is the only non-HW accelerated format
* supported by FFmpeg's H264 decoder.
*/
static PixelFormat
ChoosePixelFormat(AVCodecContext* aCodecContext, const PixelFormat* aFormats)
{
FFMPEG_LOG("Choosing FFmpeg pixel format for video decoding.");
for (; *aFormats > -1; aFormats++) {
- if (*aFormats == PIX_FMT_YUV420P) {
+ if (*aFormats == PIX_FMT_YUV420P || *aFormats == PIX_FMT_YUVJ420P) {
FFMPEG_LOG("Requesting pixel format YUV420P.");
return PIX_FMT_YUV420P;
}
}
NS_WARNING("FFmpeg does not share any supported pixel formats.");
return PIX_FMT_NONE;
}

View file

@ -30,7 +30,7 @@ ac_add_options --enable-system-pixman
# Features
ac_add_options --enable-startup-notification
ac_add_options --enable-pulseaudio
ac_add_options --enable-gstreamer=1.0
ac_add_options --disable-gstreamer
ac_add_options --disable-crashreporter
ac_add_options --disable-updater