mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/nodejs fix
This commit is contained in:
parent
1814c20a36
commit
268ee69bad
2 changed files with 13 additions and 13 deletions
|
@ -1,18 +1,18 @@
|
|||
From 5bbe0af1be3af18793e3062bfd4f26bd194af88a Mon Sep 17 00:00:00 2001
|
||||
From 3f38ac3e7066bac6874e63098d8d84c4ae96b6ed Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 13 Oct 2015 20:45:53 -0600
|
||||
Subject: [PATCH] arm fixes
|
||||
|
||||
---
|
||||
configure | 5 ++++-
|
||||
deps/v8/build/toolchain.gypi | 4 ++--
|
||||
configure | 5 ++++-
|
||||
deps/v8/gypfiles/toolchain.gypi | 4 ++--
|
||||
2 files changed, 6 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 00f20f7..464c7c8 100755
|
||||
index 9b4fa94..7c23fde 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -636,8 +636,11 @@ def configure_arm(o):
|
||||
@@ -718,8 +718,11 @@ def configure_arm(o):
|
||||
if is_arch_armv7():
|
||||
arm_fpu = 'vfpv3'
|
||||
o['variables']['arm_version'] = '7'
|
||||
|
@ -25,11 +25,11 @@ index 00f20f7..464c7c8 100755
|
|||
|
||||
o['variables']['arm_thumb'] = 0 # -marm
|
||||
o['variables']['arm_float_abi'] = arm_float_abi
|
||||
diff --git a/deps/v8/build/toolchain.gypi b/deps/v8/build/toolchain.gypi
|
||||
index a8a3b56..a03cd13 100644
|
||||
--- a/deps/v8/build/toolchain.gypi
|
||||
+++ b/deps/v8/build/toolchain.gypi
|
||||
@@ -203,7 +203,7 @@
|
||||
diff --git a/deps/v8/gypfiles/toolchain.gypi b/deps/v8/gypfiles/toolchain.gypi
|
||||
index 95eb1d9..6416a1e 100644
|
||||
--- a/deps/v8/gypfiles/toolchain.gypi
|
||||
+++ b/deps/v8/gypfiles/toolchain.gypi
|
||||
@@ -207,7 +207,7 @@
|
||||
}],
|
||||
[ 'arm_version==7 or arm_version=="default"', {
|
||||
'conditions': [
|
||||
|
@ -38,7 +38,7 @@ index a8a3b56..a03cd13 100644
|
|||
'cflags': ['-mfpu=<(arm_fpu)',],
|
||||
}],
|
||||
],
|
||||
@@ -246,7 +246,7 @@
|
||||
@@ -250,7 +250,7 @@
|
||||
}],
|
||||
[ 'arm_version==7 or arm_version=="default"', {
|
||||
'conditions': [
|
||||
|
@ -48,5 +48,5 @@ index a8a3b56..a03cd13 100644
|
|||
}],
|
||||
],
|
||||
--
|
||||
2.7.0
|
||||
2.10.0
|
||||
|
||||
|
|
|
@ -22,7 +22,7 @@ optdepends=('npm: nodejs package manager')
|
|||
source=("nodejs::git+https://github.com/nodejs/node.git#tag=v$pkgver"
|
||||
'0001-arm-fixes.patch')
|
||||
sha256sums=('SKIP'
|
||||
'eaeb2f55bd3390c50b8bb2bfe73131eb0fea20cccee88ed66331da93c1746fb6')
|
||||
'95815eb72175dba87056fb131b322fbc026a4c7537700c36824fff19b21b8e5a')
|
||||
|
||||
set_flags_for_arm() {
|
||||
if [ "$CARCH" == "arm" ]; then
|
||||
|
|
Loading…
Reference in a new issue