mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
alarm/v8 fixes
This commit is contained in:
parent
08607eebfc
commit
26f6aa713c
2 changed files with 13 additions and 25 deletions
alarm/v8
|
@ -1,26 +1,24 @@
|
|||
# $Id: PKGBUILD 62986 2012-01-30 06:42:07Z tdziedzic $
|
||||
# Maintainer: Kaiting Chen <kaitocracy@gmail.com>
|
||||
# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
|
||||
# Contributor: Kaiting Chen <kaitocracy@gmail.com>
|
||||
# Contributor: tocer <tocer.deng@gmail.com>
|
||||
# Contributor: WarheadsSE <max@warheads.net>
|
||||
|
||||
# older v8 for mongodb
|
||||
|
||||
pkgname=v8
|
||||
pkgver=3.16.4.1
|
||||
pkgrel=3
|
||||
pkgver=3.16.8.1
|
||||
pkgrel=1
|
||||
pkgdesc='Fast and modern javascript engine'
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://code.google.com/p/v8'
|
||||
license=('BSD')
|
||||
depends=('gcc-libs')
|
||||
makedepends=('subversion' 'python2')
|
||||
source=('v8.common.gypi.patch'
|
||||
http://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.bz2)
|
||||
#md5sums=('8051d31df84530df64752dafad9833b0')
|
||||
sha256sums=('774afb77874c04c5890173f553c6f6da83b3b848e1e6286f2af453163733420a'
|
||||
'74ab3bc11f6761e5108affcbe15bc673d2ecbe06aa38ea4b27d850321c0fdc2b')
|
||||
source=(http://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.bz2)
|
||||
sha256sums=('b99ffa913e8f00b8fdb3b58cadf2addbbf60549a5be8d12a6c0b7095a36ac7e0')
|
||||
|
||||
build() {
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
# _source="http://v8.googlecode.com/svn/tags/${pkgver}"
|
||||
# svn checkout "$_source" "${srcdir}/v8-${pkgver}"
|
||||
|
||||
|
@ -55,19 +53,19 @@ fi
|
|||
fi
|
||||
PATH="${srcdir}:$PATH";
|
||||
export PATH ;
|
||||
}
|
||||
|
||||
# patch build/common.gypi for VFPX selection @ hard.
|
||||
patch -p1 < ../v8.common.gypi.patch
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
# gets gyp
|
||||
make dependencies
|
||||
# make arm.release & arm.debug = just arm
|
||||
make arm.release library=shared snapshot=off vfp3=$VFP3 vfp=$VFP2
|
||||
make arm.release library=shared snapshot=off vfp3=$VFP3 vfp=$VFP2 werror=no
|
||||
# eo build
|
||||
|
||||
cd $srcdir && cp -r $pkgname-$pkgver d8-static-$pkgver
|
||||
cd d8-static-$pkgver
|
||||
make arm.release library=static snapshot=off vfp3=$VFP3 vfp=$VFP2
|
||||
make arm.release library=static snapshot=off vfp3=$VFP3 vfp=$VFP2 werror=no
|
||||
}
|
||||
|
||||
# seperated to possibly split v8-debug in the future.
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- a/build/common.gypi 2012-09-12 21:23:54.000000000 -0400
|
||||
+++ a/build/common.gypi 2012-09-12 21:35:57.000000000 -0400
|
||||
@@ -152,7 +152,6 @@
|
||||
[ 'v8_use_arm_eabi_hardfloat=="true"', {
|
||||
'defines': [
|
||||
'USE_EABI_HARDFLOAT=1',
|
||||
- 'CAN_USE_VFP2_INSTRUCTIONS',
|
||||
],
|
||||
'target_conditions': [
|
||||
['_toolset=="target"', {
|
Loading…
Reference in a new issue