extra/libvpx to 1.9.0-1

This commit is contained in:
Kevin Mihelich 2020-08-04 15:42:46 +00:00
parent b15430ae37
commit 271313a48c
2 changed files with 13 additions and 11 deletions

View file

@ -1,4 +1,4 @@
From aa08687c9d6a49b22909a88584d593f86e9e1a92 Mon Sep 17 00:00:00 2001
From fa4917057c9d5a55ed8b848c67d3a36378b3a9b9 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 15 Jan 2017 12:11:57 -0700
Subject: [PATCH] ARM fixes
@ -9,7 +9,7 @@ Subject: [PATCH] ARM fixes
2 files changed, 13 insertions(+), 10 deletions(-)
diff --git a/build/make/configure.sh b/build/make/configure.sh
index d05d0fa12a..ba5084b4bf 100644
index 206b54f775..2f4809a123 100644
--- a/build/make/configure.sh
+++ b/build/make/configure.sh
@@ -737,6 +737,14 @@ process_common_toolchain() {
@ -27,7 +27,7 @@ index d05d0fa12a..ba5084b4bf 100644
armv7*-hardfloat* | armv7*-gnueabihf | arm-*-gnueabihf)
tgt_isa=armv7
float_abi=hard
@@ -937,7 +945,7 @@ process_common_toolchain() {
@@ -941,7 +949,7 @@ process_common_toolchain() {
soft_enable neon
;;
armv7|armv7s)
@ -36,7 +36,7 @@ index d05d0fa12a..ba5084b4bf 100644
# Only enable neon_asm when neon is also enabled.
enabled neon && soft_enable neon_asm
# If someone tries to force it through, die.
@@ -957,13 +965,6 @@ process_common_toolchain() {
@@ -961,13 +969,6 @@ process_common_toolchain() {
arch_int=${arch_int%%te}
tune_cflags="-mtune="
if [ ${tgt_isa} = "armv7" ] || [ ${tgt_isa} = "armv7s" ]; then
@ -50,7 +50,7 @@ index d05d0fa12a..ba5084b4bf 100644
check_add_cflags -march=armv7-a -mfloat-abi=${float_abi}
check_add_asflags -march=armv7-a -mfloat-abi=${float_abi}
@@ -975,8 +976,8 @@ EOF
@@ -979,8 +980,8 @@ EOF
check_add_cflags -march=armv8-a
check_add_asflags -march=armv8-a
else
@ -62,7 +62,7 @@ index d05d0fa12a..ba5084b4bf 100644
enabled debug && add_asflags -g
diff --git a/configure b/configure
index 181e27b7c0..3ae0e3ba09 100755
index 32272ce36f..02bc560173 100755
--- a/configure
+++ b/configure
@@ -102,6 +102,8 @@ all_platforms="${all_platforms} arm64-darwin-gcc"
@ -75,5 +75,5 @@ index 181e27b7c0..3ae0e3ba09 100755
all_platforms="${all_platforms} armv7-darwin-gcc" #neon Cortex-A8
all_platforms="${all_platforms} armv7-linux-rvct" #neon Cortex-A8
--
2.23.0
2.26.0

View file

@ -7,21 +7,23 @@
# - disable neon and neon-asm
pkgname=libvpx
pkgver=1.8.2
pkgrel=2
pkgver=1.9.0
pkgrel=1
pkgdesc='VP8 and VP9 codec'
arch=(x86_64)
url=http://www.webmproject.org/
license=(BSD)
depends=(gcc-libs)
makedepends=(
git
nasm
)
provides=(libvpx.so)
source=(git+https://chromium.googlesource.com/webm/libvpx#tag=7ec7a33a081aeeb53fed1a8d87e4cbd189152527
_tag=6516e974f8c40d0e49b19a4b55b1c98e7432edbb
source=(git+https://chromium.googlesource.com/webm/libvpx#tag=${_tag}
0001-ARM-fixes.patch)
sha256sums=('SKIP'
'fde43bd72223854fe6d7aadd4b8d9947de902124fec01a5578ca12ca9436c810')
'65504659ca0fdc10b3ad8a82ad902aa97fd7a31f31377a217ca9538722961f22')
pkgver() {
cd libvpx