mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/vulkan-tools to 1.2.140-1
This commit is contained in:
parent
2d1845453c
commit
2740d824b0
2 changed files with 3 additions and 47 deletions
|
@ -1,36 +0,0 @@
|
||||||
From 8ee48dc62f7c0fc7b4dab7befc2f601b1873d620 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tony-LunarG <tony@lunarg.com>
|
|
||||||
Date: Thu, 7 May 2020 10:02:58 -0600
|
|
||||||
Subject: [PATCH] cube: Remove dependency on VK_DYNAMIC_STATE_RANGE_SIZE
|
|
||||||
|
|
||||||
Change-Id: Id6b3906d2605c4742ad0af45747fc37c23cab03e
|
|
||||||
Signed-off-by: Laurent Carlier <lordheavym@gmail.com>
|
|
||||||
---
|
|
||||||
cube/cube.c | 4 +++-
|
|
||||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/cube/cube.c b/cube/cube.c
|
|
||||||
index 602b4bdc..8c87b5c8 100644
|
|
||||||
--- a/cube/cube.c
|
|
||||||
+++ b/cube/cube.c
|
|
||||||
@@ -1974,6 +1974,8 @@ static void demo_prepare_fs(struct demo *demo) {
|
|
||||||
}
|
|
||||||
|
|
||||||
static void demo_prepare_pipeline(struct demo *demo) {
|
|
||||||
+#define NUM_DYNAMIC_STATES 2 /*Viewport + Scissor*/
|
|
||||||
+
|
|
||||||
VkGraphicsPipelineCreateInfo pipeline;
|
|
||||||
VkPipelineCacheCreateInfo pipelineCache;
|
|
||||||
VkPipelineVertexInputStateCreateInfo vi;
|
|
||||||
@@ -1983,7 +1985,7 @@ static void demo_prepare_pipeline(struct demo *demo) {
|
|
||||||
VkPipelineDepthStencilStateCreateInfo ds;
|
|
||||||
VkPipelineViewportStateCreateInfo vp;
|
|
||||||
VkPipelineMultisampleStateCreateInfo ms;
|
|
||||||
- VkDynamicState dynamicStateEnables[VK_DYNAMIC_STATE_RANGE_SIZE];
|
|
||||||
+ VkDynamicState dynamicStateEnables[NUM_DYNAMIC_STATES];
|
|
||||||
VkPipelineDynamicStateCreateInfo dynamicState;
|
|
||||||
VkResult U_ASSERT_ONLY err;
|
|
||||||
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
|
@ -4,7 +4,7 @@
|
||||||
# - cmake with -DBUILD_CUBE=OFF
|
# - cmake with -DBUILD_CUBE=OFF
|
||||||
|
|
||||||
pkgname=vulkan-tools
|
pkgname=vulkan-tools
|
||||||
pkgver=1.2.137
|
pkgver=1.2.140
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
url="https://www.khronos.org/vulkan/"
|
url="https://www.khronos.org/vulkan/"
|
||||||
|
@ -12,16 +12,8 @@ pkgdesc="Vulkan Utilities and Tools"
|
||||||
license=('custom')
|
license=('custom')
|
||||||
depends=(gcc-libs libxcb vulkan-icd-loader)
|
depends=(gcc-libs libxcb vulkan-icd-loader)
|
||||||
makedepends=(git cmake python vulkan-headers libx11 wayland)
|
makedepends=(git cmake python vulkan-headers libx11 wayland)
|
||||||
source=("https://github.com/KhronosGroup/Vulkan-Tools/archive/v${pkgver}.tar.gz"
|
source=("https://github.com/KhronosGroup/Vulkan-Tools/archive/v${pkgver}.tar.gz")
|
||||||
0001-cube-Remove-dependency-on-VK_DYNAMIC_STATE_RANGE_SIZ.patch)
|
sha256sums=('2e2c92914794408d2326cc2b0f37c70402a7ee81eecc75f90407b612cdd889e1')
|
||||||
sha256sums=('4b9e0aab8e873282a7163b3e9966928188c06697002f8f1ce0c567a06a1b5fda'
|
|
||||||
'8da2ac049c5e7d1253e5b55fa9ef0c1f670d17b6a0785561de5edc12e9c9d7a6')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd "${srcdir}"/Vulkan-Tools*
|
|
||||||
|
|
||||||
patch -Np1 -i ../0001-cube-Remove-dependency-on-VK_DYNAMIC_STATE_RANGE_SIZ.patch
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "${srcdir}"/Vulkan-Tools*
|
cd "${srcdir}"/Vulkan-Tools*
|
||||||
|
|
Loading…
Reference in a new issue