community/openimageio: fix

This commit is contained in:
Kevin Mihelich 2017-06-03 01:30:37 +00:00
parent d7c3c30a4e
commit 2794cd23bc
2 changed files with 41 additions and 5 deletions

View file

@ -3,7 +3,8 @@
# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - removed intel-tbb from deps, set -DUSE_TBB=0
# - removed intel-tbb from deps
# - patch to explicitly link against libatomic for v5/v6
pkgname=openimageio
pkgver=1.7.13
@ -16,8 +17,18 @@ depends=('openexr' 'boost-libs' 'jasper' 'glew' 'libtiff' 'opencolorio' 'openssl
makedepends=('cmake' 'qt4' 'python2' 'boost' 'mesa' 'git' 'freetype2' 'fontconfig' 'libxrender')
optdepends=('qt4: iv image viewer'
'python2: bindings support')
source=(git+git://github.com/OpenImageIO/oiio.git#tag=Release-${pkgver})
md5sums=('SKIP')
source=(git+git://github.com/OpenImageIO/oiio.git#tag=Release-${pkgver}
atomic.patch)
md5sums=('SKIP'
'883358fbfb7d156f92de3368adbdc488')
prepare() {
cd oiio
if [[ $CARCH == arm || $CARCH == armv6h ]]; then
patch -p1 -i ../atomic.patch
fi
}
build() {
cd oiio
@ -35,8 +46,7 @@ build() {
-DPYLIB3_INSTALL_DIR=lib/python3.6/site-packages \
-DOIIO_BUILD_TESTS=ON \
-DOIIO_BUILD_TOOLS=ON \
-DSTOP_ON_WARNING=OFF \
-DUSE_TBB=0
-DSTOP_ON_WARNING=OFF
make
}

View file

@ -0,0 +1,26 @@
diff --git a/src/libOpenImageIO/CMakeLists.txt b/src/libOpenImageIO/CMakeLists.txt
index cedb2f5b..98b8d1fc 100644
--- a/src/libOpenImageIO/CMakeLists.txt
+++ b/src/libOpenImageIO/CMakeLists.txt
@@ -100,7 +100,7 @@ endif ()
target_link_libraries (OpenImageIO
${VISIBILITY_COMMAND} ${VISIBILITY_MAP_COMMAND}
${format_plugin_libs} # Add all the target link libraries from the plugins
- ${Boost_LIBRARIES})
+ ${Boost_LIBRARIES} atomic)
# Include OpenColorIO if using it
diff --git a/src/libutil/CMakeLists.txt b/src/libutil/CMakeLists.txt
index cb00a42c..ef847c20 100644
--- a/src/libutil/CMakeLists.txt
+++ b/src/libutil/CMakeLists.txt
@@ -40,7 +40,7 @@ if (OIIO_BUILD_TESTS)
add_executable (atomic_test atomic_test.cpp)
set_target_properties (atomic_test PROPERTIES FOLDER "Unit Tests")
- target_link_libraries (atomic_test OpenImageIO_Util ${Boost_LIBRARIES} ${CMAKE_DL_LIBS})
+ target_link_libraries (atomic_test OpenImageIO_Util ${Boost_LIBRARIES} ${CMAKE_DL_LIBS} atomic)
add_test (unit_atomic atomic_test)
add_executable (array_view_test array_view_test.cpp)