core/openssl to 1.1.1.i-2

This commit is contained in:
Kevin Mihelich 2020-12-14 15:01:29 +00:00
parent 2d35e62883
commit 27c62fce69
2 changed files with 23 additions and 16 deletions

View file

@ -4,24 +4,26 @@
# - set ARM architecture targets
pkgname=openssl
_ver=1.1.1h
_ver=1.1.1i
# use a pacman compatible version scheme
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
pkgrel=1
pkgrel=2
pkgdesc='The Open Source toolkit for Secure Sockets Layer and Transport Layer Security'
arch=('x86_64')
url='https://www.openssl.org'
license=('custom:BSD')
depends=('perl')
optdepends=('ca-certificates')
depends=('glibc')
makedepends=('perl')
optdepends=('ca-certificates' 'perl')
replaces=('openssl-perl' 'openssl-doc')
backup=('etc/ssl/openssl.cnf')
source=("https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz"{,.asc}
'ca-dir.patch')
sha256sums=('5c9ca8774bd7b03e5784f26ae9e9e6d749c9da2438545077e6b3d755a06595d9'
'SKIP'
'0938c8d68110768db4f350a7ec641070686904f2fe7ba630ac94399d7dc8cc5e')
'ca-dir.patch')
sha256sums=('e8be6a35fe41d10603c3cc635e93289ed00bf34b79671a3a4de64fcee00d5242'
'SKIP'
'75aa8c2c638c8a3ebfd9fa146fc61c7ff878fc997dc6aa10d39e4b2415d669b2')
validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491'
'7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C')
'7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C')
prepare() {
cd "$srcdir/$pkgname-$_ver"
@ -58,11 +60,14 @@ build() {
}
check() {
cd "$srcdir/$pkgname-$_ver"
cd "$srcdir/$pkgbase-$_ver"
# the test fails due to missing write permissions in /etc/ssl
# revert this patch for make test
patch -p0 -R -i "$srcdir/ca-dir.patch"
make test
patch -p0 -i "$srcdir/ca-dir.patch"
# re-run make to re-generate CA.pl from th patched .in file.
make apps/CA.pl
@ -70,6 +75,8 @@ check() {
package() {
cd "$srcdir/$pkgname-$_ver"
make DESTDIR=$pkgdir MANDIR=/usr/share/man MANSUFFIX=ssl install_sw install_ssldirs install_man_docs
install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}

View file

@ -1,5 +1,5 @@
--- apps/CA.pl.in 2018-09-11 14:48:19.000000000 +0200
+++ apps/CA.pl.in 2018-09-11 16:16:32.125629435 +0200
--- apps/CA.pl.in 2019-09-10 15:13:07.000000000 +0200
+++ apps/CA.pl.in 2019-10-06 09:34:23.960864556 +0200
@@ -33,7 +33,7 @@
my $PKCS12 = "$openssl pkcs12";
@ -9,9 +9,9 @@
my $CAKEY = "cakey.pem";
my $CAREQ = "careq.pem";
my $CACERT = "cacert.pem";
--- apps/openssl.cnf 2018-09-11 14:48:20.000000000 +0200
+++ apps/openssl.cnf 2018-09-11 16:16:32.125629435 +0200
@@ -43,7 +43,7 @@
--- apps/openssl.cnf 2019-09-10 15:13:07.000000000 +0200
+++ apps/openssl.cnf 2019-10-06 09:34:23.960864556 +0200
@@ -42,7 +42,7 @@
####################################################################
[ CA_default ]
@ -20,7 +20,7 @@
certs = $dir/certs # Where the issued certs are kept
crl_dir = $dir/crl # Where the issued crl are kept
database = $dir/index.txt # database index file.
@@ -327,7 +327,7 @@
@@ -325,7 +325,7 @@
[ tsa_config1 ]
# These are used by the TSA reply generation only.