mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/mesa to 21.3.5-1.2
This commit is contained in:
parent
8b366946dd
commit
27e7575d0c
2 changed files with 4 additions and 81 deletions
|
@ -1,67 +0,0 @@
|
|||
From 23cbe6d5c1076551540159ce617ad0680b02a029 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 4 Feb 2019 17:54:45 -0700
|
||||
Subject: [PATCH] Rip out VC4 forced NEON
|
||||
|
||||
Breaks with distro-supplied CFLAGS.
|
||||
---
|
||||
meson.build | 1 -
|
||||
src/broadcom/meson.build | 5 +----
|
||||
src/gallium/drivers/vc4/meson.build | 11 -----------
|
||||
3 files changed, 1 insertion(+), 16 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 155db287796..ff703e8e631 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -1282,7 +1282,6 @@ elif host_machine.cpu_family() == 'x86_64'
|
||||
elif host_machine.cpu_family() == 'arm'
|
||||
if system_has_kms_drm
|
||||
with_asm_arch = 'arm'
|
||||
- pre_args += ['-DUSE_ARM_ASM']
|
||||
endif
|
||||
elif host_machine.cpu_family() == 'aarch64'
|
||||
if system_has_kms_drm
|
||||
diff --git a/src/broadcom/meson.build b/src/broadcom/meson.build
|
||||
index 2e1145dd0c0..c6266af9654 100644
|
||||
--- a/src/broadcom/meson.build
|
||||
+++ b/src/broadcom/meson.build
|
||||
@@ -50,12 +50,9 @@ foreach ver : v3d_versions
|
||||
)
|
||||
endforeach
|
||||
|
||||
-v3d_args = ['-DV3D_BUILD_NEON']
|
||||
+v3d_args = []
|
||||
|
||||
v3d_neon_c_args = []
|
||||
-if host_machine.cpu_family() == 'arm'
|
||||
- v3d_neon_c_args = '-mfpu=neon'
|
||||
-endif
|
||||
|
||||
libv3d_neon = static_library(
|
||||
'v3d_neon',
|
||||
diff --git a/src/gallium/drivers/vc4/meson.build b/src/gallium/drivers/vc4/meson.build
|
||||
index 90a772d5dc6..3074933584c 100644
|
||||
--- a/src/gallium/drivers/vc4/meson.build
|
||||
+++ b/src/gallium/drivers/vc4/meson.build
|
||||
@@ -84,17 +84,6 @@ files_libvc4 = files(
|
||||
vc4_c_args = []
|
||||
|
||||
libvc4_neon = []
|
||||
-if host_machine.cpu_family() == 'arm'
|
||||
- libvc4_neon = static_library(
|
||||
- 'vc4_neon',
|
||||
- 'vc4_tiling_lt_neon.c',
|
||||
- include_directories : [
|
||||
- inc_src, inc_include, inc_gallium, inc_gallium_aux, inc_broadcom
|
||||
- ],
|
||||
- c_args : '-mfpu=neon',
|
||||
- )
|
||||
- vc4_c_args += '-DUSE_ARM_ASM'
|
||||
-endif
|
||||
|
||||
if dep_simpenrose.found()
|
||||
vc4_c_args += '-DUSE_VC4_SIMULATOR'
|
||||
--
|
||||
2.30.0
|
||||
|
|
@ -6,30 +6,26 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - Removed DRI and Gallium3D drivers/packages for chipsets that don't exist in our ARM devices (intel, VMware svga).
|
||||
# - disable assembly and rip out VC4 forced NEON for v6/v7
|
||||
# - remove makedepend on valgrind, -Dvalgrind=false
|
||||
# - add PanVK driver
|
||||
# - added broadcom and panfrost vulkan packages
|
||||
|
||||
pkgbase=mesa
|
||||
pkgname=('vulkan-mesa-layers' 'opencl-mesa' 'vulkan-radeon' 'vulkan-swrast' 'vulkan-broadcom' 'vulkan-panfrost' 'libva-mesa-driver' 'mesa-vdpau' 'mesa')
|
||||
pkgdesc="An open-source implementation of the OpenGL specification"
|
||||
pkgver=21.3.5
|
||||
pkgrel=1.1
|
||||
pkgrel=1.2
|
||||
arch=('x86_64')
|
||||
makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence' 'libxxf86vm'
|
||||
'libxdamage' 'libvdpau' 'libva' 'wayland' 'wayland-protocols' 'zstd' 'elfutils' 'llvm'
|
||||
'libomxil-bellagio' 'libclc' 'clang' 'libglvnd' 'libunwind' 'lm_sensors' 'libxrandr'
|
||||
'glslang' 'vulkan-icd-loader' 'directx-headers' 'cmake' 'meson')
|
||||
'valgrind' 'glslang' 'vulkan-icd-loader' 'directx-headers' 'cmake' 'meson')
|
||||
url="https://www.mesa3d.org/"
|
||||
license=('custom')
|
||||
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
|
||||
0001-iris-implement-inter-context-busy-tracking.patch
|
||||
0001-Rip-out-VC4-forced-NEON.patch
|
||||
LICENSE)
|
||||
sha512sums=('417d1787f8177567f0c547dde3e24212f7497f2fe7cdaa945fe998cd61ec0e9eb9388feb444e377c4fd8794b056af02aac28d1bbfb9527844391ba49e6893933'
|
||||
'SKIP'
|
||||
'f9ef0f9785568000360678be719c98d49a270e9b5657245ae62d8f93f2df63f5afb7c5d0c05996c963eb7f32fe3486e851b3df10979d587a0d207abaf961bc58'
|
||||
'4cd472e3db19b658265cbbeae6b23be6b5bbf54380c64963f867aa3991de4700b48aae23718283aae4608e8e73627a0103862adbbae9ce17a00a266e425e948c'
|
||||
'f9f0d0ccf166fe6cb684478b6f1e1ab1f2850431c06aa041738563eb1808a004e52cdec823c103c9e180f03ffc083e95974d291353f0220fe52ae6d4897fecc7')
|
||||
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
|
||||
'946D09B5E4C9845E63075FF1D961C596A7203456' # Andres Gomez <tanty@igalia.com>
|
||||
|
@ -43,16 +39,10 @@ prepare() {
|
|||
|
||||
# FS#73501
|
||||
patch -Np1 -i ../0001-iris-implement-inter-context-busy-tracking.patch
|
||||
|
||||
if [[ $CARCH != "aarch64" ]]; then
|
||||
patch -p1 -i ../0001-Rip-out-VC4-forced-NEON.patch
|
||||
CPPFLAGS+=" -DNO_FORMAT_ASM"
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
case "${CARCH}" in
|
||||
armv6h) GALLIUM=",vc4" ;;
|
||||
armv7h) GALLIUM=",etnaviv,kmsro,lima,panfrost,tegra,v3d,vc4" ;;
|
||||
aarch64) GALLIUM=",etnaviv,kmsro,lima,panfrost,v3d,vc4" ;;
|
||||
esac
|
||||
|
@ -86,7 +76,7 @@ build() {
|
|||
-D osmesa=true \
|
||||
-D shared-glapi=enabled \
|
||||
-D microsoft-clc=disabled \
|
||||
-D valgrind=disabled
|
||||
-D valgrind=enabled
|
||||
|
||||
# Print config
|
||||
meson configure build
|
||||
|
|
Loading…
Reference in a new issue