alarm/kodi-rpi to 20.5-2

This commit is contained in:
graysky 2024-03-04 19:57:23 -05:00
parent f1eab0a347
commit 28199b43cd
2 changed files with 58 additions and 2 deletions

View file

@ -0,0 +1,51 @@
From e32ddfda63944ef786b3a3ddea243dc0ed2f4c11 Mon Sep 17 00:00:00 2001
From: graysky <graysky@archlinux.us>
Date: Fri, 7 Jan 2022 10:22:22 -0500
Subject: [PATCH] ffmpeg: build with lto when -DUSE_LTO=ON
I do not believe the internal ffmpeg build uses LTO if the user calls for it
via -DUSE_LTO=ON. This commit passes --enable-lto to ffmpeg's configure script
if CMAKE has CMAKE_INTERPROCEDURAL_OPTIMIZATION set which -DUSE_LTO=ON does.
The original author of this, loqs, points this out here[1].
1. https://bugs.archlinux.org/task/69333#comment196255
---
cmake/modules/FindFFMPEG.cmake | 5 +++++
tools/depends/target/ffmpeg/CMakeLists.txt | 4 ++++
2 files changed, 9 insertions(+)
diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
index 13c810591b..5f0c596cb7 100644
--- a/cmake/modules/FindFFMPEG.cmake
+++ b/cmake/modules/FindFFMPEG.cmake
@@ -55,6 +55,11 @@ macro(buildFFMPEG)
-DOS=${OS}
-DCMAKE_AR=${CMAKE_AR})
endif()
+
+ if(USE_LTO)
+ list(APPEND FFMPEG_OPTIONS -DUSE_LTO=ON)
+ endif()
+
set(LINKER_FLAGS ${CMAKE_EXE_LINKER_FLAGS})
list(APPEND LINKER_FLAGS ${SYSTEM_LDFLAGS})
diff --git a/tools/depends/target/ffmpeg/CMakeLists.txt b/tools/depends/target/ffmpeg/CMakeLists.txt
index 1bf9f53499..d438449888 100644
--- a/tools/depends/target/ffmpeg/CMakeLists.txt
+++ b/tools/depends/target/ffmpeg/CMakeLists.txt
@@ -126,6 +126,10 @@ if(CPU MATCHES x86 OR CPU MATCHES x86_64)
list(APPEND ffmpeg_conf --x86asmexe=${NASM_EXECUTABLE})
endif()
+if(USE_LTO)
+ list(APPEND ffmpeg_conf --enable-lto)
+endif()
+
if(ENABLE_DAV1D)
list(APPEND ffmpeg_conf --enable-libdav1d)
set(pkgconf_path "PKG_CONFIG_PATH=${PKG_CONFIG_PATH}")
--
2.44.0

View file

@ -7,6 +7,8 @@
# Contributor WarheadsSE <max@warheads.net>
# Contributor Adrian Fedoreanu <adrian [dot] fedoreanu [at] gmail [dot] com>
highmem=1
pkgbase=kodi-rpi
pkgname=(
'kodi-rpi'
@ -21,7 +23,7 @@ _commit=8ff17bbfc65c9b3c1923e85c4b40e5033aceebcc
_clangbuild=
pkgver=20.5
pkgrel=1
pkgrel=2
arch=('aarch64' 'armv7h')
url="https://github.com/graysky2/xbmc/tree/gs-gbm_nexus"
license=('GPL2')
@ -68,6 +70,7 @@ source=(
"ArchARM-kodi-init-v$_init_version.tar.gz::https://github.com/graysky2/kodi-standalone-service/archive/v$_init_version.tar.gz"
kodi.config.txt
0001-ffmpeg-update-for-official-5.1.4.patch
0002-ffmpeg-build-with-lto-when-DUSE_LTO-ON.patch
flatbuffers-23.3.3.patch::https://github.com/xbmc/xbmc/commit/35be40daa39965a9ea5b3569eb7d515e6a14da5d.patch
pr23703.patch::https://patch-diff.githubusercontent.com/raw/xbmc/xbmc/pull/23703.patch
https://github.com/xbmc/xbmc/pull/23227.patch
@ -95,6 +98,7 @@ sha256sums=('c57658cf04c18556fa7a60a9ec26cd8630da39438cf5f2e822395a47240162a1'
'8f8ab84a0cf3bd382edb118e475b336ca2fe1e1d4da3ad8e4637f8278ed9179c'
'9ba55fd29b3ef64de3869b092493a233eeb83a23d5ae378299ef9d335f271123'
'9dd3923d87f645ed31d37bca6cd791798d7a486335e952dd09b8076bb4c1908b'
'9d2d52787abf59ceaf116e5d9e7b2ed33ce789d74766c9e407da34e86c796999'
'ea7a409c4e260bd8f4f949cbd02b7a6609ac0ec5a6920b405abc63ec1a3e312b'
'41ed62f58f531ee65278eba2c05411c8948957989c6a21af4e19ca2623d5c03c'
'c0570dfddbd42a88446695ec4af38f6cf8a5a99f95210eeefb596c155a18f9d9')
@ -107,6 +111,7 @@ prepare() {
rm -rf system/certs # remove not needed cacert
patch -p1 -i ../0001-ffmpeg-update-for-official-5.1.4.patch
patch -p1 -i ../0002-ffmpeg-build-with-lto-when-DUSE_LTO-ON.patch
# use flatbuffers 23.3.3
patch -p1 -i ../flatbuffers-23.3.3.patch
@ -152,7 +157,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release
-DCMAKE_INSTALL_PREFIX=/usr
-DCMAKE_INSTALL_LIBDIR=/usr/lib
-DUSE_LTO=OFF
-DUSE_LTO=ON
-DVERBOSE=ON
-DENABLE_LDGOLD=OFF
-DENABLE_AIRTUNES=ON