communtiy/docker to 1.5.0-1

This commit is contained in:
Jason Plum 2015-02-10 21:17:22 -05:00
parent 324921051c
commit 285031f238
2 changed files with 3 additions and 19 deletions

View file

@ -1,13 +0,0 @@
--- a/daemon/daemon.go 2014-08-28 21:22:18.805001026 -0400
+++ b/daemon/daemon.go 2014-08-28 21:23:52.030001071 -0400
@@ -1095,10 +1095,6 @@ func (daemon *Daemon) ImageGetCached(img
}
func checkKernelAndArch() error {
- // Check for unsupported architectures
- if runtime.GOARCH != "amd64" {
- return fmt.Errorf("The Docker runtime currently only supports amd64 (not %s). This will change in the future. Aborting.", runtime.GOARCH)
- }
// Check for unsupported kernel versions
// FIXME: it would be cleaner to not test for specific versions, but rather
// test for specific functionalities.

View file

@ -5,7 +5,7 @@
# ALARM: Jason Plum <jplum@archlinuxarm.org>
pkgname=docker
pkgver=1.4.1
pkgver=1.5.0
pkgrel=1
epoch=1
pkgdesc='Pack, ship and run any application as a lightweight container'
@ -19,14 +19,11 @@ optdepends=('btrfs-progs: btrfs backend support'
# don't strip binaries! A sha1 is used to check binary consistency.
options=('!strip')
install=$pkgname.install
source=("git+https://github.com/docker/docker.git#tag=v$pkgver"
"0001-daemon-no-arch-check.patch")
md5sums=('SKIP'
'6746a788096a02829666c67bece899d5')
source=("git+https://github.com/docker/docker.git#tag=v$pkgver")
md5sums=('SKIP')
build() {
cd docker
patch -p1 < $srcdir/0001-daemon-no-arch-check.patch
export AUTO_GOPATH=1
./hack/make.sh dynbinary
}