mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
removed extra/qt5-webkit-ng
This commit is contained in:
parent
e884316701
commit
287bdfcf7f
4 changed files with 0 additions and 148 deletions
|
@ -1,58 +0,0 @@
|
|||
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - disable jit on v5/v6
|
||||
|
||||
pkgname=qt5-webkit-ng
|
||||
_qtver=5.212.0
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=1
|
||||
arch=(x86_64)
|
||||
url='https://github.com/annulen/webkit/wiki'
|
||||
license=(GPL3 LGPL3 FDL custom)
|
||||
pkgdesc='Classes for a WebKit2 based implementation and a new QML API (maintained fork)'
|
||||
depends=(qt5-location qt5-sensors qt5-webchannel libwebp libxslt libxcomposite gst-plugins-base hyphen)
|
||||
makedepends=(cmake ruby gperf python2 qt5-doc qt5-tools)
|
||||
optdepends=('gst-plugins-good: Webm codec support')
|
||||
conflicts=(qt5-webkit)
|
||||
provides=(qt5-webkit)
|
||||
source=("https://github.com/annulen/webkit/archive/qtwebkit-$pkgver-alpha.tar.gz"
|
||||
qt5-webkit-icu59.patch qt5-webkit-ng-gcc7.patch qt5-webkit-ng-functional.patch)
|
||||
sha256sums=('bf8637ad44efd781893c60a932256f435f538bea63333a7f438b897500044d98'
|
||||
'e1306e696ad7125fa00083aa966be0ea6fe6de555c9e1d119957f208f258edfe'
|
||||
'58ecbd8708f5afe4e974fdcd6c1f32fea61ccc55dc9bb711768f2d0da6963fb8'
|
||||
'c85344edcc23930c0190b2f8ec3847bf8bdbbf7f1d4fa877c502e354e5f4233e')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
||||
cd webkit-qtwebkit-$pkgver-alpha
|
||||
# Fix build with ICU 59 (PLD linux)
|
||||
patch -p1 -i ../qt5-webkit-icu59.patch
|
||||
# Fix build with GCC 7
|
||||
patch -p1 -i ../qt5-webkit-ng-gcc7.patch
|
||||
patch -p1 -i ../qt5-webkit-ng-functional.patch
|
||||
|
||||
sed -e 's|-Wundef|-Wundef -Wno-expansion-to-defined|' -i Source/cmake/WebKitHelpers.cmake
|
||||
}
|
||||
|
||||
build() {
|
||||
cd build
|
||||
|
||||
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && CONFIG="-DENABLE_JIT=OFF"
|
||||
|
||||
cmake ../webkit-qtwebkit-$pkgver-alpha \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DPORT=Qt \
|
||||
-DENABLE_TOOLS=OFF $CONFIG
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd build
|
||||
make DESTDIR="$pkgdir" install
|
||||
|
||||
install -d "$pkgdir"/usr/share/licenses
|
||||
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}
|
||||
}
|
|
@ -1,38 +0,0 @@
|
|||
--- qtwebkit-opensource-src-5.5.1/Source/JavaScriptCore/API/JSStringRef.h.orig 2015-10-13 06:37:10.000000000 +0200
|
||||
+++ qtwebkit-opensource-src-5.5.1/Source/JavaScriptCore/API/JSStringRef.h 2017-04-24 12:26:42.495345570 +0200
|
||||
@@ -32,6 +32,7 @@
|
||||
#include <stdbool.h>
|
||||
#endif
|
||||
#include <stddef.h> /* for size_t */
|
||||
+#include <uchar.h>
|
||||
|
||||
#ifdef __cplusplus
|
||||
extern "C" {
|
||||
@@ -43,7 +44,7 @@
|
||||
@typedef JSChar
|
||||
@abstract A Unicode character.
|
||||
*/
|
||||
- typedef unsigned short JSChar;
|
||||
+ typedef char16_t JSChar;
|
||||
#else
|
||||
typedef wchar_t JSChar;
|
||||
#endif
|
||||
--- qtwebkit-opensource-src-5.5.1/Source/WebKit2/Shared/API/c/WKString.h.orig 2015-10-13 06:37:12.000000000 +0200
|
||||
+++ qtwebkit-opensource-src-5.5.1/Source/WebKit2/Shared/API/c/WKString.h 2017-04-24 12:27:33.432011867 +0200
|
||||
@@ -31,6 +31,7 @@
|
||||
#ifndef __cplusplus
|
||||
#include <stdbool.h>
|
||||
#endif
|
||||
+#include <uchar.h>
|
||||
|
||||
#ifdef __cplusplus
|
||||
extern "C" {
|
||||
@@ -38,7 +39,7 @@
|
||||
|
||||
#if !defined(WIN32) && !defined(_WIN32) \
|
||||
&& !((defined(__CC_ARM) || defined(__ARMCC__)) && !defined(__linux__)) /* RVCT */
|
||||
- typedef unsigned short WKChar;
|
||||
+ typedef char16_t WKChar;
|
||||
#else
|
||||
typedef wchar_t WKChar;
|
||||
#endif
|
|
@ -1,40 +0,0 @@
|
|||
--- webkit-qtwebkit-tp5/Source/JavaScriptCore/inspector/InspectorBackendDispatcher.h.orig 2017-06-01 06:14:55.587195469 +0000
|
||||
+++ webkit-qtwebkit-tp5/Source/JavaScriptCore/inspector/InspectorBackendDispatcher.h 2017-06-01 06:15:23.040491577 +0000
|
||||
@@ -32,6 +32,7 @@
|
||||
#include <wtf/Optional.h>
|
||||
#include <wtf/RefCounted.h>
|
||||
#include <wtf/text/WTFString.h>
|
||||
+#include <functional>
|
||||
|
||||
namespace Inspector {
|
||||
|
||||
--- webkit-qtwebkit-tp5/Source/WebCore/css/CSSValue.h.orig 2017-06-01 07:48:18.099623726 +0000
|
||||
+++ webkit-qtwebkit-tp5/Source/WebCore/css/CSSValue.h 2017-06-01 07:48:41.542925091 +0000
|
||||
@@ -27,6 +27,7 @@
|
||||
#include <wtf/RefCounted.h>
|
||||
#include <wtf/RefPtr.h>
|
||||
#include <wtf/TypeCasts.h>
|
||||
+#include <functional>
|
||||
|
||||
namespace WebCore {
|
||||
|
||||
--- webkit-qtwebkit-tp5/Source/WebCore/css/StyleSheetContents.h.orig 2017-06-01 08:33:31.792577087 +0000
|
||||
+++ webkit-qtwebkit-tp5/Source/WebCore/css/StyleSheetContents.h 2017-06-01 08:33:44.715892348 +0000
|
||||
@@ -30,6 +30,7 @@
|
||||
#include <wtf/Vector.h>
|
||||
#include <wtf/text/AtomicStringHash.h>
|
||||
#include <wtf/text/TextPosition.h>
|
||||
+#include <functional>
|
||||
|
||||
namespace WebCore {
|
||||
|
||||
--- webkit-qtwebkit-tp5/Source/WebCore/loader/ResourceLoader.h.orig 2017-06-01 09:47:50.463011889 +0000
|
||||
+++ webkit-qtwebkit-tp5/Source/WebCore/loader/ResourceLoader.h 2017-06-01 09:48:21.976300680 +0000
|
||||
@@ -35,6 +35,7 @@
|
||||
#include "ResourceRequest.h"
|
||||
#include "ResourceResponse.h"
|
||||
#include <wtf/Forward.h>
|
||||
+#include <functional>
|
||||
|
||||
namespace WTF {
|
||||
class SchedulePair;
|
|
@ -1,12 +0,0 @@
|
|||
Index: /trunk/Source/JavaScriptCore/runtime/JSArrayBufferView.h
|
||||
===================================================================
|
||||
--- trunk/Source/JavaScriptCore/runtime/JSArrayBufferView.h (revision 211433)
|
||||
+++ trunk/Source/JavaScriptCore/runtime/JSArrayBufferView.h (revision 211434)
|
||||
@@ -168,5 +168,5 @@
|
||||
void neuter();
|
||||
|
||||
- void* vector()
|
||||
+ void* vector() const
|
||||
{
|
||||
return m_vector.getPredicated(
|
||||
this,
|
Loading…
Reference in a new issue